Bug 136877 - New Port: biology/phyml A simple, fast, and accurate algorithm to estimate large phylogenies
Summary: New Port: biology/phyml A simple, fast, and accurate algorithm to estimate la...
Status: Closed FIXED
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: Normal Affects Only Me
Assignee: Dmitry Marakasov
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2009-07-17 22:20 UTC by Ben Allen
Modified: 2009-07-21 02:20 UTC (History)
0 users

See Also:


Attachments
file.shar (3.49 KB, text/plain)
2009-07-17 22:20 UTC, Ben Allen
no flags Details
phyml.shar (3.89 KB, application/octet-stream; x-unix-mode=0644)
2009-07-20 21:26 UTC, ben
no flags Details

Note You need to log in before you can comment on or make changes to this bug.
Description Ben Allen 2009-07-17 22:20:01 UTC
PhyML is a software that estimates maximum likelihood phylogenies from 
alignments of nucleotide or amino acid sequences. It provides a wide range of
options that were designed to facilitate standard phylogenetic analyses. The
main strengths of PhyML lies in the large number of substitution models coupled
to various options to search the space of phylogenetic tree topologies, going
from very fast and efficient methods to slower but generally more accurate
approaches. It also implements two methods to evaluate branch supports in a
sound statistical framework (the non-parametric bootstrap and the approximate
likelihood ratio test). PhyML was designed to process moderate to large data
sets. In theory, alignments with up to 4,000 sequences 2,000,000 character-long
can analyzed. In practice however, the amount of memory required to process a
data set is proportional of the product of the number of sequences by their
length. Hence, a large number of sequences can only be processed provided that
they are short. Also, PhyML can handle long sequences provided that they are
not numerous. With most standard personal computers, the "comfort zone" for
PhyML generally lies around 3 to 500 sequences less than 2,000 character long.

Fix: See attached shar.

Patch attached with submission follows:
Comment 1 Dmitry Marakasov freebsd_committer 2009-07-18 00:10:52 UTC
Responsible Changed
From-To: freebsd-ports-bugs->amdmi3

I'll take it.
Comment 2 Dmitry Marakasov freebsd_committer 2009-07-20 17:01:41 UTC
State Changed
From-To: open->feedback

Does not build (http://people.freebsd.org/~amdmi3/phyml-20090706.log), 
apparently because it misses depends on autotools. You should use 
USE_AUTOTOOLS instead (this both depend on and call autotools for you). 
In either case, don't use scripts/.
Comment 3 ben 2009-07-20 21:26:06 UTC
Here is a new version using USE_AUTOTOOLS. Let me know if there is any  
other best practices that I've missed. See attached shar.
Comment 4 Dmitry Marakasov freebsd_committer 2009-07-21 02:09:43 UTC
State Changed
From-To: feedback->open

Submitter has fixed.
Comment 5 Dmitry Marakasov freebsd_committer 2009-07-21 02:10:18 UTC
State Changed
From-To: open->closed

New port added, with minor changes. Thanks!
Comment 6 dfilter service freebsd_committer 2009-07-21 02:10:24 UTC
amdmi3      2009-07-21 01:10:13 UTC

  FreeBSD ports repository

  Modified files:
    biology              Makefile 
  Added files:
    biology/phyml        Makefile distinfo pkg-descr 
    biology/phyml/files  patch-src-configure 
                         patch-src-configure.ac 
  Log:
  PhyML is a software that estimates maximum likelihood phylogenies from
  alignments of nucleotide or amino acid sequences. It provides a wide range of
  options that were designed to facilitate standard phylogenetic analyses. The
  main strengths of PhyML lies in the large number of substitution models coupled
  to various options to search the space of phylogenetic tree topologies, going
  from very fast and efficient methods to slower but generally more accurate
  approaches. It also implements two methods to evaluate branch supports in a
  sound statistical framework (the non-parametric bootstrap and the approximate
  likelihood ratio test). PhyML was designed to process moderate to large data
  sets. In theory, alignments with up to 4,000 sequences 2,000,000 character-long
  can analyzed. In practice however, the amount of memory required to process a
  data set is proportional of the product of the number of sequences by their
  length. Hence, a large number of sequences can only be processed provided that
  they are short. Also, PhyML can handle long sequences provided that they are
  not numerous. With most standard personal computers, the "comfort zone" for
  PhyML generally lies around 3 to 500 sequences less than 2,000 character long.
  
  WWW: http://code.google.com/p/phyml/
  
  PR:             136877
  Submitted by:   Ben Allen <ben@sysadminschronicles.com>
  
  Revision  Changes    Path
  1.111     +1 -0      ports/biology/Makefile
  1.1       +31 -0     ports/biology/phyml/Makefile (new)
  1.1       +3 -0      ports/biology/phyml/distinfo (new)
  1.1       +11 -0     ports/biology/phyml/files/patch-src-configure (new)
  1.1       +11 -0     ports/biology/phyml/files/patch-src-configure.ac (new)
  1.1       +18 -0     ports/biology/phyml/pkg-descr (new)
_______________________________________________
cvs-all@freebsd.org mailing list
http://lists.freebsd.org/mailman/listinfo/cvs-all
To unsubscribe, send any mail to "cvs-all-unsubscribe@freebsd.org"