Bug 137402 - Updates to math/octave-forge ports
Updates to math/octave-forge ports
Status: Closed FIXED
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s)
Latest
Any Any
: Normal Affects Only Me
Assigned To: dhn
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2009-08-03 22:50 UTC by stephen
Modified: 2009-08-23 18:30 UTC (History)
0 users

See Also:


Attachments
file.diff (14.10 KB, patch)
2009-08-03 22:50 UTC, stephen
no flags Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description stephen 2009-08-03 22:50:03 UTC
Octave has been updated to 3.2.2.  The octave forge ports have to be updated
accordingly.

Some of the ports now have to be marked broken, unfortunately.

Fix: PLEASE REMOVE math/octave-forge-image/files.
PLEASE REMOVE math/octave-forge-windows.

Add the port math/octave-forge-quaternion (sh file provided).

Apply the diffs (diff file provided).


# This is a shell archive.  Save it in a file, remove anything before
# this line, and then unpack it by entering "sh file".  Note, it may
# create directories; files and directories will be owned by you and
# have default permissions.
#
# This archive contains:
#
#	octave-forge-quaternion
#	octave-forge-quaternion/Makefile
#	octave-forge-quaternion/distinfo
#	octave-forge-quaternion/pkg-descr
#	octave-forge-quaternion/pkg-plist
#
echo c - octave-forge-quaternion
mkdir -p octave-forge-quaternion > /dev/null 2>&1
echo x - octave-forge-quaternion/Makefile
sed 's/^X//' >octave-forge-quaternion/Makefile << 'bbc1f1d841fcdab4c0ab388e7974dc15'
X# New ports collection makefile for:	octave-forge-quaternion
X# Date created:		3 August 2009
X# Whom:			Stephen Montgomery-Smith <stephen@math.missouri.edu>
X#
X# $FreeBSD: ports/math/octave-forge-quaternion/Makefile,v 1.6 2009/07/31 13:53:38 dinoex Exp $
X#
X
XPORTNAME=	octave-forge-quaternion
XPORTVERSION=	1.0.0
XCATEGORIES=	math
X
XMAINTAINER=	stephen@missouri.edu
XCOMMENT=	Octave-forge package ${OCTAVE_PKGNAME}
X
X.include <bsd.port.pre.mk>
X.include "${PORTSDIR}/Mk/bsd.octave.mk"
X.include <bsd.port.post.mk>
bbc1f1d841fcdab4c0ab388e7974dc15
echo x - octave-forge-quaternion/distinfo
sed 's/^X//' >octave-forge-quaternion/distinfo << 'c43d3b9f7068595899b064797ac937e0'
XMD5 (octave-forge/quaternion-1.0.0.tar.gz) = 9bd5bf6b608eb6703ac8c4edcb07377e
XSHA256 (octave-forge/quaternion-1.0.0.tar.gz) = 4fef5360ffa77a93c626326cc9eff91ddb707964b215a0305201d080eb07b16c
XSIZE (octave-forge/quaternion-1.0.0.tar.gz) = 92644
c43d3b9f7068595899b064797ac937e0
echo x - octave-forge-quaternion/pkg-descr
sed 's/^X//' >octave-forge-quaternion/pkg-descr << 'eac413d2ad8776a1b93f841617800b2f'
XThe octave-forge package is the result of The GNU Octave Repositry project,
Xwhich is intended to be a central location for custom scripts, functions and
Xextensions for GNU Octave. contains the source for all the functions plus
Xbuild and install scripts.
X
XThis is quaternion.
X
X Package for the manipulation of Quaternion's used for frame transformation.
X
XWWW: http://octave.sourceforge.net/
eac413d2ad8776a1b93f841617800b2f
echo x - octave-forge-quaternion/pkg-plist
sed 's/^X//' >octave-forge-quaternion/pkg-plist << '13215c6301de910d57d6595aed05f567'
X@comment This file intentionally left empty
13215c6301de910d57d6595aed05f567
exit
Comment 1 Martin Wilke freebsd_committer 2009-08-04 00:30:08 UTC
Responsible Changed
From-To: freebsd-ports-bugs->miwi

I'll take it.
Comment 2 Martin Wilke freebsd_committer 2009-08-07 16:28:30 UTC
State Changed
From-To: open->feedback


Hi 

Some builds failed :( 

http://32bit.miwibox.org/index.php?action=failed_buildports&maintainer=stephen%40missouri.edu&Go=Go 
http://64bit.miwibox.org/index.php?action=failed_buildports&maintainer=stephen%40missouri.edu&Go=Go 

could you please take a look? 

thx
Comment 3 Martin Wilke freebsd_committer 2009-08-07 16:51:34 UTC
Responsible Changed
From-To: miwi->dhn

over to dhn, i don't have time to fi
Comment 4 stephen 2009-08-12 04:42:22 UTC
I was looking at 
http://tb.4bit.ws/index.php?action=list_buildports&build=6-FreeBSD_I386&search_port_name=octave-forge&Go=Go

The patch in octave-forge-image still needs to be removed.

All the other ports that didn't build have been marked "broken".
Comment 5 stephen 2009-08-14 20:57:05 UTC
I haven't heard back for a while.

I was looking at 
http://pointyhat.freebsd.org/errorlogs/amd64-errorlogs/e.6.20090810220749/octave-forge-ad-1.0.6_1.log 
and it shows an error (quoted below) that I am unable to reproduce.  I 
was told that this is an error that is tinderbox specific.  Can you send 
me details about this?  I was sent a fix to bsd.octave.mk that is not 
workable.

The whole octave-forge ports collection have just been marked "BROKEN" 
(via a patch to bsd.octave.mk) and I am concerned.

Here is the error:

octave -H -q --no-site-file --eval 
"pkg('install','/usr/local/share/octave/tarballs/ad-1.0.6.tar.gz')"
warning: load_path: /usr/local/share/octave/packages/ad-1.0.6: No such 
file or directory
fwrite: invalid stream number = -1
error: called from `__makeinfo__' in file 
/usr/local/share/octave/3.2.2/m/help/__makeinfo__.m near line 128, column 5
error: called from:
error:   /usr/local/share/octave/3.2.2/m/pkg/pkg.m at line 756, column 5
error:   /usr/local/share/octave/3.2.2/m/pkg/pkg.m at line 287, column 7
*** Error code 1
Comment 6 dfilter freebsd_committer 2009-08-23 17:49:58 UTC
dhn         2009-08-23 16:49:50 UTC

  FreeBSD ports repository

  Modified files:
    math/octave-forge-ann Makefile 
    math/octave-forge-fixed Makefile 
    math/octave-forge-ftp Makefile 
    math/octave-forge-graceplot Makefile 
    math/octave-forge-parallel Makefile 
    math/octave-forge-triangular Makefile 
    math/octave-forge-vrml Makefile 
  Log:
  - Mark BROKEN with octave-3.2.2
  
  PR:             ports/137402
  Submitted by:   Stephen Montgomery-Smith <stephen@missouri.edu>
  
  Revision  Changes    Path
  1.6       +2 -0      ports/math/octave-forge-ann/Makefile
  1.5       +2 -0      ports/math/octave-forge-fixed/Makefile
  1.6       +2 -0      ports/math/octave-forge-ftp/Makefile
  1.7       +2 -0      ports/math/octave-forge-graceplot/Makefile
  1.6       +2 -0      ports/math/octave-forge-parallel/Makefile
  1.5       +2 -0      ports/math/octave-forge-triangular/Makefile
  1.7       +2 -0      ports/math/octave-forge-vrml/Makefile
_______________________________________________
cvs-all@freebsd.org mailing list
http://lists.freebsd.org/mailman/listinfo/cvs-all
To unsubscribe, send any mail to "cvs-all-unsubscribe@freebsd.org"
Comment 7 dfilter freebsd_committer 2009-08-23 17:50:18 UTC
dhn         2009-08-23 16:50:00 UTC

  FreeBSD ports repository

  Modified files:
    math/octave-forge-octcdf Makefile distinfo 
  Log:
  - Update to 1.0.13
  
  PR:             ports/137402
  Submitted by:   Stephen Montgomery-Smith <stephen@missouri.edu>
  
  Revision  Changes    Path
  1.6       +1 -2      ports/math/octave-forge-octcdf/Makefile
  1.3       +3 -3      ports/math/octave-forge-octcdf/distinfo
_______________________________________________
cvs-all@freebsd.org mailing list
http://lists.freebsd.org/mailman/listinfo/cvs-all
To unsubscribe, send any mail to "cvs-all-unsubscribe@freebsd.org"
Comment 8 dfilter freebsd_committer 2009-08-23 17:50:33 UTC
dhn         2009-08-23 16:50:06 UTC

  FreeBSD ports repository

  Modified files:
    math/octave-forge-linear-algebra Makefile distinfo 
  Log:
  - Update to 1.0.8
  
  PR:             ports/137402
  Submitted by:   Stephen Montgomery-Smith <stephen@missouri.edu>
  
  Revision  Changes    Path
  1.6       +1 -2      ports/math/octave-forge-linear-algebra/Makefile
  1.3       +3 -3      ports/math/octave-forge-linear-algebra/distinfo
_______________________________________________
cvs-all@freebsd.org mailing list
http://lists.freebsd.org/mailman/listinfo/cvs-all
To unsubscribe, send any mail to "cvs-all-unsubscribe@freebsd.org"
Comment 9 dfilter freebsd_committer 2009-08-23 17:50:49 UTC
dhn         2009-08-23 16:50:11 UTC

  FreeBSD ports repository

  Modified files:
    math/octave-forge-image Makefile distinfo 
  Removed files:
    math/octave-forge-image/files patch-src:Makefile 
  Log:
  - Update to 1.0.10
  
  PR:             ports/137402
  Submitted by:   Stephen Montgomery-Smith <stephen@missouri.edu>
  
  Revision  Changes    Path
  1.6       +2 -3      ports/math/octave-forge-image/Makefile
  1.2       +3 -3      ports/math/octave-forge-image/distinfo
  1.2       +0 -10     ports/math/octave-forge-image/files/patch-src:Makefile (dead)
_______________________________________________
cvs-all@freebsd.org mailing list
http://lists.freebsd.org/mailman/listinfo/cvs-all
To unsubscribe, send any mail to "cvs-all-unsubscribe@freebsd.org"
Comment 10 dfilter freebsd_committer 2009-08-23 17:50:53 UTC
dhn         2009-08-23 16:50:16 UTC

  FreeBSD ports repository

  Modified files:
    math/octave-forge-general Makefile distinfo 
  Log:
  - Update to 1.1.3
  
  PR:             ports/137402
  Submitted by:   Stephen Montgomery-Smith <stephen@missouri.edu>
  
  Revision  Changes    Path
  1.5       +3 -4      ports/math/octave-forge-general/Makefile
  1.2       +3 -3      ports/math/octave-forge-general/distinfo
_______________________________________________
cvs-all@freebsd.org mailing list
http://lists.freebsd.org/mailman/listinfo/cvs-all
To unsubscribe, send any mail to "cvs-all-unsubscribe@freebsd.org"
Comment 11 dfilter freebsd_committer 2009-08-23 17:51:10 UTC
dhn         2009-08-23 16:50:21 UTC

  FreeBSD ports repository

  Modified files:
    math/octave-forge-communications Makefile distinfo 
  Log:
  - Update to 1.0.10
  
  PR:             ports/137402
  Submitted by:   Stephen Montgomery-Smith <stephen@missouri.edu>
  
  Revision  Changes    Path
  1.5       +3 -4      ports/math/octave-forge-communications/Makefile
  1.2       +3 -3      ports/math/octave-forge-communications/distinfo
_______________________________________________
cvs-all@freebsd.org mailing list
http://lists.freebsd.org/mailman/listinfo/cvs-all
To unsubscribe, send any mail to "cvs-all-unsubscribe@freebsd.org"
Comment 12 dfilter freebsd_committer 2009-08-23 17:53:09 UTC
dhn         2009-08-23 16:53:01 UTC

  FreeBSD ports repository

  Modified files:
    math                 Makefile 
  Added files:
    math/octave-forge-quaternion Makefile distinfo pkg-descr 
                                 pkg-plist 
  Log:
  The octave-forge package is the result of The GNU Octave Repositry project,
  which is intended to be a central location for custom scripts, functions and
  extensions for GNU Octave. contains the source for all the functions plus
  build and install scripts.
  
  This is quaternion.
  
   Package for the manipulation of Quaternion's used for frame transformation.
  
  WWW: http://octave.sourceforge.net/
  
  PR:             ports/137402
  Submitted by:   Stephen Montgomery-Smith <stephen@missouri.edu>
  
  Revision  Changes    Path
  1.614     +1 -0      ports/math/Makefile
  1.1       +17 -0     ports/math/octave-forge-quaternion/Makefile (new)
  1.1       +3 -0      ports/math/octave-forge-quaternion/distinfo (new)
  1.1       +10 -0     ports/math/octave-forge-quaternion/pkg-descr (new)
  1.1       +1 -0      ports/math/octave-forge-quaternion/pkg-plist (new)
_______________________________________________
cvs-all@freebsd.org mailing list
http://lists.freebsd.org/mailman/listinfo/cvs-all
To unsubscribe, send any mail to "cvs-all-unsubscribe@freebsd.org"
Comment 13 dfilter freebsd_committer 2009-08-23 17:53:19 UTC
dhn         2009-08-23 16:53:10 UTC

  FreeBSD ports repository

  Modified files:
    math/octave-forge    Makefile 
  Log:
  - Add Quaternion package support
  - Remove Window package support
  - Bump PORTREVSION
  
  PR:             ports/137402
  Submitted by:   Stephen Montgomery-Smith <stephen@missouri.edu>
  
  Revision  Changes    Path
  1.31      +14 -11    ports/math/octave-forge/Makefile
_______________________________________________
cvs-all@freebsd.org mailing list
http://lists.freebsd.org/mailman/listinfo/cvs-all
To unsubscribe, send any mail to "cvs-all-unsubscribe@freebsd.org"
Comment 14 dfilter freebsd_committer 2009-08-23 18:26:52 UTC
dhn         2009-08-23 17:26:44 UTC

  FreeBSD ports repository

  Modified files:
    .                    MOVED 
    math                 Makefile 
  Removed files:
    math/octave-forge-windows Makefile distinfo pkg-descr 
                              pkg-plist 
  Log:
  - Remove math/octave-forge-windows: Version branch long since retired.
  
  PR:             ports/137402
  Submitted by:   Stephen Montgomery-Smith <stephen@missouri.edu>
  
  Revision  Changes    Path
  1.1970    +2 -1      ports/MOVED
  1.615     +0 -1      ports/math/Makefile
  1.7       +0 -18     ports/math/octave-forge-windows/Makefile (dead)
  1.4       +0 -3      ports/math/octave-forge-windows/distinfo (dead)
  1.2       +0 -10     ports/math/octave-forge-windows/pkg-descr (dead)
  1.2       +0 -1      ports/math/octave-forge-windows/pkg-plist (dead)
_______________________________________________
cvs-all@freebsd.org mailing list
http://lists.freebsd.org/mailman/listinfo/cvs-all
To unsubscribe, send any mail to "cvs-all-unsubscribe@freebsd.org"
Comment 15 dhn freebsd_committer 2009-08-23 18:27:34 UTC
State Changed
From-To: feedback->closed

Committed, with minor changes. Thanks!