Bug 137942 - [pci] 8.0-BETA2 having problems with Asus M2N-SLI-deluxe motherboard [regression]
Summary: [pci] 8.0-BETA2 having problems with Asus M2N-SLI-deluxe motherboard [regress...
Status: Closed Overcome By Events
Alias: None
Product: Base System
Classification: Unclassified
Component: amd64 (show other bugs)
Version: 7.2-STABLE
Hardware: Any Any
: Normal Affects Only Me
Assignee: Mark Linimon
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2009-08-18 22:50 UTC by hsu
Modified: 2018-05-31 15:39 UTC (History)
0 users

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description hsu 2009-08-18 22:50:03 UTC
I tried to source-upgrade to HEAD a few weeks back:

While motherboard found all the disks, FreeBSD 8 only found some of
them.  After kernel was up, there were various timeout errors on all
the disks visible except boot disk (on jmicron controller).  

I resupped and recompiled, after that, no access at all, just timeouts
from all disks being accessed, including the boot disk.

I suspected power supply motherboard problem first, replaced power supply.

Disconnecting all other drive other than boot disk still continued
just giving timeouts on boot disk.

I tried booting from 7.2R DVD, and that showed all the disks, so I
"upgraded" back to 7.2R, and the system started working, all disks are
found and they seem to be readable (at least with dd).

To figure out whether this is 8.0 related, I tried booting from 8.0B2
DVD, and it found only the boot disk, rather than finding few of the
disks.  It also behaves a bit differently from my compiled kernel, not
giving timeout errors, it just does not show any of the disks other
than boot disk.  My self-compiled 8 kernel did not have WITNESS etc,
which could explain difference (see above lock message, which did not
appear on self-compiled kernel).

Another problem noted, when going to fixit mode from 8.0B2 DVD, trying
to do anything with ethernet port produces no effect, ping did not get
replies (I could not attend the other end at the time).

How-To-Repeat: 
	Get Asus M2N-SLI Deluxe motherboard and stuff lots of disks to
	it.  My configuration is boot disk on jmicron controller and
	other disks on motherboard SATA.  This could also be NVIDIA
	chipset related, so it might show up on other motherboards
	using the same chipset.
Comment 1 Mark Linimon freebsd_committer freebsd_triage 2009-08-19 09:25:26 UTC
Responsible Changed
From-To: freebsd-bugs->freebsd-i386

Annotate and reclassify.
Comment 2 Mark Linimon freebsd_committer freebsd_triage 2009-08-19 11:02:50 UTC
Responsible Changed
From-To: freebsd-i386->freebsd-amd64

Submitter says problem appears when running in amd64 mode.
Comment 3 Mark Linimon 2009-08-19 11:04:27 UTC
----- Forwarded message from Florian Smeets <flo@smeets.im> -----

Mark i think this should be assigned to freebsd-amd64 as described in
another PR the disks are found on i386 but not on amd64 as noted it 132372.

PRs i know of which discuss this problem 128686, 132372, 137942

further down is a answer from John to a mail thread on amd64/current

-------- Original Message --------
Subject: Re: Fwd: Re: [regression] 8.0-CURRENT amd64: SATA disks not
attaching, MCP55 controller
Date: Fri, 7 Aug 2009 08:44:33 -0400
From: John Baldwin <jhb@freebsd.org>
To: Florian Smeets <flo@kasimir.com>

On Friday 07 August 2009 5:12:06 am Florian Smeets wrote:
> Hi John,
>
> sorry for approaching you directly. Would you mind taking a look at this
> thread in amd64/current.
>
> I vaguely remember that you implemented the mentioned feature, right?

You do not need MCFG to work currently, no.  It does work on the vast
majority
of machines it has been tested on FWIW.  We may be able to blacklist it
using
ACPI quirks for certain known-bad motherboard / BIOS combinations however.

> TIA,
> Florian
>
> -------- Original Message --------
> Subject: Re: [regression] 8.0-CURRENT amd64: SATA disks not attaching,
> MCP55 controller
> Date: Thu, 6 Aug 2009 20:21:56 +0200
> From: Sticky Bit <stickybit@gmx.net>
> Reply-To: stickybit@gmx.net
> To: Florian Smeets <flo@kasimir.com>
> CC: freebsd-current@freebsd.org, freebsd-amd64@freebsd.org
>
> On Thu August 6 2009 09:28:58 Florian Smeets wrote:
>
> > i had the same problem with MCP55 on amd64, i tried the new ahci module
> > but to no avail.
> >
> > However if you set hw.pci.mcfg=0 the disks are found by the normal ata
>
> Thanks for the hint!
>
> I tried it again with 'set hw.pci.mcfg=0' from boot loader prompt and
> now it
> actually finds and attaches the disks as usual.
>
> But I do not know if I need 'support for PCI-e memory mapped config
> access',
> where it is needed and if it can cause problems later with an RELENG_8
> installation if it is disabled like in RELENG_7.
>
> I only have one PCIe device, a PCIe graphics card, which is working well
> with
> drm.ko / radeon.ko modules and radeonhd driver under RELENG_7.
>
> Is it safe to stay with 'hw.pci.mcfg=0' under RELENG_8 for the future?
>
> And if so, should the default setting be changed from enabled to
> disabled for
> 8.0-RELEASE if it is not yet mature enough and the cause of problems?
Looks
> like several people are affected by this regression.
>
> --
> Regards
>

Cheers,
Florian

----- End forwarded message -----
Comment 4 Andriy Gapon freebsd_committer 2010-12-05 12:40:16 UTC
What's the current status of this issue?
Is manual user action still required?  Or do we automatically blacklist this
hardware?

-- 
Andriy Gapon
Comment 5 hsu 2010-12-06 08:48:06 UTC
I did try to upgrade to 8.1 some weeks ago on another computer with the 
same motherboard, and had a problem again, many disks were not found, 
but this is different.  The disks show up in boot, but the partitions 
are not there, and I seemed to have problems with 2T disks only.  I was 
busy at the time so I did not investigate further, just dropped back to 
7.x.  What I did gather was:

- Only 2T disks exhibit the problem in this case, other disks seemed to 
work properly.  Note that this is different computer from the one in my 
original PR, but same motherboard.

- The raw devices are there and are readable by dd (adxx device)

- Slices and partitions do not appear in /dev, only adxx device, no 
slice devices or bsdlabel partitions.

- All these disks have been initialized similarly, ie. fdisk -B -I adxx; 
bsdlabel -w -B adxxs1; bsdlabel -e adxxs1.  All the disks have been 
added after sysinstall, when expanding the system.  If I boot on 
7.3-stable or 7.3R all partitions are found, but not on 8.x.

I would also note that 2T disks not working may have a connection to my 
other PR, about gmirrors disappearing after boot on 7.x.  This also only 
happens on 2T disks, but not on smaller ones.  I have not been able to 
test gmirrors on 8.x for above reasons.

I do have an older Asus motherboard with Athlon cpu, and it does not 
exhibit this problem, so this might be motherboard dependent.  However, 
it is puzzling that the symtoms are different from 8.0 and 8.1.

I have been dropping back to 7.x on most computers for other reasons, so 
this is not urgent for me, but I can test booting from DVD on 8.1R and 
gather a bit more information, if that would help.  Please give me some 
guidance what you would like to see in terms of logs and boot options.

Heikki Suonsivu


On 12/5/10 2:40 PM, Andriy Gapon wrote:
>
> What's the current status of this issue?
> Is manual user action still required?  Or do we automatically blacklist this
> hardware?
>
Comment 6 Andriy Gapon freebsd_committer 2010-12-06 16:14:14 UTC
on 06/12/2010 10:48 Heikki Suonsivu said the following:
> I did try to upgrade to 8.1 some weeks ago on another computer with the same
> motherboard, and had a problem again, many disks were not found, but this is
> different.  The disks show up in boot, but the partitions are not there, and I
> seemed to have problems with 2T disks only.  I was busy at the time so I did not
> investigate further, just dropped back to 7.x.  What I did gather was:
> 
> - Only 2T disks exhibit the problem in this case, other disks seemed to work
> properly.  Note that this is different computer from the one in my original PR,
> but same motherboard.
> 
> - The raw devices are there and are readable by dd (adxx device)
> 
> - Slices and partitions do not appear in /dev, only adxx device, no slice devices
> or bsdlabel partitions.
> 
> - All these disks have been initialized similarly, ie. fdisk -B -I adxx; bsdlabel
> -w -B adxxs1; bsdlabel -e adxxs1.  All the disks have been added after sysinstall,
> when expanding the system.  If I boot on 7.3-stable or 7.3R all partitions are
> found, but not on 8.x.
> 
> I would also note that 2T disks not working may have a connection to my other PR,
> about gmirrors disappearing after boot on 7.x.  This also only happens on 2T
> disks, but not on smaller ones.  I have not been able to test gmirrors on 8.x for
> above reasons.
> 
> I do have an older Asus motherboard with Athlon cpu, and it does not exhibit this
> problem, so this might be motherboard dependent.  However, it is puzzling that the
> symtoms are different from 8.0 and 8.1.
> 
> I have been dropping back to 7.x on most computers for other reasons, so this is
> not urgent for me, but I can test booting from DVD on 8.1R and gather a bit more
> information, if that would help.  Please give me some guidance what you would like
> to see in terms of logs and boot options.

Hmm, I think it should be a good idea to report this to geom@ mailing list.
The more eyes looking at this the better - the people on the mailing list may have
some ideas and suggestion.

Also, a diff between verbose boot dmesg produced by 7.x and 8.1 could be enlightening.

-- 
Andriy Gapon
Comment 7 Eitan Adler freebsd_committer freebsd_triage 2017-12-31 07:59:35 UTC
For bugs matching the following criteria:

Status: In Progress Changed: (is less than) 2014-06-01

Reset to default assignee and clear in-progress tags.

Mail being skipped
Comment 8 Mark Linimon freebsd_committer freebsd_triage 2018-05-31 15:39:23 UTC
Unfortunately this PR was never addressed before these versions of FreeBSD went out of support.  Sorry.

If this is still a problem, please open a new PR.  Thanks.