Bug 137958 - [patch] ports-mgmt/portupgrade fails with recursive dependency error
[patch] ports-mgmt/portupgrade fails with recursive dependency error
Status: Closed FIXED
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s)
Latest
Any Any
: Normal Affects Only Me
Assigned To: FreeBSD ports mailing list
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2009-08-19 10:40 UTC by Nick
Modified: 2012-06-02 10:50 UTC (History)
0 users

See Also:


Attachments
file.diff (782 bytes, patch)
2009-08-19 10:40 UTC, Nick
no flags Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Nick 2009-08-19 10:40:03 UTC
On building many ports portinstall fails with a recursive dependency error.
Knowing my habit of fiddling with everything, the recursiveness is probably my
fault. But I can't find it and that prevents me from using portupgrade to
upgrade my ports because portinstall raises an exception on finding it.

I've changed two things:

- Added printing of the parent we are researching for its dependencies. The
  dot sometimes is confusing as some 'simple' ports still depend on lots of
  stuff, because of depending on a port that has lots of children.

- On finding a an origin that is already on the list, skip adding its children
  to the list. This is done in a hackish way but works here.

How-To-Repeat: 
Well, that I don't know!
Comment 1 Nick 2009-08-19 10:49:52 UTC
Found a way to reproduce it on my system (with ports csupped yesterday). Set

    USE_LINUX=f8

(and unset OVERRIDE_LINUX_BASE_PORT=...) in /etc/make.conf. Two 
mysteries resolved. Grand, now I can finish installing kde 4.3.0 using 
portupgrade instead of doing it manually...
Comment 2 Martin Wilke freebsd_committer 2009-08-19 11:30:12 UTC
Responsible Changed
From-To: freebsd-ports-bugs->freebsd-ruby

Over to maintainer.
Comment 3 Mark Linimon freebsd_committer 2009-08-19 15:50:50 UTC
Responsible Changed
From-To: freebsd-ruby->ruby

Canonicalize assignment.
Comment 4 Philip M. Gollucci freebsd_committer 2010-09-10 00:11:39 UTC
Responsible Changed
From-To: ruby->pgollucci

I will take it
Comment 5 Philip M. Gollucci freebsd_committer 2010-09-24 07:22:32 UTC
Responsible Changed
From-To: pgollucci->freebsd-ports-bugs

going to have enotime for the next 2 weeks, sorry
Comment 6 steve freebsd_committer 2011-01-03 17:19:59 UTC
Responsible Changed
From-To: freebsd-ports-bugs->ruby

Over to maintainer(s).
Comment 7 Philip M. Gollucci freebsd_committer 2012-02-22 05:23:27 UTC
State Changed
From-To: open->suspended

Over to maintainer. 


Comment 8 Philip M. Gollucci freebsd_committer 2012-02-22 05:23:27 UTC
Responsible Changed
From-To: ruby->freebsd-ports-bugs

Over to maintainer.
Comment 9 Chris Rees freebsd_committer 2012-04-12 11:02:59 UTC
State Changed
From-To: suspended->open

This should not be suspended.
Comment 10 bryan 2012-05-22 04:41:21 UTC
Hi,

This PR can be closed.

Thank you for the patch and the report.

The issue reported is indicative of a PORTS issue and not a portupgrade
issue.

To help debug this in the future, I've adapted part of the submitted
patch to display the origins when gathering recursive depends when using
-v (verbose).

This will be available in the next version.

For reference, this is logged upstream at:
https://github.com/pkgtools/pkgtools/issues/16

Regards,
Bryan Drewery

Comment 11 Mark Linimon freebsd_committer 2012-05-22 05:55:59 UTC
State Changed
From-To: open->closed

Since this PR was submitted, it has been fixed in the ports tree.  However, 
the new portupgrade maintainer has added some debugging code to make it 
easier to spot these kinds of problems next time. 

Thank you for your report and your patience.
Comment 12 dfilter freebsd_committer 2012-06-02 10:48:58 UTC
bapt        2012-06-02 09:48:45 UTC

  FreeBSD ports repository

  Modified files:
    ports-mgmt/portupgrade-devel Makefile distinfo pkg-descr 
                                 pkg-plist 
  Log:
  Port changes
  - Convert to new options framework
  - Sync pkg-message with devel/portupgrade
  portupgrade changes
  - portupgrade/portinstall -v now lists recursive depends [ports/137958]
  - portupgrade lists new version after upgrade in results
  - Fixed failure being seen as success due to broken script(1) [ports/147242,
    ports/131111]
  - A fixed script(1) is now included for systems < 8.1
  - Expanded pkgng support
  
  PR:             ports/168548 which fixes: ports/137958 ports/147242 ports/131111
  Submitted by:   Bryan Drewery <bryan@shatow.net>
  
  Revision  Changes    Path
  1.286     +14 -4     ports/ports-mgmt/portupgrade-devel/Makefile
  1.195     +2 -2      ports/ports-mgmt/portupgrade-devel/distinfo
  1.24      +1 -2      ports/ports-mgmt/portupgrade-devel/pkg-descr
  1.43      +3 -0      ports/ports-mgmt/portupgrade-devel/pkg-plist
_______________________________________________
cvs-all@freebsd.org mailing list
http://lists.freebsd.org/mailman/listinfo/cvs-all
To unsubscribe, send any mail to "cvs-all-unsubscribe@freebsd.org"