Bug 138169 - emulators/linux_base-f8: Linux emulation do not list all files/directories
Summary: emulators/linux_base-f8: Linux emulation do not list all files/directories
Status: Closed FIXED
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: Normal Affects Only Me
Assignee: Boris Samorodov
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2009-08-25 14:40 UTC by Martin Laabs
Modified: 2009-09-08 10:20 UTC (History)
0 users

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Martin Laabs 2009-08-25 14:40:02 UTC
I run several applications with the linux emulation. I.e. skype, some java application with the linux jre and an proprietary (motiv based)  CAD program. And these programs show the same behavior: Some files and directories are missing when I open the file open dialogs. I can not find any regularity which file/directory is shown and which isn't. You can reproduce this behavior also with the linux sh.

Here some information about my system:

bash:~$ cat /etc/make.conf
[...]
OVERRIDE_LINUX_BASE_PORT=f8
[...]

bash:/var/db/pkg$ ls -d linux_base* linux-f8-*
linux-f8-alsa-lib-1.0.15                linux-f8-openssl-0.9.8b
linux-f8-atk-1.20.0                     linux-f8-pango-1.18.4
linux-f8-cairo-1.4.14                   linux-f8-png-1.2.22
linux-f8-expat-2.0.1                    linux-f8-tiff-3.8.2
linux-f8-gtk2-2.12.8                    linux-f8-xorg-libs-7.3_2
linux-f8-hicolor-icon-theme-0.5_1       linux_base-f8-8_11

bash:/var/db/pkg$ mount
dev/ufs/root on / (ufs, local)
devfs on /dev (devfs, local)
/dev/ufs/tmp on /tmp (ufs, local)
/dev/ufs/usr on /usr (ufs, local, soft-updates)
/dev/ufs/var on /var (ufs, local, soft-updates)
/dev/ufs/media on /media (ufs, local, soft-updates)
/dev/ufs/home on /home (ufs, local, soft-updates)
linprocfs on /usr/compat/linux/proc (linprocfs, local)
procfs on /proc (procfs, local)

How-To-Repeat: bash:~$ ls -a /media
.               .snap           Hoerspiele
.              Films           Music
bash:~$ /compat/linux/bin/sh 
sh:~$ ls -a /media
.  ..
sh:~$ exit
bash:~$
Comment 1 Mark Linimon freebsd_committer freebsd_triage 2009-08-25 16:18:59 UTC
Responsible Changed
From-To: freebsd-bugs->bsam

Fix synopsis and assign.
Comment 2 Boris B.Samorodov 2009-08-25 16:33:01 UTC
Aha, I see a regularity. Please, remove the directory
/compat/linux/media and see if it helps.

-- 
WBR, bsam
Comment 3 Boris Samorodov freebsd_committer 2009-08-25 16:46:35 UTC
State Changed
From-To: open->feedback

Awaiting for a feedback.
Comment 4 Martin Laabs 2009-08-25 17:01:10 UTC
Boris Samorodov wrote:
> Aha, I see a regularity. Please, remove the directory
> /compat/linux/media and see if it helps.

Ah - it works.

Thank you very much,

  Martin L.
Comment 5 Boris B.Samorodov 2009-08-25 17:39:23 UTC
On Tue, 25 Aug 2009 18:01:10 +0200 Martin Laabs wrote:
> Boris Samorodov wrote:
> > Aha, I see a regularity. Please, remove the directory
> > /compat/linux/media and see if it helps.

> Ah - it works.
> Thank you very much,

Thanks for the PR and the feedback.

If linuxulator accesses a <directory> it is searched at (en brief):
. /compat/linux/<directory>, if not found,
. <directory>...

But if it is found at stage 1, this directory is used.

That's why all common native FreeBSD and Linux (under /compat/linux)
got deletted at linux base ports before install. This particular
directory (/media) was missed. BTW, this bug is presented at all
linux_base ports. You were first to face and report it. Thanks!

I'll try to fix linux base ports ASAP.

-- 
WBR, Boris Samorodov (bsam)
Research Engineer, http://www.ipt.ru Telephone & Internet SP
FreeBSD Committer, http://www.FreeBSD.org The Power To Serve
Comment 6 Boris Samorodov freebsd_committer 2009-08-25 17:49:57 UTC
State Changed
From-To: feedback->open

A patch for linux base ports is being worked on.
Comment 7 dfilter service freebsd_committer 2009-09-08 10:16:41 UTC
bsam        2009-09-08 09:16:28 UTC

  FreeBSD ports repository

  Modified files:
    emulators/linux_base-f10 Makefile pkg-plist 
    emulators/linux_base-f7 Makefile pkg-plist 
    emulators/linux_base-f8 Makefile pkg-plist 
    emulators/linux_base-f9 Makefile pkg-plist 
    emulators/linux_base-fc4 Makefile pkg-install pkg-plist 
    emulators/linux_base-fc6 Makefile pkg-install pkg-plist 
  Log:
  Remove /compat/linux/media from linux_base ports since the native
  FreeBSD /media can not be accessed by a linux application.
  
  PR:             ports/138169
  Submitted by:   Martin Laabs <info at martinlaabs.de>
  
  Revision  Changes    Path
  1.56      +2 -2      ports/emulators/linux_base-f10/Makefile
  1.33      +0 -2      ports/emulators/linux_base-f10/pkg-plist
  1.40      +2 -2      ports/emulators/linux_base-f7/Makefile
  1.21      +0 -2      ports/emulators/linux_base-f7/pkg-plist
  1.53      +2 -2      ports/emulators/linux_base-f8/Makefile
  1.30      +0 -2      ports/emulators/linux_base-f8/pkg-plist
  1.55      +2 -2      ports/emulators/linux_base-f9/Makefile
  1.32      +0 -2      ports/emulators/linux_base-f9/pkg-plist
  1.33      +2 -2      ports/emulators/linux_base-fc4/Makefile
  1.8       +0 -1      ports/emulators/linux_base-fc4/pkg-install
  1.16      +0 -1      ports/emulators/linux_base-fc4/pkg-plist
  1.36      +2 -2      ports/emulators/linux_base-fc6/Makefile
  1.10      +0 -1      ports/emulators/linux_base-fc6/pkg-install
  1.18      +0 -1      ports/emulators/linux_base-fc6/pkg-plist
_______________________________________________
cvs-all@freebsd.org mailing list
http://lists.freebsd.org/mailman/listinfo/cvs-all
To unsubscribe, send any mail to "cvs-all-unsubscribe@freebsd.org"
Comment 8 Boris Samorodov freebsd_committer 2009-09-08 10:16:43 UTC
State Changed
From-To: open->closed

Linux base ports are fixed. Thanks for the report!