Bug 138183 - [PATCH] x11/xcb-util: update to 0.3.6
Summary: [PATCH] x11/xcb-util: update to 0.3.6
Status: Closed FIXED
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: Normal Affects Only Me
Assignee: Renato Botelho
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2009-08-25 21:20 UTC by Renato Botelho
Modified: 2009-09-10 19:40 UTC (History)
1 user (show)

See Also:


Attachments
xcb-util-0.3.6.patch (1.09 KB, patch)
2009-08-25 21:20 UTC, Renato Botelho
no flags Details | Diff
xcb-util.diff (1.43 KB, patch)
2009-09-05 09:03 UTC, Nikos Ntarmos
no flags Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Renato Botelho freebsd_committer 2009-08-25 21:20:00 UTC
- Update to 0.3.6

Port maintainer (ntarmos@cs.uoi.gr) is cc'd.

Generated with FreeBSD Port Tools 0.77
Comment 1 Edwin Groothuis freebsd_committer 2009-08-25 21:20:13 UTC
Responsible Changed
From-To: freebsd-ports-bugs->garga

Submitter has GNATS access (via the GNATS Auto Assign Tool)
Comment 2 Edwin Groothuis freebsd_committer 2009-08-25 21:20:16 UTC
Maintainer of x11/xcb-util,

Please note that PR ports/138183 has just been submitted.

If it contains a patch for an upgrade, an enhancement or a bug fix
you agree on, reply to this email stating that you approve the patch
and a committer will take care of it.

The full text of the PR can be found at:
    http://www.freebsd.org/cgi/query-pr.cgi?pr=ports/138183

-- 
Edwin Groothuis via the GNATS Auto Assign Tool
edwin@FreeBSD.org
Comment 3 Edwin Groothuis freebsd_committer 2009-08-25 21:20:17 UTC
State Changed
From-To: open->feedback

Awaiting maintainers feedback (via the GNATS Auto Assign Tool)
Comment 4 Nikos Ntarmos 2009-09-05 09:03:58 UTC
Since x11/xcb-util v0.3.5 I've received multiple emails about xcb-util
failing to build. This is caused by x11/libxcb having been built against 
x11/xcb-proto version 1.4, while xcb-util requires the former to be
built against xcb-proto 1.5 or higher. As of this, I've added a check in
xcb-util's Makefile to warn when this is the case. Obviously, this
situation arises when the installed ports are not fully in sync with the
ports tree or when libxcb has been installed via an early package. If
the added check is deemed unnecessary, then the patch supplied by Renato
is good to go, but perhaps we should add a line or two in UPDATING.

Cheers.

\n\n
Comment 5 dfilter service freebsd_committer 2009-09-10 19:31:41 UTC
garga       2009-09-10 18:31:33 UTC

  FreeBSD ports repository

  Modified files:
    x11/xcb-util         Makefile distinfo 
  Log:
  Update to 0.3.6
  
  PR:             ports/138183
  Submitted by:   garga
  Approved by:    Nikos Ntarmos <ntarmos@cs.uoi.gr> (maintainer)
  
  Revision  Changes    Path
  1.13      +1 -1      ports/x11/xcb-util/Makefile
  1.8       +3 -3      ports/x11/xcb-util/distinfo
_______________________________________________
cvs-all@freebsd.org mailing list
http://lists.freebsd.org/mailman/listinfo/cvs-all
To unsubscribe, send any mail to "cvs-all-unsubscribe@freebsd.org"
Comment 6 Renato Botelho freebsd_committer 2009-09-10 19:32:46 UTC
State Changed
From-To: feedback->closed

Committed. Thanks!