Bug 138377 - misc/mc fails to build due to autconf problem
Summary: misc/mc fails to build due to autconf problem
Status: Closed FIXED
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: Normal Affects Only Me
Assignee: Max Khon
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2009-08-31 11:00 UTC by Oleg Gawriloff
Modified: 2009-09-14 14:00 UTC (History)
0 users

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Oleg Gawriloff 2009-08-31 11:00:15 UTC
When upgrading misc/mc it fails with following error:
barzog@albatros:~>sudo portupgrade mc
--->  Upgrading 'mc-4.6.1_4' to 'mc-4.6.2' (misc/mc)
--->  Building '/usr/ports/misc/mc'
===>  Cleaning for mc-4.6.2
===>  Found saved configuration for mc-4.6.2
===>  Extracting for mc-4.6.2
=> MD5 Checksum OK for mc-4.6.2.tar.gz.
=> SHA256 Checksum OK for mc-4.6.2.tar.gz.
=> MD5 Checksum OK for mc-4.6.2-utf8.patch.gz.
=> SHA256 Checksum OK for mc-4.6.2-utf8.patch.gz.
===>   mc-4.6.2 depends on file: /usr/local/bin/perl5.8.9 - found
===>  Patching for mc-4.6.2
===>   mc-4.6.2 depends on file: /usr/local/bin/perl5.8.9 - found
===>  Applying distribution patches for mc-4.6.2
===>  Applying FreeBSD patches for mc-4.6.2
===>   mc-4.6.2 depends on executable: pkg-config - found
===>   mc-4.6.2 depends on executable: gmake - found
===>   mc-4.6.2 depends on file: /usr/local/bin/perl5.8.9 - found
===>   mc-4.6.2 depends on file: /usr/local/bin/automake-1.9 - found
===>   mc-4.6.2 depends on executable: pkg-config - found
===>   mc-4.6.2 depends on shared library: slang.2 - found
===>   mc-4.6.2 depends on shared library: iconv.3 - found
===>   mc-4.6.2 depends on shared library: intl - found
===>   mc-4.6.2 depends on shared library: glib-2.0.0 - found
===>  Configuring for mc-4.6.2
/usr/local/share/aclocal/glib.m4:8: warning: underquoted definition of AM_PATH_GLIB
  run info '(automake)Extending aclocal'
  or see http://sources.redhat.com/automake/automake.html#Extending-aclocal
/usr/local/share/aclocal/audiofile.m4:12: warning: underquoted definition of AM_PATH_AUDIOFILE
configure.ac:6: error: Autoconf version 2.60 or higher is required
configure.ac:6: the top level
autom4te259: /usr/local/bin/gm4 failed with exit status: 63
aclocal-1.9: autom4te failed with exit status: 63
*** Error code 63

Stop in /usr/ports/misc/mc.
*** Error code 1

Stop in /usr/ports/misc/mc.
** Command failed [exit code 1]: /usr/bin/script -qa /tmp/portupgrade20090831-59251-zk5pgv-0 env UPGRADE_TOOL=portupgrade UPGRADE_PORT=mc-4.6.1_4 UPGRADE_PORT_VER=4.6.1_4 make
** Fix the problem and try again.
** Listing the failed packages (-:ignored / *:skipped / !:failed)
        ! misc/mc (mc-4.6.1_4)  (unknown build error)

I reinstalled autoconf and autoconf-wrapper and have following versions:
autoconf-2.13.000227_6
autoconf-2.62
autoconf-wrapper-20071109
The problem is here:
barzog@albatros:~>ls -l /usr/local/bin/autoconf
lrwxr-xr-x  1 root  wheel  16 Aug 31 12:45 /usr/local/bin/autoconf -> autoconf-wrapper

barzog@albatros:~>autoconf -V
autoconf (GNU Autoconf) 2.59

Problem occured after portupgrade -a.
Comment 1 Edwin Groothuis freebsd_committer 2009-08-31 11:00:34 UTC
Responsible Changed
From-To: freebsd-ports-bugs->fjoe

Over to maintainer (via the GNATS Auto Assign Tool)
Comment 2 Max Khon freebsd_committer 2009-09-14 13:58:30 UTC
State Changed
From-To: open->closed

Mising depend on autoconf 2.62 added.
Comment 3 dfilter service freebsd_committer 2009-09-14 13:58:35 UTC
fjoe        2009-09-14 12:58:21 UTC

  FreeBSD ports repository

  Modified files:
    misc/mc              Makefile 
  Log:
  Add missing on autoconf.
  
  PR:             138377
  
  Revision  Changes    Path
  1.119     +1 -1      ports/misc/mc/Makefile
_______________________________________________
cvs-all@freebsd.org mailing list
http://lists.freebsd.org/mailman/listinfo/cvs-all
To unsubscribe, send any mail to "cvs-all-unsubscribe@freebsd.org"