Bug 138533 - databases/mysql-proxy doesn't build with mysql 4.1
Summary: databases/mysql-proxy doesn't build with mysql 4.1
Status: Closed FIXED
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: Normal Affects Only Me
Assignee: Steve Wills
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2009-09-04 17:00 UTC by Till Klampaeckel
Modified: 2010-12-12 01:00 UTC (History)
0 users

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Till Klampaeckel 2009-09-04 17:00:13 UTC
I've got the latest 4.1 server installed from ports. When I try to make databases/mysql-proxy, it dies with "Requires at least MySQL 4.1 to compile.".

How-To-Repeat: portsnap fetch update
cd /usr/ports/databases/mysql41-server/ && make install clean
cd /usr/ports/databases/mysql-proxy && make
Comment 1 Edwin Groothuis freebsd_committer 2009-09-04 22:23:43 UTC
Responsible Changed
From-To: freebsd-ports-bugs->freebsd-ports-bugs

n/a
Comment 2 Edwin Groothuis freebsd_committer 2009-09-04 22:27:28 UTC
Responsible Changed
From-To: freebsd-ports-bugs->clsung

Over to maintainer (via the GNATS Auto Assign Tool)
Comment 3 Philip M. Gollucci freebsd_committer 2010-12-10 23:15:12 UTC
Responsible Changed
From-To: clsung->swills

Over to maintainer
Comment 4 Steve Wills 2010-12-12 00:29:09 UTC
-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA1

Hi,

The initial source of this bug seems to be here:

http://bazaar.launchpad.net/~mysql-proxy-developers/mysql-proxy/trunk/revision/525

Given that mysql 4.1 declares it's MYSQL_VERSION_ID as 40125, it seems
this code is wrong. It would be checking for mysql version 4.10 or
greater. I can patch the code to fix that, but when I do, I get further
errors about missing types. Which leads me to conclude that even 4.1 is
also "missing too many things":

libtool: compile:  cc -DHAVE_CONFIG_H -I. -I..
- -I/usr/local/include/mysql -I/usr/local/include/glib-2.0
- -I/usr/local/lib/glib-2.0/include -I/usr/local/include/lua51
- -D_REENTRANT -I/usr/local/include/glib-2.0
- -I/usr/local/lib/glib-2.0/include -O2 -fno-strict-aliasing -pipe
- -I/usr/local/include -MT libmysql_proxy_la-network-conn-pool-lua.lo -MD
- -MP -MF .deps/libmysql_proxy_la-network-conn-pool-lua.Tpo -c
network-conn-pool-lua.c  -fPIC -DPIC -o
.libs/libmysql_proxy_la-network-conn-pool-lua.o
network-mysqld-binlog.c: In function
'network_mysqld_binlog_event_tablemap_get':
network-mysqld-binlog.c:499: error: 'MYSQL_TYPE_VARCHAR' undeclared
(first use in this function)
network-mysqld-binlog.c:499: error: (Each undeclared identifier is
reported only once
network-mysqld-binlog.c:499: error: for each function it appears in.)
network-mysqld-binlog.c:518: error: 'MYSQL_TYPE_NEWDECIMAL' undeclared
(first use in this function)
network-mysqld-binlog.c:555: error: 'MYSQL_TYPE_BIT' undeclared (first
use in this function)
*** Error code 1

The mysql folks also seem to have stopped supporting it on 4.1, given
that the docs for it have disappeared from the 4.1 manual. This page
announced the docs:

http://forums.mysql.com/read.php?3,170163,170163

The 5.1 and 5.0 pages work fine, but the link to the 4.1 documentation
is 404 and redirects to a search page.

Given all that and the age of 4.1 (and this bug) it seems the best thing
to do is to add 4.1 to the IGNORE_WITH_MYSQL for this port.

Steve
-----BEGIN PGP SIGNATURE-----
Version: GnuPG v2.0.16 (FreeBSD)
Comment: Using GnuPG with Mozilla - http://enigmail.mozdev.org/

iQEcBAEBAgAGBQJNBBdVAAoJEPXPYrMgexuhy9MH/1TtP1oQYfEDslnSAvxMf3Q5
W3GxhE4cyqNkIGwKe6hjBjKjRyv53t0B5gAH0911LmqiU0D8Ixat5shbnBDojFBM
AnNQYtzSAvl1UmJ9PKmB/5Q50beRHoBdkvtRBMmExnLEAAjhGLmhG9X4wUvaibH5
w8QUGJ7PMvt4RelMMEP5Kf9g4NFeJDT/u8Wr21R1aT0WueF1zWEX8CXW+/tHIbgB
fzlzIWcE7ajjcADDWGVUmQ0lBiQfHh+w4iUf+94UA+G2tE5GJxEWZwYTIDerJq/o
2e79VVWUpuFLm8B0P/ubduD19S6NBz/SkrQfvPFzdsarxbNvfpPAH5xcl1TF+eM=
=JZDL
-----END PGP SIGNATURE-----
Comment 5 dfilter service freebsd_committer 2010-12-12 00:55:18 UTC
swills      2010-12-12 00:55:06 UTC

  FreeBSD ports repository

  Modified files:
    databases/mysql-proxy Makefile 
  Log:
  - Remove support for building with MySQL 4.1 since it is broken
  
  PR:             ports/138533
  Approved by:    pgollucci (mentor)
  
  Revision  Changes    Path
  1.23      +1 -1      ports/databases/mysql-proxy/Makefile
_______________________________________________
cvs-all@freebsd.org mailing list
http://lists.freebsd.org/mailman/listinfo/cvs-all
To unsubscribe, send any mail to "cvs-all-unsubscribe@freebsd.org"
Comment 6 Steve Wills freebsd_committer 2010-12-12 00:57:45 UTC
State Changed
From-To: open->closed

Can't be fixed, port has been patched to prevent building with MySQL 
4.1. Sorry.