Bug 138774 - Tools/bump_revision.pl incorrectly handled REVISION?=
Summary: Tools/bump_revision.pl incorrectly handled REVISION?=
Status: Closed FIXED
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: Normal Affects Only Me
Assignee: Gerald Pfeifer
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2009-09-13 01:30 UTC by Gerald Pfeifer
Modified: 2009-09-15 10:40 UTC (History)
0 users

See Also:


Attachments
file.diff (583 bytes, patch)
2009-09-13 01:30 UTC, Gerald Pfeifer
no flags Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Gerald Pfeifer freebsd_committer 2009-09-13 01:30:03 UTC
	This first happened in January when I chased PORTREVISIONs for
	all ports with USE_FORTRAN=yes.  I reported it by mail back then,
	yet just ran into this again so I had a look into the actual code.

	The problem is that for a port with PORTREVISION?=n, 
	bump_revision.pl will not bump n to n+1, but reset to 1.

	The bug is in extracting the version number properly, and it
	seems the one line patch below fixes it.

	Is this okay to commit?

How-To-Repeat: 	I tested the patch both on math/fftw and lang/gcc34 to cover
	various cases.
Comment 1 Edwin Groothuis freebsd_committer 2009-09-14 22:36:38 UTC
Responsible Changed
From-To: freebsd-ports-bugs->gerald

Patch looks fine, go for it. 
(ports/Tools/scripts is a free area)
Comment 2 dfilter service freebsd_committer 2009-09-15 10:34:16 UTC
gerald      2009-09-15 09:34:08 UTC

  FreeBSD ports repository

  Modified files:
    Tools/scripts        bump_revision.pl 
  Log:
  Correctly bump PORTREVISION?= instead of always resetting to 1 in this case.
  
  PR:             138774
  Approved by:    edwin
  
  Revision  Changes    Path
  1.5       +2 -2      ports/Tools/scripts/bump_revision.pl
_______________________________________________
cvs-all@freebsd.org mailing list
http://lists.freebsd.org/mailman/listinfo/cvs-all
To unsubscribe, send any mail to "cvs-all-unsubscribe@freebsd.org"
Comment 3 Gerald Pfeifer freebsd_committer 2009-09-15 10:34:45 UTC
State Changed
From-To: open->closed

I applied the patch; thanks for the review.