Bug 139145 - [ip6] IPv6 blackhole / reject routes broken
Summary: [ip6] IPv6 blackhole / reject routes broken
Status: Closed FIXED
Alias: None
Product: Base System
Classification: Unclassified
Component: kern (show other bugs)
Version: unspecified
Hardware: Any Any
: Normal Affects Only Me
Assignee: qingli
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2009-09-25 23:50 UTC by sten
Modified: 2009-12-04 18:54 UTC (History)
0 users

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description sten 2009-09-25 23:50:01 UTC
	IPv6 blackhole/reject routes don't work as expected/documented.

How-To-Repeat: 	route an IPv6 netblock to a host, enable forwarding,
	add a blackhole route with iface lo0, observe the icmp6 replies.

	towel# sysctl -w net.inet6.ip6.forwarding=1
	net.inet6.ip6.forwarding: 0 -> 1
	towel# route add -inet6 -net 2a02:898:17::/48 -iface lo0 -blackhole
	add net 2a02:898:17::/48: gateway lo0

	sten@bastard:~$ traceroute6 2a02:898:17:1234::
	traceroute to 2a02:898:17:1234:: (2a02:898:17:1234::) from 2001:7b8e00:4, 30 hops max, 24 byte packets
 	1  gw.nkenlights.nl (2001:7b8:666:ffff::1)  0.274 ms  0.203 ms  0.145 ms
 	2  hobby.etwork.bit.nl (2001:7b8:3:47::2)  0.451 ms  0.384 ms  0.308 ms
 	5  dcg-1-.clue.net (2a02:898:8283:2::1)  6.142 ms  5.516 ms  5.512 ms
 	6  eddie.blinkenlights.nl (2a02:898::74:2)  3.474 ms  3.458 ms  2.968 ms
 	7  2a02:898:17:ffff::2 (2a02:898:17:ffff::2)  2.862 ms 3.012 ms 3.293 ms
 	8  2a02:898:17:ffff::2 (2a02:898:17:ffff::2)  3.205 ms 4.055 ms 2.965 ms
 	9  2a02:898:17:ffff::2 (2a02:898:17:ffff::2)  3.256 ms 3.95 ms  3.9 ms
Comment 1 Mark Linimon freebsd_committer freebsd_triage 2009-09-26 17:00:26 UTC
Responsible Changed
From-To: freebsd-bugs->freebsd-net

Over to maintainer(s).
Comment 2 sten 2009-10-28 23:05:45 UTC
On Fri, 25 Sep 2009, FreeBSD-gnats-submit@FreeBSD.org wrote:

>> Category:       kern
>> Responsible:    freebsd-bugs
>> Synopsis:       IPv6 blackhole / reject routes broken
>> Arrival-Date:   Fri Sep 25 22:50:01 UTC 2009

Not sure which commit fixed it but this issue seems to
be fixed in 8.0-RC2:

traceroute to 2a02:898:17:1234:: (2a02:898:17:1234::) from 
2001:7b8:666:ffff:0:42ff:fe00:4, 30 hops max, 24 byte packets
  1  gw.deepthought.blinkenlights.nl (2001:7b8:666:ffff::1)  0.292 ms  0.227 ms  0.193 ms
  2  hobby-gw.jun1.galilei.network.bit.nl (2001:7b8:3:47::2)  0.357 ms  0.402 ms  0.461 ms
  3  nikhef.ams-ix.ipv6.intouch.net (2001:7f8:1::a500:8954:1)  2.603 ms  2.494 ms  2.234 ms
  4  2001:6e0:8954:205b:1::2 (2001:6e0:8954:205b:1::2)  5.103 ms  5.144 ms  5.829 ms
  5  ge-0-0-1-0.dcg-1.ipv6.coloclue.net (2a02:898:0:301::a)  5.238 ms  6.026 ms  6.345 ms
  6  eddie.blinkenlights.nl (2a02:898::74:2)  3.18 ms  3.158 ms  4.044 ms
  7  * * *

-- 
Sten Spans

"There is a crack in everything, that's how the light gets in."
Leonard Cohen - Anthem
Comment 3 sten 2009-10-29 07:33:03 UTC
On Wed, 28 Oct 2009, Li, Qing wrote:

> I remember looking at this bug and tried to reproduce it ...
>
> If my memory serves me right, I believe this bug was fixed by
> svn r197364, committed on 9/20.  RC1 was built on 9/17.
>
> Another symptom of this bug is the "route get" command issued
> on any lo0 addresses returns "destination: default" instead
> of "destination: lo0".

That indeed looks like the culprit, thanks for fixing it.

-- 
Sten Spans

"There is a crack in everything, that's how the light gets in."
Leonard Cohen - Anthem
Comment 4 qingli freebsd_committer 2009-12-04 18:53:31 UTC
State Changed
From-To: open->closed

The fix had been committed and verified by the submitter. 



Comment 5 qingli freebsd_committer 2009-12-04 18:53:31 UTC
Responsible Changed
From-To: freebsd-net->qingli

The fix had been committed and verified by the submitter.