Bug 139560 - New port: games/opensonic
Summary: New port: games/opensonic
Status: Closed FIXED
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: Normal Affects Only Me
Assignee: Dima Panov
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2009-10-13 07:00 UTC by Stas Timokhin
Modified: 2010-02-03 09:20 UTC (History)
0 users

See Also:


Attachments
file.shar (7.91 KB, text/plain)
2009-10-13 07:00 UTC, Stas Timokhin
no flags Details
patch-CMakeLists.txt.gz (311 bytes, application/x-gzip)
2009-11-05 04:19 UTC, techlist
no flags Details

Note You need to log in before you can comment on or make changes to this bug.
Description Stas Timokhin 2009-10-13 07:00:10 UTC
This port require two new ports:
http://www.freebsd.org/cgi/query-pr.cgi?pr=139557
http://www.freebsd.org/cgi/query-pr.cgi?pr=139558

Fix: Patch attached with submission follows:
Comment 1 Martin Wilke freebsd_committer 2009-10-13 11:46:06 UTC
Responsible Changed
From-To: freebsd-ports-bugs->miwi

I'll take it.
Comment 2 Martin Wilke freebsd_committer 2009-10-13 17:15:16 UTC
State Changed
From-To: open->feedback

Howdy 

Fist thx for the nice port, I just checked now installing working etc. 
And found 2 problems. 


1) The patch reject from files dir, 
i fixed that with: 

${REINPLACE_CMD} -e 's|/usr/share/|${PREFIX}/share/|g'  
-e 's|/usr/bin|${PREFIX}/bin/|g'  
${WRKSRC}/CMakeLists.txt 

that seems to be works. But now the strange error: both binarys are 
installed in 


usr/local/share/opensonic 


list of extra files and directories in / (not present before this port 
was installed but present after it was deinstalled) 
13122        8 drwxr-xr-x    2 root             wheel 
80 Oct 13 16:11 usr/local/share/opensonic 13126      912 -rwxr-xr-x 
1 root             wheel              465448 Oct 13 16:11 
usr/local/share/opensonic/opensonic 13128       88 -rwxr-xr-x    1 root 
wheel               41784 Oct 13 16:11 
usr/local/share/opensonic/opensonic_launche 

could you please take a look were here exactly the problem is? 


Thx 

a full build log can you see here: 

http://64bit.miwibox.org/index.php?action=describe_port&id=2229
Comment 3 Martin Wilke freebsd_committer 2009-10-29 22:34:03 UTC
State Changed
From-To: feedback->closed

subitter timeout.
Comment 4 Martin Wilke freebsd_committer 2009-10-29 22:37:12 UTC
State Changed
From-To: closed->open

ups this was the wrong pr.
Comment 5 techlist 2009-11-05 04:19:07 UTC
		Hello !


I send gzipped patch, it applied cleanly and port build ok in tinderbox.
Comment 6 Martin Wilke freebsd_committer 2010-01-26 23:46:45 UTC
Responsible Changed
From-To: miwi->fluffy

fluffy@ will deal with this pr.
Comment 7 dfilter service freebsd_committer 2010-02-03 09:10:50 UTC
fluffy      2010-02-03 09:10:37 UTC

  FreeBSD ports repository

  Modified files:
    games                Makefile 
  Added files:
    games/opensonic      Makefile distinfo pkg-descr pkg-plist 
    games/opensonic/files patch-CMakeLists.txt 
                          patch-src__misc__opensonic 
                          patch-src__misc__opensonic_launcher 
  Log:
  Add opensonic 0.1.2, game based on the "Sonic the Hedgehog" universe.
  
  PR:             ports/139560
  Submitted by:   Stas Timokhin <devel at stasyan dot com>
  
  Revision  Changes    Path
  1.1326    +1 -0      ports/games/Makefile
  1.1       +48 -0     ports/games/opensonic/Makefile (new)
  1.1       +3 -0      ports/games/opensonic/distinfo (new)
  1.1       +43 -0     ports/games/opensonic/files/patch-CMakeLists.txt (new)
  1.1       +14 -0     ports/games/opensonic/files/patch-src__misc__opensonic (new)
  1.1       +14 -0     ports/games/opensonic/files/patch-src__misc__opensonic_launcher (new)
  1.1       +8 -0      ports/games/opensonic/pkg-descr (new)
  1.1       +153 -0    ports/games/opensonic/pkg-plist (new)
_______________________________________________
cvs-all@freebsd.org mailing list
http://lists.freebsd.org/mailman/listinfo/cvs-all
To unsubscribe, send any mail to "cvs-all-unsubscribe@freebsd.org"
Comment 8 Dima Panov freebsd_committer 2010-02-03 09:15:43 UTC
State Changed
From-To: open->closed

Committed, with minor changes. Thanks!