Bug 139811 - FreeBSD did not recognize Intel Gigabit ET Dual Port Srvr Adpt network adapter from intel with chipset 897654
Summary: FreeBSD did not recognize Intel Gigabit ET Dual Port Srvr Adpt network adapte...
Status: Closed Not Enough Information
Alias: None
Product: Base System
Classification: Unclassified
Component: kern (show other bugs)
Version: unspecified
Hardware: Any Any
: Normal Affects Only Me
Assignee: Gavin Atkinson
URL:
Keywords: IntelNetworking
Depends on:
Blocks:
 
Reported: 2009-10-21 10:30 UTC by José Luís
Modified: 2015-07-01 15:06 UTC (History)
1 user (show)

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description José Luís 2009-10-21 10:30:04 UTC
I have installed a network adapter from intel (Intel Gigabit ET Dual Port Srvr Adpt) with chipset 897654 but FreeBSD did not recognize this new hardware. This adapter was purchased to substitute another from intel with the following chipset: 82575 (that work fine!)

The SO versio is FreeBSD 7.0, however, i have already tried kldload of ixgb device (developped by Intel), i tried with 7.1 and 7.2 always without success...

My major doubt is related with the fact of, apparently the device are not finded by the SO at startup, i mean, whem i execute (in fix mode) commands as devinfo -v / dmesg / pciconf -lv the new pci interface are not listed.
Comment 1 jack.vogel 2009-10-21 18:23:21 UTC
This is not an adequate designation of the parts involved, I need the Intel part numbers, I also cannot tell from this description if this is only supposed to describe the adapter board or a server motherboard.

I'm guessing that you mean its an 82576?  If so, are you aware that in FreeBSD 7.2 this should use the igb rather than the em driver? Nevertheless, both drivers are in the GENERIC kernel so your adapter should be discovered.

The only other thing I can think of, depending on the server hardware, with many things plugged into expansion slots I have seen some cards mysteriously disappear from the PCI tree, this would be on ESB2 type systems. Making sure that all firmware is updated to the latest can help this. You can try removing everything but the new card and see if it then becomes visible. Try putting the adapter into a different system as another test.

If this fails its likely bad hardware.

Jack Vogel
Intel LAD Software
Comment 2 Gavin Atkinson freebsd_committer freebsd_triage 2009-10-22 22:12:45 UTC
State Changed
From-To: open->feedback

To submitter: Can you provide the output of "pciconf -lv" from 
this system please? 


Comment 3 Gavin Atkinson freebsd_committer freebsd_triage 2009-10-22 22:12:45 UTC
Responsible Changed
From-To: freebsd-i386->gavin

Track