Bug 140267 - Update net-im/pidgin-facebookchat to 1.62, fixes protocol breakage
Update net-im/pidgin-facebookchat to 1.62, fixes protocol breakage
Status: Closed FIXED
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s)
Latest
Any Any
: Normal Affects Only Me
Assigned To: Beat Gaetzi
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2009-11-04 09:50 UTC by jsa
Modified: 2009-11-14 16:10 UTC (History)
0 users

See Also:


Attachments
file.diff (1.18 KB, patch)
2009-11-04 09:50 UTC, jsa
no flags Details | Diff
pidgin-facebookchat_1.62v2.diff.txt (1.66 KB, text/plain)
2009-11-12 08:05 UTC, jsa.bsd
no flags Details
pidgin-facebookchat_1.63_IGNORE.diff (1.66 KB, patch)
2009-11-14 09:57 UTC, jsa.bsd
no flags Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description jsa 2009-11-04 09:50:04 UTC
Facebook appears to have changed something. This update restores the functionality of the plugin.

Fix: Update to 1.62 which was relased a couple of hours ago and fixes this issue.

Patch attached with submission follows:
How-To-Repeat: Just attempt to login to facebook via pidgin. It will fail a few times, then prompt you for your birtday. No matter how correct you answer, you will still be unable to login.
Comment 1 Edwin Groothuis freebsd_committer 2009-11-04 09:50:14 UTC
Responsible Changed
From-To: freebsd-ports-bugs->pgollucci

pgollucci@ wants his PRs (via the GNATS Auto Assign Tool)
Comment 2 Edwin Groothuis freebsd_committer 2009-11-04 09:50:16 UTC
Maintainer of net-im/pidgin-facebookchat,

Please note that PR ports/140267 has just been submitted.

If it contains a patch for an upgrade, an enhancement or a bug fix
you agree on, reply to this email stating that you approve the patch
and a committer will take care of it.

The full text of the PR can be found at:
    http://www.freebsd.org/cgi/query-pr.cgi?pr=ports/140267

-- 
Edwin Groothuis via the GNATS Auto Assign Tool
edwin@FreeBSD.org
Comment 3 Edwin Groothuis freebsd_committer 2009-11-04 09:50:18 UTC
State Changed
From-To: open->feedback

Awaiting maintainers feedback (via the GNATS Auto Assign Tool)
Comment 4 Martin Wilke freebsd_committer 2009-11-04 10:19:51 UTC
State Changed
From-To: feedback->closed

duplicate with  ports/140096.
Comment 5 Corey Halpin 2009-11-04 14:32:43 UTC
On 2009-11-04, Edwin Groothuis wrote:
> Maintainer of net-im/pidgin-facebookchat,
> 
> Please note that PR ports/140267 has just been submitted.


  This is not a dup of ports/140096 -- this upgrades to 1.62, whereas 
ports/140096 only upgrades to 1.61.

  Can this PR be re-opened, and ports/140096 be closed?

  Furthermore, I approve the patch.

~crh
Comment 6 Mark Linimon freebsd_committer 2009-11-06 04:27:50 UTC
State Changed
From-To: closed->open

Superses ports/140096. 


Comment 7 Mark Linimon freebsd_committer 2009-11-06 04:27:50 UTC
Responsible Changed
From-To: pgollucci->freebsd-ports-bugs
Comment 8 Beat Gaetzi freebsd_committer 2009-11-06 08:44:08 UTC
Responsible Changed
From-To: freebsd-ports-bugs->beat

I'll take it.
Comment 9 jsa.bsd 2009-11-06 09:14:47 UTC
I've been using it ever since. I am on 8.0-RC2 amd64 and ports were 
current as of the submission. Unless there is some feature that I am not 
using, it's been working fine. The FAQ mentions issues with the protocol 
not showing in the list of available options with less than 0.7.6 but I 
tested specifically for that when I was pointed to ports/140096. I can 
try to get in contact with the author "einrobb" and see what exactly is 
going on, but I seen no regressions personally.
Comment 10 Beat Gaetzi freebsd_committer 2009-11-06 10:01:23 UTC
State Changed
From-To: open->feedback

Have you been able to run pidgin-facebookchat? According to the 
changelog it requires json-glib 0.7.6 or higher now and we still have 
0.6.2 in ports.
Comment 11 hrkfdn 2009-11-07 21:15:44 UTC
I can confirm this. No problems yet, with json-glib from Ports and
pidgin-facebookchat 1.62.
Comment 12 jsa.bsd 2009-11-11 00:09:02 UTC
I spoke with Eion Robb from the project. The problem is that Facebook UIDs are 
now in the range of 64-bit int, while json-glib prior to 0.7.6 used default 
system in, or 32-bit on i386 and other 32-bit archs. This means that 1.60 (in 
ports currently) would show messages that appear to come from random strangers 
because the UID maps to the wrong accounts for more recent users.

However, a fix was implemented to address this in theory in 1.62.

Also, because of recent Facebook protocol changes, this plugin cannot function 
at all in any version prior to 1.62.
Comment 13 codeblock 2009-11-12 05:32:36 UTC
I can confirm this as well, 1.62 fixes the issues, and works fine with 
json-glib from ports :).
Comment 14 jsa.bsd 2009-11-12 08:05:42 UTC
This is an updated version of the patch because:

a) I have been assigned maintainership - thanks to Corey Halpin for maintaining 
this previously.

b) Because there is a known issue with recent Facebook UIDs, the port is 
effectively BROKEN until json-glib gets updated (soon after 8.0-RELEASE).

c) As a "buyer beware" compromise between usability and portmgr sanity the port 
is being *temporarily* marked INGNORE.

The benefit of this of this is that a broken package will not be built by the 
cluster, but for those of you who need/want this, you may still use ports and 
build via:

# make install NO_IGNORE=1

 From there, you are on your own.

See http://code.google.com/p/pidgin-facebookchat/wiki/FAQ for details on the 
problem.

If beat@ and miwi@ approve, welcome back to Facebook via Pidgin.
Comment 15 jsa.bsd 2009-11-14 09:57:36 UTC
Upstream has released 1.63. This fixes other issues that were caused buy the 
sudden Facebook changes but not addressed in the 1.62 connection hotfix.

This supersedes previous two patches.
Comment 16 dfilter freebsd_committer 2009-11-14 16:04:00 UTC
beat        2009-11-14 16:03:51 UTC

  FreeBSD ports repository

  Modified files:
    net-im/pidgin-facebookchat Makefile distinfo 
  Log:
  - Update to 1.63. Due to recent Facebook protocol changes, this plugin
    cannot function at all in any version prior to 1.62. Due to a known
    usability issue with recent Facebook UIDs, the port is marked INGNORE
    until json-glib (ports/140097) gets updated. Use NO_IGNORE to build
    anyway.
  
  PR:             ports/140267
  Submitted by:   Joseph S. Atkinson <jsa AT wickedmachine.net> (maintainer)
  Discussed with: miwi
  
  Revision  Changes    Path
  1.9       +7 -2      ports/net-im/pidgin-facebookchat/Makefile
  1.7       +3 -3      ports/net-im/pidgin-facebookchat/distinfo
_______________________________________________
cvs-all@freebsd.org mailing list
http://lists.freebsd.org/mailman/listinfo/cvs-all
To unsubscribe, send any mail to "cvs-all-unsubscribe@freebsd.org"
Comment 17 Beat Gaetzi freebsd_committer 2009-11-14 16:06:42 UTC
State Changed
From-To: feedback->closed

Committed. Thanks!