Bug 140268 - [install] 8.0-RC* does not install on MSI MS-7255 [regression]
Summary: [install] 8.0-RC* does not install on MSI MS-7255 [regression]
Status: Open
Alias: None
Product: Base System
Classification: Unclassified
Component: i386 (show other bugs)
Version: unspecified
Hardware: Any Any
: Normal Affects Only Me
Assignee: freebsd-i386 mailing list
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2009-11-04 09:50 UTC by Bozhin Zafirov
Modified: 2018-01-03 05:14 UTC (History)
0 users

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Bozhin Zafirov 2009-11-04 09:50:04 UTC
Installation of FreeBSD 8.0-RC1 and 8.0-RC2 fails after the "last
chance" question with the following error:


Unable to find device node for /dev/ad0s1b in /dev!
The creation of filesystems will be aborted.

I also tried to install 7.2 and upgrade it to 8.0-RC2 (I have never
done this before and thus there is a possibility i do things the wrong
way):

freebsd-update -r 8.0-RC2 upgrade
freebsd-update install

Then I was asked to restart the system and continue the upgrade process.
After the restart, things went wrong again:

..
Trying to mount root from ufs:/dev/ad0s1a
ROOT MOUNT ERROR:

If you have invalid mount options, reboot, and first try the following from the loader prompt:
  set vfs.root.mountfrom.options=rw
and then remove invalid options from /etc/fstab
..


Motherboard used is MSI MS-7255 Ver. 1.2; HDD 80GB Maxtor PATA;
In all cases I partitioned the disk like this:
ad0s1a - 76111MB  /
ad0s1b - 2048MB swap

It makes no difference whether I use standard MBR or boot loader.
Having in mind that FreeBSD 7.2 installs (and works) flawlessly on
this hardware, I assume problem is related to broken support for any
device present in this motherboard (maybe disk controller?) rather
than hardware malfunction.

I also tried to change settings in motherboard's BIOS to different
values with no luck.  I am out of ideas what further tests I may
conduct in order to attempt to resolve this problem.

Fix: 

not known so far
How-To-Repeat: Maybe attempt to install FreeBSD 8.0-* on MSI MS-7255 motherboard?
Comment 1 Bozhin Zafirov 2009-11-17 22:32:13 UTC
FreeBSD 8.0-RC3 does not seem to fix this problem, things are even  
getting worse:
now installer cannot detect my CD/DVD drive, which is External Super  
Multi DVD Rewriter, by LG - model GSA - E50L).
However, if I connect serial ata disk to this motherboard, I can  
successfully install FreeBSD 8.0-RC3 from a passive FTP - thus the  
problem seems to only be relevant to the on-board PATA disk  
controller. And since FreeBSD 8.0-RC3 there is a new problem with at  
least this USB DVD drive.


-------------------------------------

ICN.Bg ñ íàé-áîãàòàòà ãàìà îò Õîñòèíã óñëóãè íà Áúëãàðñêèÿ ïàçàð -
Ïðîôåñèîíàëåí Õîñòèíã çà 23 ñòîòèíêè íà äåí ñ ÄÄÑ, 18 GB ìÿñòî,
Íåîãðàíè÷åí òðàôèê è Áåçïëàòåí äîìåéí
  http://www.icn.bg/?referer=MailBg
Comment 2 Eitan Adler freebsd_committer freebsd_triage 2017-12-31 07:58:45 UTC
For bugs matching the following criteria:

Status: In Progress Changed: (is less than) 2014-06-01

Reset to default assignee and clear in-progress tags.

Mail being skipped