Bug 140969 - sysutils/bacula-bat: make install fails due to missing file
Summary: sysutils/bacula-bat: make install fails due to missing file
Status: Closed FIXED
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: Normal Affects Only Me
Assignee: Pav Lucistnik
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2009-11-28 13:30 UTC by Martin Laabs
Modified: 2009-12-19 23:23 UTC (History)
0 users

See Also:


Attachments
patch-Makefile (525 bytes, text/plain)
2009-12-19 17:02 UTC, Andrei V. Lavreniyuk
no flags Details

Note You need to log in before you can comment on or make changes to this bug.
Description Martin Laabs 2009-11-28 13:30:04 UTC
make install results in an error because of a missing file:

su:/usr/ports/sysutils/bacula-bat$ make install
===>  Installing for bacula-bat-3.0.3
===>   bacula-bat-3.0.3 depends on shared library: qwt.5 - found
===>   bacula-bat-3.0.3 depends on shared library: sqlite.2 - found
===>   bacula-bat-3.0.3 depends on shared library: intl - found
# override master
===>   Generating temporary packing list
===>  Checking if sysutils/bacula-bat already installed
# Install config files and preserve existing ones
install  -s -o root -g wheel -m 555 /usr/ports/sysutils/bacula-bat/work/bacula-3.0.3/src/qt-console/.libs/bat /usr/local/sbin
install: /usr/ports/sysutils/bacula-bat/work/bacula-3.0.3/src/qt-console/.libs/bat: No such file or directory
*** Error code 71

Stop in /usr/ports/sysutils/bacula-bat.
*** Error code 1

Stop in /usr/ports/sysutils/bacula-bat.

How-To-Repeat: cd /usr/ports/sysutils/bacula-bat
make config #select NLS and OPENSSL
make
make install
Comment 1 Edwin Groothuis freebsd_committer 2009-11-28 13:30:12 UTC
Maintainer of sysutils/bacula-bat,

Please note that PR ports/140969 has just been submitted.

If it contains a patch for an upgrade, an enhancement or a bug fix
you agree on, reply to this email stating that you approve the patch
and a committer will take care of it.

The full text of the PR can be found at:
    http://www.freebsd.org/cgi/query-pr.cgi?pr=ports/140969

-- 
Edwin Groothuis via the GNATS Auto Assign Tool
edwin@FreeBSD.org
Comment 2 Edwin Groothuis freebsd_committer 2009-11-28 13:30:14 UTC
State Changed
From-To: open->feedback

Awaiting maintainers feedback (via the GNATS Auto Assign Tool)
Comment 3 Martin Wilke freebsd_committer 2009-11-28 13:57:26 UTC
State Changed
From-To: feedback->closed

duplicate with ports/137957.
Comment 4 Mark Linimon freebsd_committer freebsd_triage 2009-11-28 15:24:41 UTC
State Changed
From-To: closed->open

apparently not a duplicate after all.
Comment 5 Pav Lucistnik freebsd_committer 2009-12-19 15:14:34 UTC
State Changed
From-To: open->feedback

Cannot reproduce. Please post a complete typescript of the build output. 


Comment 6 Pav Lucistnik freebsd_committer 2009-12-19 15:14:34 UTC
Responsible Changed
From-To: freebsd-ports-bugs->pav

Cannot reproduce. Please post a complete typescript of the build output.
Comment 7 Andrei V. Lavreniyuk 2009-12-19 17:02:07 UTC
Hi!


--- Makefile.orig       2009-08-14 23:02:51.000000000 +0300
+++ Makefile    2009-12-19 18:58:25.932693336 +0200
@@ -39,7 +39,7 @@

  do-install:
         # Install config files and preserve existing ones
-       ${INSTALL_PROGRAM} ${WRKSRC}/src/qt-console/.libs/bat ${PREFIX}/sbin
+       ${INSTALL_PROGRAM} ${WRKSRC}/src/qt-console/bat ${PREFIX}/sbin
         ${INSTALL_SCRIPT}  ${WRKSRC}/src/qt-console/bat.conf 
${PREFIX}/etc/bat.conf.sample
         ${GZIP_CMD} ${WRKSRC}/manpages/bat.1
         ${INSTALL_MAN}     ${WRKSRC}/manpages/bat.1.gz 
${PREFIX}/man/man1/




-- 
  Best regards, Andrei V. Lavreniyuk.
Comment 8 Pav Lucistnik freebsd_committer 2009-12-19 17:12:26 UTC
State Changed
From-To: feedback->open

I have reproduced it now and have a patch similar to the one from Andrey
Comment 9 dfilter service freebsd_committer 2009-12-19 23:13:29 UTC
pav         2009-12-19 23:13:14 UTC

  FreeBSD ports repository

  Modified files:
    sysutils/bacula-bat  Makefile 
    sysutils/bacula-server Makefile 
  Log:
  - Fixes to bacula-bat: add dependency on the libraries (needed to run), and fix
    the installation problem for some people
  
  PR:             ports/137957, ports/140969
  Approved by:    maintainer
  
  Revision  Changes    Path
  1.10      +7 -2      ports/sysutils/bacula-bat/Makefile
  1.122     +2 -5      ports/sysutils/bacula-server/Makefile
_______________________________________________
cvs-all@freebsd.org mailing list
http://lists.freebsd.org/mailman/listinfo/cvs-all
To unsubscribe, send any mail to "cvs-all-unsubscribe@freebsd.org"
Comment 10 Pav Lucistnik freebsd_committer 2009-12-19 23:23:07 UTC
State Changed
From-To: open->closed

Fixed