Bug 141007 - Broken multimedia/dvdauthor repaired
Summary: Broken multimedia/dvdauthor repaired
Status: Closed FIXED
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: Normal Affects Only Me
Assignee: Pierre Beyssac
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2009-11-29 21:20 UTC by hawei
Modified: 2009-12-08 14:23 UTC (History)
1 user (show)

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description hawei 2009-11-29 21:20:00 UTC
	multimedia/dvdauthor does not build

Fix: 

It suffices to comment two lines - 1082 and 1083 - in subreader.c like so:
   //fribidi_set_mirroring (FRIBIDI_TRUE);
   //fribidi_set_reorder_nsm (FRIBIDI_FALSE);
	# make install
	Okay, lxdvdrip which requires dvdauthor is working now as usual.
How-To-Repeat: 	# cd /usr/ports/multimedia/dvdauthor
	# make
Comment 1 Edwin Groothuis freebsd_committer 2009-11-29 21:20:11 UTC
Responsible Changed
From-To: freebsd-ports-bugs->pb

Over to maintainer (via the GNATS Auto Assign Tool)
Comment 2 Andriy Gapon 2009-12-08 13:30:19 UTC
This PR is duplicate of ports/138470.
The latter also has a nicer fix.

-- 
Andriy Gapon
Comment 3 dfilter service freebsd_committer 2009-12-08 14:11:30 UTC
pb          2009-12-08 14:11:21 UTC

  FreeBSD ports repository

  Modified files:
    multimedia/dvdauthor Makefile 
  Added files:
    multimedia/dvdauthor/files patch-src__subreader.c 
  Log:
  Fix compilation problem with Fribidi.
  
  PR:             ports/138470, ports/141007
  Submitted by:   Dima Panov <fluffy@fluffy.khv.ru>, <hawei@free.fr>
  
  Revision  Changes    Path
  1.38      +1 -1      ports/multimedia/dvdauthor/Makefile
  1.1       +13 -0     ports/multimedia/dvdauthor/files/patch-src__subreader.c (new)
_______________________________________________
cvs-all@freebsd.org mailing list
http://lists.freebsd.org/mailman/listinfo/cvs-all
To unsubscribe, send any mail to "cvs-all-unsubscribe@freebsd.org"
Comment 4 Pierre Beyssac freebsd_committer 2009-12-08 14:21:40 UTC
State Changed
From-To: open->closed

Committed in part, with bits from ports/138470, thanks.