Bug 143043 - graphics/xv: xv-3.10a_{7,11} improperly ignores SIGTERM (ctrl-C)
Summary: graphics/xv: xv-3.10a_{7,11} improperly ignores SIGTERM (ctrl-C)
Status: Closed FIXED
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: Normal Affects Only Me
Assignee: Dirk Meyer
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2010-01-21 01:00 UTC by Ronald F. Guilmette
Modified: 2010-02-11 14:50 UTC (History)
0 users

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Ronald F. Guilmette 2010-01-21 01:00:19 UTC
	Since upgrading a number of my ports (including numerous libraries)
	in order to get other things to work, I noticed that xv-3.10a_7 was
	no longer responding at all to ctrl-C (SIGTERM).  So I did the obvious
	thing and did a portupgrade to the latest, xv-3.10a_11.  That has been
	installed, but the problem remains... xv-3.10a_11 is not responding to
	SIGTERM, e.g. while it is displaying a JPEG.

Fix: 

Beats me.  I guess that I could tear into the code to try to find out
	where it is _supposed_ to handle SIGTERM, but I'm sort of hoping that
	someone who is already familiar with this code will have a look see
	first.
How-To-Repeat: 	Step 1)
	  Run xv-3.10a_11 and give it a filename of a JPEG on the command line.
	Step 2)
	  Type a ctrl-C, or else go to another xterm window and run ps to find
	  the PID of the xv process and then do kill -15 <procno>
	
	Note that after Step 2, nothing happens.

	(Note that kill -9 still works however, but kill -15 should work also.
	It did so previously, and there's no reason it shouldn't work properly.)
Comment 1 Mark Linimon freebsd_committer freebsd_triage 2010-01-21 01:40:09 UTC
Responsible Changed
From-To: freebsd-ports-bugs->dinoex

Fix synopsis and assign.
Comment 2 Dirk Meyer freebsd_committer 2010-02-11 14:28:50 UTC
State Changed
From-To: open->analyzed


yv hangs around in libxcb, the problem is known. 

https://bugs.freedesktop.org/show_bug.cgi?id=12133 
https://bugzilla.novell.com/show_bug.cgi?id=283914 

The suggested patches does not appy. 
I am working on different workaround.
Comment 3 dfilter service freebsd_committer 2010-02-11 14:45:32 UTC
dinoex      2010-02-11 14:45:23 UTC

  FreeBSD ports repository

  Modified files:
    graphics/xv          Makefile 
  Added files:
    graphics/xv/files    patch-xvmisc.c patch-xvvd.c 
  Log:
  - add workaround for a deadlock in libxcb
  PR:             143043
  
  Revision  Changes    Path
  1.77      +1 -1      ports/graphics/xv/Makefile
  1.1       +19 -0     ports/graphics/xv/files/patch-xvmisc.c (new)
  1.1       +20 -0     ports/graphics/xv/files/patch-xvvd.c (new)
_______________________________________________
cvs-all@freebsd.org mailing list
http://lists.freebsd.org/mailman/listinfo/cvs-all
To unsubscribe, send any mail to "cvs-all-unsubscribe@freebsd.org"
Comment 4 Dirk Meyer freebsd_committer 2010-02-11 14:48:00 UTC
State Changed
From-To: analyzed->closed

workaround committed, thanks.