Bug 143077 - security/logcheck: logcheck didn't work after upgrade to 1.2.54
Summary: security/logcheck: logcheck didn't work after upgrade to 1.2.54
Status: Closed FIXED
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: Normal Affects Only Me
Assignee: Greg Larkin
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2010-01-22 06:40 UTC by berend
Modified: 2010-01-25 23:30 UTC (History)
0 users

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description berend 2010-01-22 06:40:00 UTC
Logcheck failed with:

Details:
Could not run logtail or save output

Check temporary directory: /tmp/logcheck.urOJdC

Also verify that the logcheck user can read all files referenced in
/usr/local/etc/logcheck/logcheck.logfiles!

This is a misleading message. Logcheck could read those files. It appears that the problem was with logtail2:

/usr/local/sbin/logtail2 /var/log/messages

This failed with:

cannot compile /usr/local/share/logcheck/detectrotate/10-savelog.dtr: Permission denied

Fix: 

chown this directory to logcheck solved the problem. Next thing was a complaint about messages.offset. After chowning that and auth.log.offset to logcheck, logcheck worked again.
Comment 1 Remko Lodder freebsd_committer 2010-01-22 13:45:27 UTC
Responsible Changed
From-To: freebsd-bugs->freebsd-ports-bugs

Reassign to ports.
Comment 2 Greg Larkin freebsd_committer 2010-01-23 01:08:49 UTC
Responsible Changed
From-To: freebsd-ports-bugs->glarkin

This one's for me.
Comment 3 dfilter service freebsd_committer 2010-01-25 23:23:11 UTC
glarkin     2010-01-25 23:23:02 UTC

  FreeBSD ports repository

  Modified files:
    security/logcheck    Makefile 
  Log:
  - Fix permissions on DATADIR so code snippets can be compiled on the
    fly by logtail2.
  - Bumped PORTREVISION
  
  PR:             ports/143077, ports/143099
  Submitted by:   Berend de Boer <berend@pobox.com>, Yasuhiro KIMURA <yasu@utahime.org>
  
  Revision  Changes    Path
  1.31      +4 -1      ports/security/logcheck/Makefile
_______________________________________________
cvs-all@freebsd.org mailing list
http://lists.freebsd.org/mailman/listinfo/cvs-all
To unsubscribe, send any mail to "cvs-all-unsubscribe@freebsd.org"
Comment 4 Greg Larkin freebsd_committer 2010-01-25 23:23:42 UTC
State Changed
From-To: open->closed

Committed the patch in ports/143099 to fix this problem, thank you for 
the report!