Bug 143487 - net/freeradius2 libtool+perl problem workaround
Summary: net/freeradius2 libtool+perl problem workaround
Status: Closed FIXED
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: Normal Affects Only Me
Assignee: Wesley Shields
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2010-02-02 17:20 UTC by Ryan Steinmetz
Modified: 2010-02-22 14:50 UTC (History)
0 users

See Also:


Attachments
file.diff (416 bytes, patch)
2010-02-02 17:20 UTC, Ryan Steinmetz
no flags Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Ryan Steinmetz 2010-02-02 17:20:01 UTC
When launching net/freeradius2 with perl support, one gets the following error:

Can't load '/usr/local/lib/perl5/5.10.1/mach/auto/Data/Dumper/Dumper.so' for module Data::Dumper: /usr/local/lib/perl5/5.10.1/mach/auto/Data/Dumper/Dumper.so: Undefined symbol "Perl_sv_cmp" at /usr/local/lib/perl5/5.10.1/mach/XSLoader.pm line 70.
 at /usr/local/lib/perl5/5.10.1/mach/Data/Dumper.pm line 36
Compilation failed in require at /usr/local/etc/raddb/example.pl line 30.
BEGIN failed--compilation aborted at /usr/local/etc/raddb/example.pl line 30.
rlm_perl: perl_parse failed: /usr/local/etc/raddb/example.pl not found or has syntax errors.  
/usr/local/etc/raddb/modules/perl[7]: Instantiation failed for module "perl"

Information/workarounds/discussion regarding this issue can be located all over the net.

Fix: Apply the attached patch to activate the new code in FR 2.1.8 to support the newer libtool API as mentioned in http://www.mail-archive.com/freeradius-users@lists.freeradius.org/msg60579.html.  This will only take place whenever WITH_PERL is defined.

Potential issues:
-Alan DeKok says the new code is untested, however, it does appear to eliminate the need for the LD_PRELOAD workaround that has been floating around, as mentioned in http://bbs.archlinux.org/viewtopic.php?id=64557.
-This is a temporary workaround that will most likely need to be removed once 2.2.x of FR has been released and someone has confirmed that this has been resolved without the extra define.


Patch attached with submission follows:
How-To-Repeat: Build and install net/freeradius2, with perl support and attempt to launch.  (Ensuring FR has the perl module instantiated/used in some way)
Comment 1 Edwin Groothuis freebsd_committer 2010-02-02 17:20:11 UTC
Maintainer of net/freeradius2,

Please note that PR ports/143487 has just been submitted.

If it contains a patch for an upgrade, an enhancement or a bug fix
you agree on, reply to this email stating that you approve the patch
and a committer will take care of it.

The full text of the PR can be found at:
    http://www.freebsd.org/cgi/query-pr.cgi?pr=ports/143487

-- 
Edwin Groothuis via the GNATS Auto Assign Tool
edwin@FreeBSD.org
Comment 2 Edwin Groothuis freebsd_committer 2010-02-02 17:20:12 UTC
State Changed
From-To: open->feedback

Awaiting maintainers feedback (via the GNATS Auto Assign Tool)
Comment 3 Wesley Shields freebsd_committer 2010-02-02 17:20:58 UTC
Responsible Changed
From-To: freebsd-ports-bugs->wxs

I'll take it.
Comment 4 Ryan Steinmetz 2010-02-12 01:52:06 UTC
This appears to be a duplicate of ports/138445, ports/143493, ports/143656.  It is (in my opinion) the cleanest option.

As there are currently 4 PRs open to fix the same problem, one going back to September, I'd recommend closing the rest and committing the fix in this one.  Even if someone updates the port without removing this particular workaround, the port should still work fine.

I would be interested in taking over maintainership of this port if the current maintainer doesn't have enough free time available.  Eitherway, this has been a problem for around 5 months and should be resolved.

-r
Comment 5 dfilter service freebsd_committer 2010-02-22 14:46:51 UTC
wxs         2010-02-22 14:46:37 UTC

  FreeBSD ports repository

  Modified files:
    net/freeradius2      Makefile 
  Log:
  - Fix libtool problem when using perl option. See ports/143487 for information.
  
  PR:             ports/143487, ports/143656, ports/143493, ports/138445
  Submitted by:   Ryan Steinmetz <rpsfa@rit.edu>
  Approved by:    maintainer timeout
  Feature safe:   yes
  
  Revision  Changes    Path
  1.82      +3 -0      ports/net/freeradius2/Makefile
_______________________________________________
cvs-all@freebsd.org mailing list
http://lists.freebsd.org/mailman/listinfo/cvs-all
To unsubscribe, send any mail to "cvs-all-unsubscribe@freebsd.org"
Comment 6 Wesley Shields freebsd_committer 2010-02-22 14:46:53 UTC
State Changed
From-To: feedback->closed

Committed. Thanks!