Bug 143591 - [ral] RT2561C-based DLink card (DWL-510) fails to work with ral0 in FreeBSD 8 Release [regression]
Summary: [ral] RT2561C-based DLink card (DWL-510) fails to work with ral0 in FreeBSD 8...
Status: Open
Alias: None
Product: Base System
Classification: Unclassified
Component: kern (show other bugs)
Version: unspecified
Hardware: Any Any
: Normal Affects Only Me
Assignee: freebsd-wireless mailing list
URL:
Keywords: regression
Depends on:
Blocks:
 
Reported: 2010-02-05 23:10 UTC by Dima
Modified: 2019-04-02 07:27 UTC (History)
1 user (show)

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Dima 2010-02-05 23:10:03 UTC
Ralink Technology RT2561, RF RT2527 - based card (D-Link DWL-510) fails to work with default ral0 driver even after creation of virtual interface wlan0. System specified can't connect to access point even without encryption (authmode open). System with that version of FreeBSD can't scan vicinity in search of any AP available. 
Windows (r) XP with native driver for that card works fine.

Fix: 

FreeBSD 7.2 works fine with that card
How-To-Repeat: 1) Create virtual interface wlan0: ifconfig wlan0 create wlandev ral0
2) Scan for AP's: ifconfig wlan0 up scan
It lasts forever...
Comment 1 Mark Linimon freebsd_committer freebsd_triage 2010-02-05 23:42:49 UTC
Responsible Changed
From-To: freebsd-bugs->freebsd-net

Over to maintainer(s).
Comment 2 Eitan Adler freebsd_committer freebsd_triage 2017-12-31 07:58:53 UTC
For bugs matching the following criteria:

Status: In Progress Changed: (is less than) 2014-06-01

Reset to default assignee and clear in-progress tags.

Mail being skipped
Comment 3 Andriy Voskoboinyk freebsd_committer 2019-04-02 07:27:30 UTC
Is it still reproducible with currently supported (11+) FreeBSD versions?