Bug 146804 - devel/darcs doesn't build
Summary: devel/darcs doesn't build
Status: Closed FIXED
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: Normal Affects Only Me
Assignee: freebsd-haskell (Nobody)
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2010-05-21 20:00 UTC by Anatoly Borodin
Modified: 2010-05-21 23:43 UTC (History)
0 users

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Anatoly Borodin 2010-05-21 20:00:11 UTC
devel/darcs 2.4.3 does not build, it cannot find some required haskell packages.

Fix: 

Add missing dependencies.
How-To-Repeat: # cd /usr/ports/devel/darcs && make install
===>  Found saved configuration for darcs-2.4.3
===>  Extracting for darcs-2.4.3
=> MD5 Checksum OK for darcs-2.4.3.tar.gz.
=> SHA256 Checksum OK for darcs-2.4.3.tar.gz.
===>  Patching for darcs-2.4.3
===>  Applying FreeBSD patches for darcs-2.4.3
===>   darcs-2.4.3 depends on executable: ghc - found
===>   darcs-2.4.3 depends on package: hs-hashed-storage>=0 - found
===>   darcs-2.4.3 depends on package: hs-haskeline>=0.6.1 - found
===>   darcs-2.4.3 depends on package: hs-utf8-string-ghc>=0.3 - found
===>   darcs-2.4.3 depends on package: hs-zlib>=0.5.1.0 - found
===>   darcs-2.4.3 depends on package: hs-HTTP>=3000.0 - found
===>   darcs-2.4.3 depends on package: hs-terminfo>=0.3 - found
===>   darcs-2.4.3 depends on package: hs-mmap>=0.2 - found
===>   darcs-2.4.3 depends on executable: HsColour - found
===>   darcs-2.4.3 depends on shared library: curl - found
===>   darcs-2.4.3 depends on shared library: gmp.10 - found
===>  Configuring for darcs-2.4.3
[1 of 2] Compiling Distribution.ShellHarness ( Distribution/ShellHarness.hs, Distribution/ShellHarness.o )
[2 of 2] Compiling Main             ( Setup.lhs, Setup.o )
Linking setup ...
Configuring darcs-2.4.3...
setup: At least the following dependencies are missing:
QuickCheck >=2.1.0.0,
mmap >=0.2 && <0.5 && >=0.2 && <0.5 && >=0.2 && <0.5,
test-framework >=0.2.2,
test-framework-hunit >=0.2.2,
test-framework-quickcheck2 >=0.2.2
*** Error code 1

Stop in /usr/ports/devel/darcs.
*** Error code 1

Stop in /usr/ports/devel/darcs.

# make showconfig
===> The following configuration options are available for darcs-2.4.3:
     CURL=on "Use libcurl for HTTP support"
     CURL_PIPELINING=on "Use libcurl's HTTP pipelining"
     HTTP=on "Use the pure HTTP package"
     STATIC=off "Build static binary"
     TERMINFO=on "Use the terminfo package"
     THREADED=on "Use threading and SMP support"
     TYPE_WITNESSES=on "Use GADT type witnesses"
     COLOR=on "Use ANSI color escapes"
     MMAP=on "Compile with mmap support"
     TEST=on "Compile unit tests"
Comment 1 Edwin Groothuis freebsd_committer 2010-05-21 20:00:23 UTC
Responsible Changed
From-To: freebsd-ports-bugs->haskell

Over to maintainer (via the GNATS Auto Assign Tool)
Comment 2 dfilter service freebsd_committer 2010-05-21 23:31:25 UTC
pgj         2010-05-21 22:31:11 UTC

  FreeBSD ports repository

  Modified files:
    devel/darcs          Makefile 
    devel/darcs/files    patch-darcs.cabal 
  Log:
  - Fix build when non-default options are used
  
  PR:             ports/146804
  Submitted by:   Anatoly Borodin <anatoly.borodin@gmail.com>
  
  Revision  Changes    Path
  1.61      +2 -0      ports/devel/darcs/Makefile
  1.2       +28 -1     ports/devel/darcs/files/patch-darcs.cabal
_______________________________________________
cvs-all@freebsd.org mailing list
http://lists.freebsd.org/mailman/listinfo/cvs-all
To unsubscribe, send any mail to "cvs-all-unsubscribe@freebsd.org"
Comment 3 Gabor Pali freebsd_committer 2010-05-21 23:43:03 UTC
State Changed
From-To: open->closed

The issue has been fixed, thank you for reporting it.