Bug 147239 - network problem with system start
Summary: network problem with system start
Status: Open
Alias: None
Product: Base System
Classification: Unclassified
Component: misc (show other bugs)
Version: 8.1-PRERELEASE
Hardware: Any Any
: Normal Affects Only Me
Assignee: freebsd-bugs mailing list
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2010-05-30 23:10 UTC by Andreas Schwarz
Modified: 2017-12-31 22:34 UTC (History)
0 users

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Andreas Schwarz 2010-05-30 23:10:00 UTC
After upgrade from 8.0-STABLE #0: (Fri Mar 26 21:58:46 CET 2010),
to 8.1-PRERELEASE something seems to be wrong with the network 
startup. The network is not up when essential network daemons
are starting (like ntpd). This causes that they will not work 
properly. I have to run manually "/etc/rc.d/ntpd restart".

Have a look at the following part of the boot log, age0 link 
state changed to up after the ntpdate/ntpd init is processed. 
Compared to 8.0-STABLE the ntpdate/ntpd init is processed 3 
seconds (absolute from kernel log start) earlier, this makes
the difference.

May 30 22:36:32 tapir ntpdate[633]: can't find host 0.freebsd.pool.ntp.org
May 30 22:36:32 tapir ntpdate[633]: can't find host 1.freebsd.pool.ntp.org
May 30 22:36:32 tapir ntpdate[633]: can't find host 2.freebsd.pool.ntp.org
May 30 22:36:32 tapir ntpdate[633]: no servers can be used, exiting
May 30 22:36:32 tapir ntpd[822]: ntpd 4.2.4p5-a (1)
May 30 22:36:32 tapir kernel: fuse4bsd: version 0.3.9-pre1, FUSE ABI 7.8
May 30 22:36:34 tapir ntpd_initres[830]: host name not found: 0.freebsd.pool.ntp.org
May 30 22:36:34 tapir ntpd_initres[830]: couldn't resolve `0.freebsd.pool.ntp.org', giving up on it
May 30 22:36:34 tapir ntpd_initres[830]: host name not found: 1.freebsd.pool.ntp.org
May 30 22:36:34 tapir ntpd_initres[830]: couldn't resolve `1.freebsd.pool.ntp.org', giving up on it
May 30 22:36:34 tapir ntpd_initres[830]: host name not found: 2.freebsd.pool.ntp.org
May 30 22:36:34 tapir ntpd_initres[830]: couldn't resolve `2.freebsd.pool.ntp.org', giving up on it
May 30 22:36:34 tapir kernel: age0: link state changed to UP

How-To-Repeat: Reboot the system.
Comment 1 Garrett Cooper 2010-05-31 00:18:20 UTC
This issue has existed for some time now, but has only become more
noticeable in 8.0+ with the rc script rework.

koitsu@ had a proposal out a while back to hack around this problem,
but I'm not sure what the status is on his work.

Thanks,
-Garrett
Comment 2 Andreas.Schwarz 2010-06-01 11:01:32 UTC
The ntpdate rc script requires NETWORKING. The question is,
why is NETWORKING provided when NETWORKING is not possible?

Al possible workaround is to add a "sleep 5" (depends on NIC) to 
"/etc/rc.d/NETWORKING" (which provides NETWORKING).


best regards
Andreas
Comment 3 Andreas Schwarz 2010-06-01 11:13:13 UTC
The ntpdate rc script requires NETWORKING. The question is,
why is NETWORKING provided when NETWORKING is not possible?

Al possible workaround is to add a "sleep 5" (depends on NIC) to 
"/etc/rc.d/NETWORKING" (which provides NETWORKING).


best regards
Andreas
Comment 4 Garrett Cooper 2010-06-01 16:47:27 UTC
On Tue, Jun 1, 2010 at 3:01 AM, Andreas Schwarz
<Andreas.Schwarz@schwarzes.net> wrote:
>
> The ntpdate rc script requires NETWORKING. The question is,
> why is NETWORKING provided when NETWORKING is not possible?
>
> Al possible workaround is to add a "sleep 5" (depends on NIC) to
> "/etc/rc.d/NETWORKING" (which provides NETWORKING).

That's a hack at best as not all links are usable after 5 seconds.
-Garrett
Comment 5 Andreas.Schwarz 2010-08-11 00:38:53 UTC
MIME-Version: 1.0
Content-Type: text/plain


Unfortunately, with 8.1-STABLE the problem is still there. 8(

best regards,
Andreas
Comment 6 Eitan Adler freebsd_committer freebsd_triage 2017-12-31 08:01:42 UTC
For bugs matching the following criteria:

Status: In Progress Changed: (is less than) 2014-06-01

Reset to default assignee and clear in-progress tags.

Mail being skipped