Bug 147558 - [panic] sbdrops kernel panic
Summary: [panic] sbdrops kernel panic
Status: Closed DUPLICATE of bug 148807
Alias: None
Product: Base System
Classification: Unclassified
Component: kern (show other bugs)
Version: 7.3-RELEASE
Hardware: Any Any
: Normal Affects Only Me
Assignee: freebsd-bugs (Nobody)
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2010-06-06 13:10 UTC by Sebastian Hyrwall
Modified: 2017-01-07 22:56 UTC (History)
1 user (show)

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Sebastian Hyrwall 2010-06-06 13:10:04 UTC
"Random" kernelpanics related to "sbdrops" after the system has been on for a few hours. 

Only process running is Quagga (bgpd,zebra). 
Network traffic is minimum (<= 100kbit/s avg). 
NIC is bge. 
IPV6 is enabled/configured.

Attaching stacktrace. 

VMCORE available at : http://slask.keff.org/vmcore

# kgdb kernel /var/crash/vmcore.1
GNU gdb 6.1.1 [FreeBSD]
Copyright 2004 Free Software Foundation, Inc.
GDB is free software, covered by the GNU General Public License, and you are
welcome to change it and/or distribute copies of it under certain conditions.
Type "show copying" to see the conditions.
There is absolutely no warranty for GDB.  Type "show warranty" for details.
This GDB was configured as "i386-marcel-freebsd"...

Unread portion of the kernel message buffer:
panic: sbdrop
cpuid = 0
Uptime: 14h31m24s
Physical memory: 1011 MB
Dumping 154 MB: 139 123 107 91 75 59 43 27 11

Reading symbols from /boot/kernel/acpi.ko...Reading symbols from /boot/kernel/ac                                                                                                      
pi.ko.symbols...done.
done.
Loaded symbols for /boot/kernel/acpi.ko
Reading symbols from /boot/kernel/pf.ko...Reading symbols from /boot/kernel/pf.k                                                                                                      
o.symbols...done.
done.
Loaded symbols for /boot/kernel/pf.ko
#0  doadump () at pcpu.h:196
196     pcpu.h: No such file or directory.
        in pcpu.h
(kgdb) backtrace
#0  doadump () at pcpu.h:196
#1  0xc07f8c57 in boot (howto=260) at /usr/src/sys/kern/kern_shutdown.c:418
#2  0xc07f8f29 in panic (fmt=Variable "fmt" is not available.
) at /usr/src/sys/kern/kern_shutdown.c:574
#3  0xc08514db in sbdrop_internal (sb=0xc469b5c4, len=293)
    at /usr/src/sys/kern/uipc_sockbuf.c:843
#4  0xc08516ce in sbdrop_locked (sb=0xc469b5c4, len=398)
    at /usr/src/sys/kern/uipc_sockbuf.c:893
#5  0xc0853f90 in soisdisconnected (so=0xc469b4e0)
    at /usr/src/sys/kern/uipc_socket.c:3097
#6  0xc094e32e in tcp_close (tp=0xc5714740)
    at /usr/src/sys/netinet/tcp_subr.c:819
#7  0xc094e4ac in tcp_drop (tp=0xc5714740, errno=61)
    at /usr/src/sys/netinet/tcp_subr.c:699
#8  0xc0953ca2 in tcp_timer_rexmt (xtp=0xc5714740)
    at /usr/src/sys/netinet/tcp_timer.c:455
#9  0xc080b7aa in softclock (dummy=0x0) at /usr/src/sys/kern/kern_timeout.c:274
#10 0xc07d54ab in ithread_loop (arg=0xc4093240)
    at /usr/src/sys/kern/kern_intr.c:1181
#11 0xc07d1c49 in fork_exit (callout=0xc07d5300 <ithread_loop>,
    arg=0xc4093240, frame=0xc3fb1d38) at /usr/src/sys/kern/kern_fork.c:811
#12 0xc0ae50b0 in fork_trampoline () at /usr/src/sys/i386/i386/exception.s:271
(kgdb)

How-To-Repeat: You wait a few hours (~10h).
Comment 1 Sebastian Hyrwall 2010-06-06 14:27:04 UTC
Hi

I seemed to have made a little mistake by posting the stack-trace under 
the "fix"-section. This is of course not a fix.


Some more information:

HP DL360 G3
CPU: Intel(R) Xeon(TM) CPU 2.80GHz (2799.22-MHz 686-class CPU)
  Logical CPUs per core: 2
FreeBSD/SMP: Multiprocessor System Detected: 2 CPUs
 cpu0 (BSP): APIC ID:  6
 cpu1 (AP/HT): APIC ID:  7

Sincerely,
Sebastian H
Comment 2 Sebastian Hyrwall 2010-06-08 06:36:56 UTC
Hi

Problem seems to have gone away after disabling TSO on the bge 
interface. Still doing testing but stable for 40 hours now.

Sincerely,
Sebastian H
Comment 3 Hiren Panchasara freebsd_committer 2017-01-07 22:56:56 UTC
Bug 148807 is tracking the issue.

*** This bug has been marked as a duplicate of bug 148807 ***