Bug 147639 - [PATCH] audio/libtunepimp: make compilable with gcc44
Summary: [PATCH] audio/libtunepimp: make compilable with gcc44
Status: Closed FIXED
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: Normal Affects Only Me
Assignee: Rene Ladan
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2010-06-07 09:10 UTC by Andriy Gapon
Modified: 2010-07-12 12:43 UTC (History)
1 user (show)

See Also:


Attachments
libtunepimp-0.5.3_6,1.patch (9.91 KB, patch)
2010-06-07 09:10 UTC, Andriy Gapon
no flags Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Andriy Gapon 2010-06-07 09:10:05 UTC
I am trying to use lang/gcc44 to build as much of my ports as possible.
Many ports including this one have problems outlined here:
http://gcc.gnu.org/gcc-4.3/porting_to.html
under section "Header dependency cleanup"

Added file(s):
- files/patch-include_tunepimp-0.5_metadata.h
- files/patch-lib_c_wrapper.cpp
- files/patch-lib_protocol.cpp
- files/patch-lib_readmeta.cpp
- files/patch-lib_tunepimp.cpp
- files/patch-plugins_mp3_id3_2_3_meta.cpp
- files/patch-plugins_mp3_id3_meta.cpp
- files/patch-plugins_wma_wma.cpp
- files/patch-plugins_wma_wmafile.cpp

Port maintainer (bsdkaffee@gmail.com) is cc'd.

Generated with FreeBSD Port Tools 0.99
Patchfiles created via update-patches target.
Comment 1 Edwin Groothuis freebsd_committer 2010-06-07 09:10:14 UTC
Maintainer of audio/libtunepimp,

Please note that PR ports/147639 has just been submitted.

If it contains a patch for an upgrade, an enhancement or a bug fix
you agree on, reply to this email stating that you approve the patch
and a committer will take care of it.

The full text of the PR can be found at:
    http://www.freebsd.org/cgi/query-pr.cgi?pr=ports/147639

-- 
Edwin Groothuis via the GNATS Auto Assign Tool
edwin@FreeBSD.org
Comment 2 Edwin Groothuis freebsd_committer 2010-06-07 09:10:15 UTC
State Changed
From-To: open->feedback

Awaiting maintainers feedback (via the GNATS Auto Assign Tool)
Comment 3 Rene Ladan freebsd_committer 2010-06-15 20:40:58 UTC
Responsible Changed
From-To: freebsd-ports-bugs->rene

Grab
Comment 4 Jason E. Hale 2010-06-18 08:05:51 UTC
I don't have time to test this, but it looks harmless.  Go ahead with it.

- Jason
Comment 5 Rene Ladan freebsd_committer 2010-06-20 17:51:09 UTC
When trying to build the port with gcc-4.4.5.20100608 on a
9.0-CURRENT/amd64 box (r209035, all ports reinstalled after updating),
after adding this patch to fix some compiler errors:

% cat files/patch-lib_fileio.cpp
--- lib/fileio.cpp.orig	2006-11-18 11:52:33.000000000 +0100
+++ lib/fileio.cpp	2010-06-20 18:37:34.000000000 +0200
@@ -28,6 +28,8 @@
 #include <assert.h>
 #include <errno.h>
+#include <stdlib.h>
 #include <string>
+#include <string.h>
 #ifndef WIN32
 #include <unistd.h>
 #endif

I'm getting linker errors (fileio.cpp is not involved):

libtool: link: c++ -shared -nostdlib /usr/lib/crti.o
/usr/lib/crtbeginS.o  .libs/tunepimp.o .libs/filecache.o
.libs/analyzer.o .libs/dirsearch.o .libs/metadata.o .libs/astrcmp.o
.libs/track.o .libs/write.o .libs/c_wrapper.o .libs/watchdog.o
.libs/plugins.o .libs/readmeta.o .libs/fileio.o .libs/protocol.o
-Wl,--whole-archive threads/posix/.libs/libtpthread.a
utf8/.libs/libutf8.a ../libltdl/.libs/libltdlc.a -Wl,--no-whole-archive
 -Wl,-rpath -Wl,/usr/local/lib -Wl,-rpath -Wl,/usr/local/lib
-L/usr/local/lib -pthread /usr/local/lib/libcurl.so
/usr/local/lib/libidn.so /usr/local/lib/libintl.so
/usr/local/lib/libiconv.so /usr/local/lib/libssh2.so
/usr/local/lib/libldap.so /usr/local/lib/liblber.so -lssl -lcrypto -lz
/usr/local/lib/libofa.so /usr/local/lib/libfftw3.so
/usr/local/lib/libmusicbrainz.so /usr/local/lib/libexpat.so -L/usr/lib
-lstdc++ -lm -lc -lgcc_s /usr/lib/crtendS.o /usr/lib/crtn.o
-march=nocona -pthread   -pthread -Wl,-soname -Wl,libtunepimp.so.5 -o
.libs/libtunepimp.so.5
local symbol 0: discarded in section `.text._ZN8MetadataD1Ev' from
.libs/filecache.o
local symbol 1: discarded in section
`.text._ZNSt6vectorIP5TrackSaIS1_EE13_M_insert_auxEN9__gnu_cxx17__normal_iteratorIPS1_S3_EERKS1_'
from .libs/filecache.o
local symbol 2: discarded in section `.text._ZN8MetadataD1Ev' from
.libs/analyzer.o
local symbol 3: discarded in section `.text._ZN8MetadataD1Ev' from
.libs/metadata.o
local symbol 4: discarded in section `.text._ZN13FileNameMakerD1Ev' from
.libs/write.o
local symbol 5: discarded in section `.text._ZN8MetadataD1Ev' from
.libs/write.o
local symbol 6: discarded in section `.text._ZN8MetadataC1ERKS_' from
.libs/write.o
local symbol 7: discarded in section
`.text._ZStplIcSt11char_traitsIcESaIcEESbIT_T0_T1_ERKS6_S8_' from
.libs/write.o
local symbol 8: discarded in section `.text._ZN13FileNameMakerD0Ev' from
.libs/write.o
local symbol 9: discarded in section
`.text._ZStplIcSt11char_traitsIcESaIcEESbIT_T0_T1_EPKS3_RKS6_' from
.libs/write.o
local symbol 10: discarded in section `.text._ZN15MetadataCompareD1Ev'
from .libs/c_wrapper.o
local symbol 11: discarded in section `.text._ZN15MetadataCompareD0Ev'
from .libs/c_wrapper.o
local symbol 12: discarded in section
`.text._ZNSt8_Rb_treeI12TPFileStatusSt4pairIKS0_iESt10_Select1stIS3_ESt4lessIS0_ESaIS3_EE10_M_insert_EPKSt18_Rb_tree_node_baseSC_RKS3_'
from .libs/c_wrapper.o
local symbol 13: discarded in section
`.text._ZNSt8_Rb_treeI12TPFileStatusSt4pairIKS0_iESt10_Select1stIS3_ESt4lessIS0_ESaIS3_EE16_M_insert_uniqueERKS3_'
from .libs/c_wrapper.o
local symbol 14: discarded in section
`.text._ZNSt8_Rb_treeI12TPFileStatusSt4pairIKS0_iESt10_Select1stIS3_ESt4lessIS0_ESaIS3_EE17_M_insert_unique_ESt23_Rb_tree_const_iteratorIS3_ERKS3_'
from .libs/c_wrapper.o
local symbol 15: discarded in section
`.text._ZNSt6vectorIiSaIiEE13_M_insert_auxEN9__gnu_cxx17__normal_iteratorIPiS1_EERKi'
from .libs/c_wrapper.o
local symbol 16: discarded in section `.text._ZNSt6vectorISsSaISsEED1Ev'
from .libs/c_wrapper.o
local symbol 17: discarded in section `.text._ZN8MetadataD1Ev' from
.libs/c_wrapper.o
local symbol 18: discarded in section
`.text._ZNSt6vectorISsSaISsEE13_M_insert_auxEN9__gnu_cxx17__normal_iteratorIPSsS1_EERKSs'
from .libs/plugins.o
local symbol 19: discarded in section `.text._ZN13FileNameMakerD1Ev'
from .libs/readmeta.o
local symbol 20: discarded in section `.text._ZN13FileNameMakerD0Ev'
from .libs/readmeta.o
local symbol 21: discarded in section `.text._ZN8MetadataD1Ev' from
.libs/readmeta.o
gmake[3]: *** [libtunepimp.la] Fout 1
gmake[3]: Map
'/usr/home/rene/freebsd/ports/audio/libtunepimp/work/libtunepimp-0.5.3/lib'
wordt verlaten
gmake[2]: *** [all-recursive] Fout 1
gmake[2]: Map
'/usr/home/rene/freebsd/ports/audio/libtunepimp/work/libtunepimp-0.5.3/lib'
wordt verlaten
gmake[1]: *** [all-recursive] Fout 1
gmake[1]: Map
'/usr/home/rene/freebsd/ports/audio/libtunepimp/work/libtunepimp-0.5.3'
wordt verlaten
gmake: *** [all] Fout 2
*** Error code 1

Do you have a fix for these errors?

Rene
-- 
http://www.rene-ladan.nl/

GPG fingerprint = ADBC ECCD EB5F A6B4 549F  600D 8C9E 647A E564 2BFC
(subkeys.pgp.net)
Comment 6 Andriy Gapon 2010-06-20 17:59:44 UTC
on 20/06/2010 19:51 Rene Ladan said the following:
> When trying to build the port with gcc-4.4.5.20100608 on a
> 9.0-CURRENT/amd64 box (r209035, all ports reinstalled after updating),
> after adding this patch to fix some compiler errors:
> 
> % cat files/patch-lib_fileio.cpp
> --- lib/fileio.cpp.orig	2006-11-18 11:52:33.000000000 +0100
> +++ lib/fileio.cpp	2010-06-20 18:37:34.000000000 +0200
> @@ -28,6 +28,8 @@
>  #include <assert.h>
>  #include <errno.h>
> +#include <stdlib.h>
>  #include <string>
> +#include <string.h>
>  #ifndef WIN32
>  #include <unistd.h>
>  #endif
> 
> I'm getting linker errors (fileio.cpp is not involved):
> 
> libtool: link: c++ -shared -nostdlib /usr/lib/crti.o

I see that here c++ is invoked instead if g++45.
Not sure now if I had this problem here and how I fixed it.

> /usr/lib/crtbeginS.o  .libs/tunepimp.o .libs/filecache.o
> .libs/analyzer.o .libs/dirsearch.o .libs/metadata.o .libs/astrcmp.o
> .libs/track.o .libs/write.o .libs/c_wrapper.o .libs/watchdog.o
> .libs/plugins.o .libs/readmeta.o .libs/fileio.o .libs/protocol.o
> -Wl,--whole-archive threads/posix/.libs/libtpthread.a
> utf8/.libs/libutf8.a ../libltdl/.libs/libltdlc.a -Wl,--no-whole-archive
>  -Wl,-rpath -Wl,/usr/local/lib -Wl,-rpath -Wl,/usr/local/lib
> -L/usr/local/lib -pthread /usr/local/lib/libcurl.so
> /usr/local/lib/libidn.so /usr/local/lib/libintl.so
> /usr/local/lib/libiconv.so /usr/local/lib/libssh2.so
> /usr/local/lib/libldap.so /usr/local/lib/liblber.so -lssl -lcrypto -lz
> /usr/local/lib/libofa.so /usr/local/lib/libfftw3.so
> /usr/local/lib/libmusicbrainz.so /usr/local/lib/libexpat.so -L/usr/lib
> -lstdc++ -lm -lc -lgcc_s /usr/lib/crtendS.o /usr/lib/crtn.o
> -march=nocona -pthread   -pthread -Wl,-soname -Wl,libtunepimp.so.5 -o
> .libs/libtunepimp.so.5
> local symbol 0: discarded in section `.text._ZN8MetadataD1Ev' from
> .libs/filecache.o
> local symbol 1: discarded in section
> `.text._ZNSt6vectorIP5TrackSaIS1_EE13_M_insert_auxEN9__gnu_cxx17__normal_iteratorIPS1_S3_EERKS1_'
> from .libs/filecache.o
> local symbol 2: discarded in section `.text._ZN8MetadataD1Ev' from
> .libs/analyzer.o
> local symbol 3: discarded in section `.text._ZN8MetadataD1Ev' from
> .libs/metadata.o
> local symbol 4: discarded in section `.text._ZN13FileNameMakerD1Ev' from
> .libs/write.o
> local symbol 5: discarded in section `.text._ZN8MetadataD1Ev' from
> .libs/write.o
> local symbol 6: discarded in section `.text._ZN8MetadataC1ERKS_' from
> .libs/write.o
> local symbol 7: discarded in section
> `.text._ZStplIcSt11char_traitsIcESaIcEESbIT_T0_T1_ERKS6_S8_' from
> .libs/write.o
> local symbol 8: discarded in section `.text._ZN13FileNameMakerD0Ev' from
> .libs/write.o
> local symbol 9: discarded in section
> `.text._ZStplIcSt11char_traitsIcESaIcEESbIT_T0_T1_EPKS3_RKS6_' from
> .libs/write.o
> local symbol 10: discarded in section `.text._ZN15MetadataCompareD1Ev'
> from .libs/c_wrapper.o
> local symbol 11: discarded in section `.text._ZN15MetadataCompareD0Ev'
> from .libs/c_wrapper.o
> local symbol 12: discarded in section
> `.text._ZNSt8_Rb_treeI12TPFileStatusSt4pairIKS0_iESt10_Select1stIS3_ESt4lessIS0_ESaIS3_EE10_M_insert_EPKSt18_Rb_tree_node_baseSC_RKS3_'
> from .libs/c_wrapper.o
> local symbol 13: discarded in section
> `.text._ZNSt8_Rb_treeI12TPFileStatusSt4pairIKS0_iESt10_Select1stIS3_ESt4lessIS0_ESaIS3_EE16_M_insert_uniqueERKS3_'
> from .libs/c_wrapper.o
> local symbol 14: discarded in section
> `.text._ZNSt8_Rb_treeI12TPFileStatusSt4pairIKS0_iESt10_Select1stIS3_ESt4lessIS0_ESaIS3_EE17_M_insert_unique_ESt23_Rb_tree_const_iteratorIS3_ERKS3_'
> from .libs/c_wrapper.o
> local symbol 15: discarded in section
> `.text._ZNSt6vectorIiSaIiEE13_M_insert_auxEN9__gnu_cxx17__normal_iteratorIPiS1_EERKi'
> from .libs/c_wrapper.o
> local symbol 16: discarded in section `.text._ZNSt6vectorISsSaISsEED1Ev'
> from .libs/c_wrapper.o
> local symbol 17: discarded in section `.text._ZN8MetadataD1Ev' from
> .libs/c_wrapper.o
> local symbol 18: discarded in section
> `.text._ZNSt6vectorISsSaISsEE13_M_insert_auxEN9__gnu_cxx17__normal_iteratorIPSsS1_EERKSs'
> from .libs/plugins.o
> local symbol 19: discarded in section `.text._ZN13FileNameMakerD1Ev'
> from .libs/readmeta.o
> local symbol 20: discarded in section `.text._ZN13FileNameMakerD0Ev'
> from .libs/readmeta.o
> local symbol 21: discarded in section `.text._ZN8MetadataD1Ev' from
> .libs/readmeta.o
> gmake[3]: *** [libtunepimp.la] Fout 1
> gmake[3]: Map
> '/usr/home/rene/freebsd/ports/audio/libtunepimp/work/libtunepimp-0.5.3/lib'
> wordt verlaten
> gmake[2]: *** [all-recursive] Fout 1
> gmake[2]: Map
> '/usr/home/rene/freebsd/ports/audio/libtunepimp/work/libtunepimp-0.5.3/lib'
> wordt verlaten
> gmake[1]: *** [all-recursive] Fout 1
> gmake[1]: Map
> '/usr/home/rene/freebsd/ports/audio/libtunepimp/work/libtunepimp-0.5.3'
> wordt verlaten
> gmake: *** [all] Fout 2
> *** Error code 1
> 
> Do you have a fix for these errors?
> 
> Rene


-- 
Andriy Gapon
Comment 7 Rene Ladan freebsd_committer 2010-06-20 18:09:06 UTC
2010/6/20 Andriy Gapon <avg@icyb.net.ua>:
> on 20/06/2010 19:51 Rene Ladan said the following:
>> I'm getting linker errors (fileio.cpp is not involved):
>>
>> libtool: link: c++ -shared -nostdlib /usr/lib/crti.o
>
> I see that here c++ is invoked instead if g++45.
> Not sure now if I had this problem here and how I fixed it.
>
Good catch.  It might be that the port is not respecting CC and/or
CXX in all situations. I'll look into it.  The reference to /usr/lib/crti.o
seems correct, as I have is no gcc44-specific version installed.

Rene
Comment 8 Rene Ladan freebsd_committer 2010-06-20 19:35:59 UTC
The build breaks in work/libtunepimp-0.5.3/lib, but there are no
instances of "c++" in the Makefile there. The instances of "CXX" are
(commented out instances removed):

grep CXX Makefile | grep -v ^#
CXXCOMPILE = $(CXX) $(DEFS) $(DEFAULT_INCLUDES) $(INCLUDES) \
	$(AM_CPPFLAGS) $(CPPFLAGS) $(AM_CXXFLAGS) $(CXXFLAGS)
LTCXXCOMPILE = $(LIBTOOL) --tag=CXX --mode=compile $(CXX) $(DEFS) \
	$(AM_CXXFLAGS) $(CXXFLAGS)
CXXLD = $(CXX)
CXXLINK = $(LIBTOOL) --tag=CXX --mode=link $(CXXLD) $(AM_CXXFLAGS) \
	$(CXXFLAGS) $(AM_LDFLAGS) $(LDFLAGS) -o $@
CXX = g++44
CXXCPP = g++44 -E
CXXDEPMODE = depmode=gcc3
CXXFLAGS = -O2 -pipe -march=nocona -fno-strict-aliasing
ac_ct_CXX =
am__fastdepCXX_FALSE = #
am__fastdepCXX_TRUE =
	$(CXXLINK)  $(libpluginsupport_la_LDFLAGS)
$(libpluginsupport_la_OBJECTS) $(libpluginsupport_la_LIBADD) $(LIBS)
	$(CXXLINK) -rpath $(libdir) $(libtunepimp_la_LDFLAGS)
$(libtunepimp_la_OBJECTS) $(libtunepimp_la_LIBADD) $(LIBS)
	if $(CXXCOMPILE) -MT $@ -MD -MP -MF "$(DEPDIR)/$*.Tpo" -c -o $@ $<; \
	if $(CXXCOMPILE) -MT $@ -MD -MP -MF "$(DEPDIR)/$*.Tpo" -c -o $@
`$(CYGPATH_W) '$<'`; \
	if $(LTCXXCOMPILE) -MT $@ -MD -MP -MF "$(DEPDIR)/$*.Tpo" -c -o $@ $<; \

libtunepimp.la is built with:
libtunepimp.la: $(libtunepimp_la_OBJECTS) $(libtunepimp_la_DEPENDENCIES)
        $(CXXLINK) -rpath $(libdir) $(libtunepimp_la_LDFLAGS)
$(libtunepimp_la_OBJECTS) $(libtunepimp_la_LIBADD) $(LIBS)

So it all looks correct?

Rene
Comment 9 Andriy Gapon 2010-06-21 08:09:04 UTC
on 20/06/2010 21:35 Rene Ladan said the following:
> The build breaks in work/libtunepimp-0.5.3/lib, but there are no
> instances of "c++" in the Makefile there. The instances of "CXX" are
> (commented out instances removed):
> 
> grep CXX Makefile | grep -v ^#
[output snipped]

It looks correct as far as I can tell.

But I can't reproduce the linking problem you had.

BTW, it seems that I missed to submit another patch file:

****** files/patch-lib_fileio.cpp *******************
--- lib/fileio.cpp.orig	2010-06-21 10:03:16.263147090 +0300
+++ lib/fileio.cpp	2010-06-21 10:03:49.123357985 +0300
@@ -28,6 +28,8 @@
 #include <assert.h>
 #include <errno.h>
 #include <string>
+#include <string.h>
+#include <stdlib.h>
 #ifndef WIN32
 #include <unistd.h>
 #endif

-- 
Andriy Gapon
Comment 10 Andriy Gapon 2010-06-21 08:14:02 UTC
on 20/06/2010 19:51 Rene Ladan said the following:
> When trying to build the port with gcc-4.4.5.20100608 on a
> 9.0-CURRENT/amd64 box (r209035, all ports reinstalled after updating),
> after adding this patch to fix some compiler errors:
> 
> % cat files/patch-lib_fileio.cpp
> --- lib/fileio.cpp.orig	2006-11-18 11:52:33.000000000 +0100
> +++ lib/fileio.cpp	2010-06-20 18:37:34.000000000 +0200
> @@ -28,6 +28,8 @@
>  #include <assert.h>
>  #include <errno.h>
> +#include <stdlib.h>
>  #include <string>
> +#include <string.h>
>  #ifndef WIN32
>  #include <unistd.h>
>  #endif

Oops - I originally missed this part of your email.


> I'm getting linker errors (fileio.cpp is not involved):
> 
> libtool: link: c++ -shared -nostdlib /usr/lib/crti.o
> /usr/lib/crtbeginS.o  .libs/tunepimp.o .libs/filecache.o
> .libs/analyzer.o .libs/dirsearch.o .libs/metadata.o .libs/astrcmp.o
> .libs/track.o .libs/write.o .libs/c_wrapper.o .libs/watchdog.o
> .libs/plugins.o .libs/readmeta.o .libs/fileio.o .libs/protocol.o
> -Wl,--whole-archive threads/posix/.libs/libtpthread.a
> utf8/.libs/libutf8.a ../libltdl/.libs/libltdlc.a -Wl,--no-whole-archive
>  -Wl,-rpath -Wl,/usr/local/lib -Wl,-rpath -Wl,/usr/local/lib
> -L/usr/local/lib -pthread /usr/local/lib/libcurl.so
> /usr/local/lib/libidn.so /usr/local/lib/libintl.so
> /usr/local/lib/libiconv.so /usr/local/lib/libssh2.so
> /usr/local/lib/libldap.so /usr/local/lib/liblber.so -lssl -lcrypto -lz
> /usr/local/lib/libofa.so /usr/local/lib/libfftw3.so
> /usr/local/lib/libmusicbrainz.so /usr/local/lib/libexpat.so -L/usr/lib
> -lstdc++ -lm -lc -lgcc_s /usr/lib/crtendS.o /usr/lib/crtn.o
> -march=nocona -pthread   -pthread -Wl,-soname -Wl,libtunepimp.so.5 -o
> .libs/libtunepimp.so.5

BTW, this is how this invocation looks in my environment:
libtool: link: g++44 -shared -nostdlib /usr/lib/crti.o
/usr/local/lib/gcc44/gcc/x86_64-portbld-freebsd9.0/4.4.5/crtbeginS.o
.libs/tunepimp.o .libs/filecache.o .libs/analyzer.o .libs/dirsearch.o
.libs/metadata.o .libs/astrcmp.o .libs/track.o .libs/write.o .libs/c_wrapper.o
.libs/watchdog.o .libs/plugins.o .libs/readmeta.o .libs/fileio.o
.libs/protocol.o  -Wl,--whole-archive threads/posix/.libs/libtpthread.a
utf8/.libs/libutf8.a ../libltdl/.libs/libltdlc.a -Wl,--no-whole-archive
-Wl,-rpath -Wl,/usr/local/lib -Wl,-rpath -Wl,/usr/local/lib -L/usr/local/lib
-pthread /usr/local/lib/libiconv.so /usr/local/lib/libcurl.so
/usr/local/lib/libcares.so /usr/local/lib/libssh2.so -lssl -lcrypto -lz
/usr/local/lib/libofa.so /usr/local/lib/libfftw3.so
/usr/local/lib/libmusicbrainz.so /usr/local/lib/libexpat.so
-L/usr/local/lib/gcc44/gcc/x86_64-portbld-freebsd9.0/4.4.5
-L/usr/local/lib/gcc44/gcc/x86_64-portbld-freebsd9.0/4.4.5/../../../../../x86_64-portbld-freebsd9.0/lib
-L/usr/local/lib/gcc44/gcc/x86_64-portbld-freebsd9.0/4.4.5/../../.. -lstdc++ -lm
-lgcc_s /usr/local/lib/gcc44/gcc/x86_64-portbld-freebsd9.0/4.4.5/crtendS.o
/usr/lib/crtn.o  -march=amdfam10 -pthread   -pthread -Wl,-soname
-Wl,libtunepimp.so.5 -o .libs/libtunepimp.so.5

-- 
Andriy Gapon
Comment 11 dfilter service freebsd_committer 2010-07-12 12:39:47 UTC
rene        2010-07-12 11:39:31 UTC

  FreeBSD ports repository

  Modified files:
    audio/libtunepimp/files patch-lib-metadata.cpp 
                            patch-lib-utf8-utf8util.cpp 
                            patch-plugins-mp4-mp4.cpp 
                            patch-plugins-wav-wav.cpp 
  Added files:
    audio/libtunepimp/files patch-include_tunepimp-0.5_metadata.h 
                            patch-lib_c_wrapper.cpp 
                            patch-lib_fileio.cpp 
                            patch-lib_protocol.cpp 
                            patch-lib_readmeta.cpp 
                            patch-lib_tunepimp.cpp 
                            patch-plugins_mp3_id3_2_3_meta.cpp 
                            patch-plugins_mp3_id3_meta.cpp 
                            patch-plugins_wma_wma.cpp 
                            patch-plugins_wma_wmafile.cpp 
  Log:
  Make compilable with gcc 4.4
  
  PR:             ports/147639
  Submitted by:   Andriy Gapon [avg icyb.net.ua]
  Approved by:    maintainer, tabthorpe (mentor)
  
  Revision  Changes    Path
  1.1       +10 -0     ports/audio/libtunepimp/files/patch-include_tunepimp-0.5_metadata.h (new)
  1.4       +11 -3     ports/audio/libtunepimp/files/patch-lib-metadata.cpp
  1.4       +12 -4     ports/audio/libtunepimp/files/patch-lib-utf8-utf8util.cpp
  1.1       +10 -0     ports/audio/libtunepimp/files/patch-lib_c_wrapper.cpp (new)
  1.1       +11 -0     ports/audio/libtunepimp/files/patch-lib_fileio.cpp (new)
  1.1       +10 -0     ports/audio/libtunepimp/files/patch-lib_protocol.cpp (new)
  1.1       +10 -0     ports/audio/libtunepimp/files/patch-lib_readmeta.cpp (new)
  1.1       +10 -0     ports/audio/libtunepimp/files/patch-lib_tunepimp.cpp (new)
  1.2       +4 -4      ports/audio/libtunepimp/files/patch-plugins-mp4-mp4.cpp
  1.4       +3 -3      ports/audio/libtunepimp/files/patch-plugins-wav-wav.cpp
  1.1       +10 -0     ports/audio/libtunepimp/files/patch-plugins_mp3_id3_2_3_meta.cpp (new)
  1.1       +10 -0     ports/audio/libtunepimp/files/patch-plugins_mp3_id3_meta.cpp (new)
  1.1       +10 -0     ports/audio/libtunepimp/files/patch-plugins_wma_wma.cpp (new)
  1.1       +10 -0     ports/audio/libtunepimp/files/patch-plugins_wma_wmafile.cpp (new)
_______________________________________________
cvs-all@freebsd.org mailing list
http://lists.freebsd.org/mailman/listinfo/cvs-all
To unsubscribe, send any mail to "cvs-all-unsubscribe@freebsd.org"
Comment 12 Rene Ladan freebsd_committer 2010-07-12 12:42:20 UTC
State Changed
From-To: feedback->closed

Committed, thanks