Bug 148 - auvoxware dumps core sometimes after playing file
Summary: auvoxware dumps core sometimes after playing file
Status: Closed FIXED
Alias: None
Product: Base System
Classification: Unclassified
Component: kern (show other bugs)
Version: Unspecified
Hardware: Any Any
: Normal Affects Only Me
Assignee: freebsd-bugs (Nobody)
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 1995-01-16 18:40 UTC by Stephen Hocking
Modified: 1995-01-16 18:40 UTC (History)
0 users

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Stephen Hocking 1995-01-16 18:40:02 UTC
Has been observed on two machines, although the problem is more common on the
slower machine. At the end of playing a sound, the auvoxware program would die
with a signal 10.  Recompiling with debugging info and linking static gave
little joy - gdb claimed that it was unable to display stuff at a particular
address. Also at this kernel level, xdm will occasionally exit with a SIG 10,
leaving the X server running without any xdm prompt. At the risk of annoying
the crap out of people who know better, I'd think, judging on where it dies,
that signal handling was involved.

Fix: 

Yes please.
How-To-Repeat: 
	Compile auvoxware from the nas-1.2p1 package, and play any sound. Do
a few times to make sure.
Comment 1 Joerg Wunsch freebsd_committer 1995-04-03 21:27:30 UTC
State Changed
From-To: open->closed

Stephen Hocking, who submitted the PR, claims 
it's fixed now.