Bug 148439 - net-mgmt/cacti-spine does not compile due to a net-snmp dependency failure
Summary: net-mgmt/cacti-spine does not compile due to a net-snmp dependency failure
Status: Closed FIXED
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: Normal Affects Only Me
Assignee: Steven Kreuzer
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2010-07-07 23:40 UTC by Eric Cables
Modified: 2010-12-22 15:00 UTC (History)
0 users

See Also:


Attachments
file.txt (62.73 KB, text/plain)
2010-07-07 23:40 UTC, Eric Cables
no flags Details
pkg-list.txt (15.76 KB, text/plain; charset=US-ASCII)
2010-07-07 23:51 UTC, Eric Cables
no flags Details

Note You need to log in before you can comment on or make changes to this bug.
Description Eric Cables 2010-07-07 23:40:01 UTC
After upgrading numerous ports, I noticed that net-mgmt/cacti-spine would not compile.  After investigation it appears that this is a known bug (PR 141238), and has supposedly been fixed.  Please see the config.log for full details of the error message.

Fix: This was supposedly fixed in PR 141238, but as of 7/7/2010, with an updated ports tree, I am still experiencing this problem.

Patch attached with submission follows:
How-To-Repeat: Attempt to compile net-mgmt/cacti-spine.
Comment 1 Edwin Groothuis freebsd_committer 2010-07-07 23:40:15 UTC
Responsible Changed
From-To: freebsd-ports-bugs->skreuzer

Over to maintainer (via the GNATS Auto Assign Tool)
Comment 2 Eric Cables 2010-07-07 23:51:57 UTC
Attached is a list of installed ports.

-- Eric Cables
Comment 3 Wesley Shields freebsd_committer 2010-11-25 13:45:22 UTC
Eric and Steve,

A workaround is to rebuild net-mgmt/net-snmp with PERL_EMBEDDED knob
turned off.  After doing that net-mgmt/cacti-spine should build
properly.

Getting the proper fix in place would require figuring out the actual
bug in net-mgmt/net-snmp and working with sylvio@, the current
maintainer, who is on CC.

Sylvio,

My apologies for not providing more than this, but you can reproduce the
bug on a recent 8-STABLE (or newer?) i386 system. It's also showing up
on pointyhat and I believe the root cause is somehow involved in using
the PERL_EMBEDDED option in net-mgmt/net-snmp.

-- WXS
Comment 4 dfilter service freebsd_committer 2010-12-22 14:53:28 UTC
skreuzer    2010-12-22 14:53:22 UTC

  FreeBSD ports repository

  Modified files:
    net-mgmt/cacti-spine Makefile 
  Log:
  For OSVERSION >= 800040, add -fstack-protector to LDFLAGS
  
  PR:             ports/148439
  Submitted by:   Eric Cables <ecables@gmail.com>
  
  Revision  Changes    Path
  1.27      +7 -1      ports/net-mgmt/cacti-spine/Makefile
_______________________________________________
cvs-all@freebsd.org mailing list
http://lists.freebsd.org/mailman/listinfo/cvs-all
To unsubscribe, send any mail to "cvs-all-unsubscribe@freebsd.org"
Comment 5 Steven Kreuzer freebsd_committer 2010-12-22 14:59:27 UTC
State Changed
From-To: open->closed

I believe this issue is fixed by building with stack protection