Bug 148587 - [New port] mail/squirrelmail-squirrel_logger-plugin: Logging functionality for your webmail interface
Summary: [New port] mail/squirrelmail-squirrel_logger-plugin: Logging functionality f...
Status: Closed FIXED
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: Normal Affects Only Me
Assignee: Thomas Abthorpe
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2010-07-14 06:20 UTC by Suzuki
Modified: 2010-08-05 15:20 UTC (History)
0 users

See Also:


Attachments
file.shar (4.81 KB, text/plain)
2010-07-14 06:20 UTC, Suzuki
no flags Details

Note You need to log in before you can comment on or make changes to this bug.
Description Suzuki 2010-07-14 06:20:05 UTC
Logging functionality for your webmail interface

Fix: Patch attached with submission follows:
Comment 1 Edwin Groothuis freebsd_committer 2010-07-14 06:20:15 UTC
Responsible Changed
From-To: freebsd-ports-bugs->tabthorpe

tabthorpe@ wants this port PRs (via the GNATS Auto Assign Tool)
Comment 2 Thomas Abthorpe freebsd_committer 2010-07-15 14:53:42 UTC
LS0tLS1CRUdJTiBQR1AgU0lHTkVEIE1FU1NBR0UtLS0tLQ0KSGFzaDogU0hBMQ0KDQpJbiB5b3Vy
IHBvcnQsIHlvdSBkZWNsYXJlZCBwb3J0c0AgdG8gYmUgdGhlIE1BSU5UQUlORVIsIGZvciBhIG5l
dyBwb3J0LCBpdCBpcw0KcHJlZmVyZWQgdG8gaGF2ZSBhIHByb3BlciBtYWludGFpbmVyLCBhcmUg
eW91IHByZXBhcmVkIHRvIHRha2UgaXQgb24/DQoNCg0KVGhvbWFzDQoNCi0gLS0gDQpUaG9tYXMg
QWJ0aG9ycGUJCXwgRnJlZUJTRCBDb21taXR0ZXINCnRhYnRob3JwZUBGcmVlQlNELm9yZwl8IGh0
dHA6Ly9wZW9wbGUuZnJlZWJzZC5vcmcvfnRhYnRob3JwZQ0KLS0tLS1CRUdJTiBQR1AgU0lHTkFU
VVJFLS0tLS0NClZlcnNpb246IEdudVBHIHYyLjAuMTUgKEZyZWVCU0QpDQoNCmlRRWNCQUVCQWdB
R0JRSk1QeEwxQUFvSkVOazNFSmVrYzhtUXlDa0gvMDA5OHJkVDJyZ2hWK3dRSnZESzdaa0YNCkFB
bEVBNGZ3MDdveDF1RXhVNUlvRE41NjMxV21KSENJczJsZnNnckQzQnRTMkxDbUwrZmptWDZGM0xC
eEVOb0ENCi9selVJN1d0NHhPVUd3Y3BkOWNIVk1vVVo4T25PSnAyaTA4ZlBNdk94RUd4cTFYVlg2
MUxYdk90RzVqd0Yyb1QNCnJ1Sjg5VmtJajZvcUtSdXg5bnh2M3ZDSEY2UTdHK0tlckZSWG5YOHMz
OWI2UXRieFFrb3JxWFBWRkZDRldpYlINCnM4SDFEMW0wV0VIVXRobXRMdGx5Q3pCT3crNHB5S3B6
d0lMM094d2xpRis5TTA4ZGJqbmtyRXo3Y1FKMWJ0TmgNCndLUG1EUXRjOVFaVldOR3hFdFNTbEZt
OU1PdlBkdVhqbkZ2cXJqb3RmK3R6OEwrbVBUUFlNNTBtdnQrRkxDYz0NCj0ySlMyDQotLS0tLUVO
RCBQR1AgU0lHTkFUVVJFLS0tLS0NCg==
Comment 3 Kazumi MORINAGA 2010-08-05 09:33:17 UTC
> In your port, you declared ports@ to be the MAINTAINER, for a new port, 
> it is prefered to have a proper maintainer, are you prepared to take it on?

I will be the maintainer of this ports.
Sorry for our overlooking the directions about MAINTAINER in the sample Makefile.

--
 Kazumi MORINAGA | RIKEN ACCC, Yokohama Team
 morinaga@riken.jp
Comment 4 dfilter service freebsd_committer 2010-08-05 15:13:45 UTC
tabthorpe    2010-08-05 14:13:30 UTC

  FreeBSD ports repository

  Modified files:
    mail                 Makefile 
  Added files:
    mail/squirrelmail-squirrel_logger-plugin Makefile distinfo 
                                             pkg-descr pkg-plist 
    mail/squirrelmail-squirrel_logger-plugin/files pkg-message.in 
  Log:
  This plugin implements logging functionality for your webmail interface.
  You can choose to log to a database, a file, your system log, or any
  combination thereof. You can also choose which kinds of events to log,
  including login events, logout events, login error events, all outgoing
  messages, possible outgoing spam messages, and other error events.
  
  Also included is monitoring functionality that will send alert emails to
  the administrator when certain events trigger.
  
  If you use the timeout_user plugin, logout events caused by user timeouts
  will be captured.
  
  Log message format is also completely custom-defined to meet your needs
  in the configuration file.
  
  WWW: http://www.squirrelmail.org/plugin_view.php?id=52
  
  PR:             ports/148587
  Submitted by:   Satoru Suzuki <xsuzu at yokohama.riken.jp>
  
  Revision  Changes    Path
  1.1029    +1 -0      ports/mail/Makefile
  1.1       +26 -0     ports/mail/squirrelmail-squirrel_logger-plugin/Makefile (new)
  1.1       +3 -0      ports/mail/squirrelmail-squirrel_logger-plugin/distinfo (new)
  1.1       +7 -0      ports/mail/squirrelmail-squirrel_logger-plugin/files/pkg-message.in (new)
  1.1       +16 -0     ports/mail/squirrelmail-squirrel_logger-plugin/pkg-descr (new)
  1.1       +18 -0     ports/mail/squirrelmail-squirrel_logger-plugin/pkg-plist (new)
_______________________________________________
cvs-all@freebsd.org mailing list
http://lists.freebsd.org/mailman/listinfo/cvs-all
To unsubscribe, send any mail to "cvs-all-unsubscribe@freebsd.org"
Comment 5 Thomas Abthorpe freebsd_committer 2010-08-05 15:16:06 UTC
State Changed
From-To: open->closed

New port added. Thanks!