Bug 149087 - editors/openoffice.org-3 does not compile
Summary: editors/openoffice.org-3 does not compile
Status: Closed FIXED
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: Normal Affects Only Me
Assignee: freebsd-openoffice (Nobody)
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2010-07-30 01:10 UTC by Hans-Werner Braun
Modified: 2010-10-19 18:50 UTC (History)
0 users

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Hans-Werner Braun 2010-07-30 01:10:01 UTC
openoffice.org-3 does not compile. The problem is with the diablo-jdk-1.6.0.07.02_9 part:

===>   diablo-jdk-1.6.0.07.02_9 depends on shared library: z.4 - not found
===>    Verifying install for z.4 in /usr/ports/misc/compat7x
===>   Returning to build of diablo-jdk-1.6.0.07.02_9
Error: shared library "z.4" does not exist
*** Error code 1

The only libz files I found are:

/lib/libz.so.5
/usr/lib/libz.a
/usr/lib/libz.so

How-To-Repeat: "make" repeats the problem
Comment 1 Mark Linimon freebsd_committer freebsd_triage 2010-07-30 02:29:38 UTC
Responsible Changed
From-To: freebsd-bugs->openoffice

Fix synopsis and assign.
Comment 2 Hans-Werner Braun 2010-08-04 02:00:26 UTC
I think the problem is that during the 8.1 system installation
/usr/local/lib/compat was installed with group write permission, and
consequently that directory was refused during boot time. Removing the
group write permission made make find shared library "z.4"
Comment 3 Eric F Crist 2010-10-19 18:10:03 UTC
This issue is really with compat7x, which uses mkdir to create the =
/usr/local/lib/compat directory, without using a -m to mkdir to =
explicitly set modes.  As is, it honors your currently set umask.

This ticket is a red herring, and should probably be closed.
---
Eric F Crist
System Administrator
ClaimLynx, Inc
(952) 593-5969 x2301
Comment 4 Renato Botelho freebsd_committer 2010-10-19 18:49:55 UTC
State Changed
From-To: open->closed

compat7x was changed to create compat with correct permissions