Bug 149516 - [ath] ath(4) hostap with fake MAC/BSSID results in station dropping packets when associated
Summary: [ath] ath(4) hostap with fake MAC/BSSID results in station dropping packets w...
Status: Open
Alias: None
Product: Base System
Classification: Unclassified
Component: wireless (show other bugs)
Version: 8.1-RELEASE
Hardware: Any Any
: Normal Affects Only Me
Assignee: freebsd-wireless (Nobody)
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2010-08-11 08:40 UTC by Martin
Modified: 2018-05-28 19:44 UTC (History)
2 users (show)

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Martin 2010-08-11 08:40:03 UTC
I noticed a bug that was introduced somewhere in the Atheros 9280 support in 8.1-RELEASE when used as a station. I had this already running correctly with 7.x releases.

What happens:

I cannot connect to a hostap ath(4) (Atheros 2413) when using a fake MAC/BSSID (on the hostap!).

Further information:

- This only affects ath(4) and I could only see this on Atheros 9280, because I don't have any other ath(4) adapters at the moment.
- I tried rum(4). It does not have any problems like this. DHCP and everything else works with this driver (of course with a fake MAC/BSSID!).
- Running 8.1-RELEASE on all machines. Kernel is GENERIC, but on hostap machine there is ALTQ added (should not affect anything, as I said, I had this running already).
- hostapd is configured with 11g, WPA2 and passwords in hostapd.wpapsk. WME is switched off, because it does not work at all for me.

I can provide more information, if needed.

How-To-Repeat: 1) Put this into your rc.local on your hostap machine and replace xx's by an address of your choice (first octet needs to have lowest bit "0"):

ifconfig ath0 ether xx:xx:xx:xx:xx:xx

2) Start hostapd (must be configured, of course). Eventually you need to set BSSID also in hostapd.conf.

3) Try to connect with an Atheros 9280. You don't need to fake MAC address here (I'm only talking about the hostap MAC/BSSID).

What you get:

- You get association. This is OK, so far.
- Try DHCP. You won't see packets arriving at the station. They are not recognized and filtered somewhere.
- When you watch with tcpdump on the hostap interface you'll see DHCP requests arriving and being answered.
- I further noticed, even you don't have any IP (set to 0.0.0.0, because of failed DHCP), you can see packets being sent to different machines (so the net connection is physically available)
- You can try to setup a static address, but when you ping the station, you don't see a ping arriving (watch tcpdump on the station wireless interface and try to ping from the hostap machine).
Comment 1 Mark Linimon freebsd_committer freebsd_triage 2010-08-12 01:09:20 UTC
Responsible Changed
From-To: freebsd-bugs->freebsd-net

Over to maintainer(s).
Comment 2 Adrian Chadd freebsd_committer 2011-04-11 12:39:47 UTC
Responsible Changed
From-To: freebsd-net->freebsd-wireless

punt to wireless list
Comment 3 Martin 2012-11-29 19:35:05 UTC
Confirmed on 9.0-RELEASE-p3. Bug still exists.

--
Martin
Comment 4 martin 2017-01-14 07:53:37 UTC
Confirmed on FreeBSD 11.0. Bug still exists.

I've tried to configure wireless failover as the FreeBSD handbook suggests. This is not possibile.

At the time I wrote this bug report, I assumed that it only affects ath(4). Now I reproduced it on ral(4).

Further change is that the interface does not even associate anymore.

Please update my old email address, if it's possible. There are also a lot of duplicate reports by now (see: bug #213207 for example).

--
Martin
Comment 5 Eitan Adler freebsd_committer freebsd_triage 2018-05-28 19:44:16 UTC
batch change:

For bugs that match the following
-  Status Is In progress 
AND
- Untouched since 2018-01-01.
AND
- Affects Base System OR Documentation

DO:

Reset to open status.


Note:
I did a quick pass but if you are getting this email it might be worthwhile to double check to see if this bug ought to be closed.