Bug 149607 - sysutils/confman needs BUILD_DEPENDS set
Summary: sysutils/confman needs BUILD_DEPENDS set
Status: Closed FIXED
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: Normal Affects Only Me
Assignee: freebsd-ports-bugs (Nobody)
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2010-08-13 04:00 UTC by ben
Modified: 2010-08-15 09:20 UTC (History)
0 users

See Also:


Attachments
file.diff (474 bytes, patch)
2010-08-13 04:00 UTC, ben
no flags Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description ben 2010-08-13 04:00:17 UTC
The sysutils/confman port needs BUILD_DEPENDS set so that the dependencies are installed before ./configure runs.

Fix: Apply the attached patch, which sets BUILD_DEPENDS equal to RUN_DEPENDS.

Patch attached with submission follows:
How-To-Repeat: Install sysutils/confman without having its dependencies installed already.
Comment 1 Edwin Groothuis freebsd_committer 2010-08-13 04:10:32 UTC
Maintainer of sysutils/confman,

Please note that PR ports/149607 has just been submitted.

If it contains a patch for an upgrade, an enhancement or a bug fix
you agree on, reply to this email stating that you approve the patch
and a committer will take care of it.

The full text of the PR can be found at:
    http://www.freebsd.org/cgi/query-pr.cgi?pr=ports/149607

-- 
Edwin Groothuis via the GNATS Auto Assign Tool
edwin@FreeBSD.org
Comment 2 Edwin Groothuis freebsd_committer 2010-08-13 04:10:34 UTC
State Changed
From-To: open->feedback

Awaiting maintainers feedback (via the GNATS Auto Assign Tool)
Comment 3 Chris Cowart 2010-08-13 16:57:47 UTC
This is a duplicate of ports/149345. However, the patch was made against
a more current version of the port (I didn't realize things had been
bumped for some apr refactoring), so I approve this change and recommend
that ports/149345 be closed.

Thanks!

-- 
Chris Cowart
  http://www.timesinks.net/
Comment 4 Tilman Keskinoz freebsd_committer 2010-08-15 09:10:52 UTC
State Changed
From-To: feedback->closed

committed, thanks
Comment 5 dfilter service freebsd_committer 2010-08-15 09:10:54 UTC
arved       2010-08-15 08:10:45 UTC

  FreeBSD ports repository

  Modified files:
    sysutils/confman     Makefile 
  Log:
  Add BUILD_DEPENDS
  
  PR:             149607
  Submitted by:   Benjamin Lee <ben@b1c1l1.com>
  Approved by:    maintainer
  
  Revision  Changes    Path
  1.9       +2 -1      ports/sysutils/confman/Makefile
_______________________________________________
cvs-all@freebsd.org mailing list
http://lists.freebsd.org/mailman/listinfo/cvs-all
To unsubscribe, send any mail to "cvs-all-unsubscribe@freebsd.org"