Bug 150309 - [PATCH] print/cups-base: cups ports have duplicated UNIQUENAME
Summary: [PATCH] print/cups-base: cups ports have duplicated UNIQUENAME
Status: Closed FIXED
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: Normal Affects Only Me
Assignee: Dirk Meyer
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2010-09-06 00:30 UTC by mwisnicki+freebsd
Modified: 2010-11-17 09:15 UTC (History)
1 user (show)

See Also:


Attachments
cups-base-1.4.4.patch (517 bytes, patch)
2010-09-06 00:30 UTC, mwisnicki+freebsd
no flags Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description mwisnicki+freebsd 2010-09-06 00:30:07 UTC
Make UNIQUENAME uniqe.
Among other things, this prevents overwriting options file every time you build another cups-* port.

Port maintainer (dinoex@FreeBSD.org) is cc'd.

Generated with FreeBSD Port Tools 0.99
Comment 1 Edwin Groothuis freebsd_committer 2010-09-06 00:30:46 UTC
Responsible Changed
From-To: freebsd-ports-bugs->dinoex

Over to maintainer (via the GNATS Auto Assign Tool)
Comment 2 dfilter service freebsd_committer 2010-09-07 20:35:28 UTC
dinoex      2010-09-07 19:35:15 UTC

  FreeBSD ports repository

  Modified files:
    print/cups-base      Makefile 
  Log:
  - fix options by forcing UNIQUENAME
  PR:             150309
  Submitted by:   Marcin Wisnicki
  
  Revision  Changes    Path
  1.144     +2 -1      ports/print/cups-base/Makefile
_______________________________________________
cvs-all@freebsd.org mailing list
http://lists.freebsd.org/mailman/listinfo/cvs-all
To unsubscribe, send any mail to "cvs-all-unsubscribe@freebsd.org"
Comment 3 Dirk Meyer freebsd_committer 2010-09-07 20:39:24 UTC
State Changed
From-To: open->closed

committedw ith modifications, thanks.
Comment 4 swell.k 2010-09-25 08:47:04 UTC
This breaks OPTIONS in print/cups-client on my box, unselecting GNUTLS
no longer works. I think it affects other slave ports as well.

  $ cd print/cups-client
  $ make config (unselect GNUTLS)
  $ make -V WITHOUT_GNUTLS

  $ make -V WITH_GNUTLS
  true
  $ make package-depends
  gnutls-2.8.6_2:security/gnutls
  libgcrypt-1.4.6:security/libgcrypt
  libgpg-error-1.8:security/libgpg-error
  lzo2-2.03_2:archivers/lzo2
  libiconv-1.13.1_1:converters/libiconv
  pkg-config-0.25_1:devel/pkg-config
Comment 5 dfilter service freebsd_committer 2010-09-25 16:08:32 UTC
dinoex      2010-09-25 15:08:26 UTC

  FreeBSD ports repository

  Modified files:
    print/cups-base      Makefile 
  Log:
  - revert patch
  PR:             150309
  
  Revision  Changes    Path
  1.145     +0 -1      ports/print/cups-base/Makefile
_______________________________________________
cvs-all@freebsd.org mailing list
http://lists.freebsd.org/mailman/listinfo/cvs-all
To unsubscribe, send any mail to "cvs-all-unsubscribe@freebsd.org"
Comment 6 mwisnicki+freebsd 2010-09-25 17:42:05 UTC
Please:
1. Always reopen bug when reverting patch and notify submitter.
2. Always test it locally.

[yesterday's ports, before patch was reverted]:

$ cd /usr/ports/print/cups-client/
$ make rmconfig
$ make config # unselect GNUTLS
$ make showconfig
===> The following configuration options are available for cups-client-1.4.4:
     GNUTLS=off "Build with GNUTLS library"
===> Use 'make config' to modify these settings
$ make -V WITHOUT_GNUTLS
true

$ make -V WITH_GNUTLS

$

Thanks.
Comment 7 Dirk Meyer freebsd_committer 2010-09-26 19:21:04 UTC
State Changed
From-To: closed->analyzed

- no solution found
Comment 8 dirk.meyer 2010-09-27 02:25:01 UTC
Marcin Wisnicki schrieb:,

> Please:
> 1. Always reopen bug when reverting patch and notify submitter.

This is not possible without ssh accesss.
So the reopen had to be delayed.

> 2. Always test it locally.
> 
> [yesterday's ports, before patch was reverted]:
> 
> $ cd /usr/ports/print/cups-client/
> $ make rmconfig
> $ make config # unselect GNUTLS
> $ make showconfig
> ===> The following configuration options are available for cups-client-1.4.4:
>      GNUTLS=off "Build with GNUTLS library"
> ===> Use 'make config' to modify these settings
> $ make -V WITHOUT_GNUTLS
> true
> 
> $ make -V WITH_GNUTLS
> 
> $

Options did us the wrong file,
I could reproduce the problem with a clean /var/db/ports
before reverting.

kind regards Dirk

- Dirk Meyer, Im Grund 4, 34317 Habichtswald, Germany
- [dirk.meyer@dinoex.sub.org],[dirk.meyer@guug.de],[dinoex@FreeBSD.org]
Comment 9 mwisnicki 2010-09-29 17:30:17 UTC
I cannot reproduce your problem with my patch:

$ cd /usr/ports
$ rm -rf print/cups*
$ make update

$ make __MAKE_CONF=/dev/null PORT_DBDIR=/var/empty -C print/cups-base
-V OPTIONSFILE
/var/empty/cups/options
$ make __MAKE_CONF=/dev/null PORT_DBDIR=/var/empty -C
print/cups-client -V OPTIONSFILE
/var/empty/cups/options

$ fetch -o- "http://www.freebsd.org/cgi/query-pr.cgi?prp=150309-1-txt&n=/cups-base-1.4.4.patch"
| patch -p3

$ make __MAKE_CONF=/dev/null PORT_DBDIR=/var/empty -C print/cups-base
-V OPTIONSFILE
/var/empty/cups-base/options
$ make __MAKE_CONF=/dev/null PORT_DBDIR=/var/empty -C
print/cups-client -V OPTIONSFILE
/var/empty/cups-client/options

Expected OPTIONSFILE location in both cases. Also it works
(config/showconfig/all):

$ make __MAKE_CONF=/dev/null PORT_DBDIR=/tmp/portsdb -C
print/cups-client showconfig
===> The following configuration options are available for cups-client-1.4.4:
     GNUTLS=on (default) "Build with GNUTLS library"
===> Use 'make config' to modify these settings
$ make __MAKE_CONF=/dev/null PORT_DBDIR=/tmp/portsdb -C print/cups-client config
# deselect GNUTLS
$ make __MAKE_CONF=/dev/null PORT_DBDIR=/tmp/portsdb -C
print/cups-client showconfig
===> The following configuration options are available for cups-client-1.4.4:
     GNUTLS=off "Build with GNUTLS library"
===> Use 'make config' to modify these settings

$ cat /tmp/portsdb/cups-client/options
# This file is auto-generated by 'make config'.
# No user-servicable parts inside!
# Options for cups-client-1.4.4
_OPTIONS_READ=cups-client-1.4.4
WITHOUT_GNUTLS=true

Again, everything is as expected.
Comment 10 dfilter service freebsd_committer 2010-11-15 06:30:46 UTC
dinoex      2010-11-15 06:30:40 UTC

  FreeBSD ports repository

  Modified files:
    print/cups-base      Makefile 
  Log:
  - fix options by forcing UNIQUENAME
  PR:             150309
  Submitted by:   Marcin Wisnicki
  
  Revision  Changes    Path
  1.146     +10 -3     ports/print/cups-base/Makefile
_______________________________________________
cvs-all@freebsd.org mailing list
http://lists.freebsd.org/mailman/listinfo/cvs-all
To unsubscribe, send any mail to "cvs-all-unsubscribe@freebsd.org"
Comment 11 Dirk Meyer freebsd_committer 2010-11-15 08:26:48 UTC
State Changed
From-To: analyzed->patched


Please test again. 
I think I have resolved all issues with the Options.
Comment 12 mwisnicki+freebsd 2010-11-17 00:02:31 UTC
On Mon, Nov 15, 2010 at 09:27,  <dinoex@freebsd.org> wrote:
> Synopsis: [PATCH] print/cups-base: cups ports have duplicated UNIQUENAME
>
> State-Changed-From-To: analyzed->patched
> State-Changed-By: dinoex
> State-Changed-When: Mon Nov 15 09:26:48 CET 2010
> State-Changed-Why:
>
> Please test again.
> I think I have resolved all issues with the Options.
>

Seems to be working. Thanks!

>
> http://www.freebsd.org/cgi/query-pr.cgi?pr=150309
>
Comment 13 Dirk Meyer freebsd_committer 2010-11-17 09:15:03 UTC
State Changed
From-To: patched->closed

Thanks