Bug 151593 - [igb] [panic] Kernel panic when bringing up igb network adapter with MSI-X enabled
Summary: [igb] [panic] Kernel panic when bringing up igb network adapter with MSI-X en...
Status: Closed DUPLICATE of bug 172113
Alias: None
Product: Base System
Classification: Unclassified
Component: kern (show other bugs)
Version: 8.1-RELEASE
Hardware: Any Any
: Normal Affects Only Me
Assignee: freebsd-net mailing list
URL:
Keywords: IntelNetworking
Depends on:
Blocks:
 
Reported: 2010-10-20 06:00 UTC by Vasily Ivanov
Modified: 2018-05-28 20:57 UTC (History)
3 users (show)

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Vasily Ivanov 2010-10-20 06:00:20 UTC
Shortly after bringing up igb interfaces system panics. Screenshot: http://pix.academ.org/img/2010/10/20/35b6dd863e7099555ed84a616a97f0bb.jpg

This by far happened only with MSI-X enabled (default).

Hardware is SuperMicro X8DTL with dual Xeon X5650 and Intel Pro/1000ET QuadPort.

# dmesg | grep igb0
igb0: <Intel(R) PRO/1000 Network Connection version - 1.9.5> port 0xbc00-0xbc1f mem 0xf97e0000-0xf97fffff,0xf9800000-0xf9bfffff,0xf97dc000-0xf97dffff irq 39 at device 0.0 on pci5
igb0: Using MSIX interrupts with 10 vectors
igb0: [ITHREAD]
igb0: [ITHREAD]
igb0: [ITHREAD]
igb0: [ITHREAD]
igb0: [ITHREAD]
igb0: [ITHREAD]
igb0: [ITHREAD]
igb0: [ITHREAD]
igb0: [ITHREAD]
igb0: [ITHREAD]
igb0: Ethernet address: 00:1b:21:53:ce:38

# pciconf -l | grep igb0
igb0@pci0:5:0:0:        class=0x020000 card=0xa02b8086 chip=0x10e88086 rev=0x01 hdr=0x00

Fix: 

Turn off MSX-X in /boot/loader.conf : hw.igb.enable_msix=0
How-To-Repeat: http://www.youtube.com/watch?v=H6xe0CFiZOQ
Comment 1 Mark Linimon freebsd_committer freebsd_triage 2010-10-23 08:51:51 UTC
Responsible Changed
From-To: freebsd-bugs->freebsd-net

Over to maintainer(s).
Comment 2 eschoedler 2011-01-25 15:22:45 UTC
I have the same problem.
Please comment the lines in your /boot/loader.conf and run your tests again.

#hw.igb.rxd=4096
#hw.igb.txd=4096
#hw.igb.enable_aim=1

Best regards,

--
Eduardo Schoedler
Comment 3 Sean Bruno freebsd_committer 2015-08-04 15:45:36 UTC
This doesn't seem to happen on my machines (I have almost identical SM hardware) on fbsd8 and fbsd10.  Is this still happeneing for you?
Comment 4 Eitan Adler freebsd_committer freebsd_triage 2018-05-28 19:44:59 UTC
batch change:

For bugs that match the following
-  Status Is In progress 
AND
- Untouched since 2018-01-01.
AND
- Affects Base System OR Documentation

DO:

Reset to open status.


Note:
I did a quick pass but if you are getting this email it might be worthwhile to double check to see if this bug ought to be closed.
Comment 5 Eugene Grosbein freebsd_committer 2018-05-28 20:57:38 UTC
Duplicate of the PR 172113 fixed long time ago.

*** This bug has been marked as a duplicate of bug 172113 ***