Bug 151673 - [PATCH] emulators/qemu-devel: fix MASTER_SITES:n usage
[PATCH] emulators/qemu-devel: fix MASTER_SITES:n usage
Status: Closed FIXED
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s)
Latest
Any Any
: Normal Affects Only Me
Assigned To: Juergen Lock
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2010-10-24 07:00 UTC by Sahil Tandon
Modified: 2010-10-24 17:00 UTC (History)
1 user (show)

See Also:


Attachments
qemu-devel.diff (570 bytes, patch)
2010-10-24 07:00 UTC, Sahil Tandon
no flags Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Sahil Tandon freebsd_committer 2010-10-24 07:00:21 UTC
Fix MASTER_SITES:n usage so that the ":n" postfix is added 
to *all* elements of MASTER_SITE_LOCAL, not just the final
one.  To observe the difference, run the following command
while inside the port's dir before and after applying the
patch:

% make -V MASTER_SITES
Comment 1 Edwin Groothuis freebsd_committer 2010-10-24 07:01:15 UTC
Responsible Changed
From-To: freebsd-ports-bugs->nox

Over to maintainer (via the GNATS Auto Assign Tool)
Comment 2 swell.k 2010-10-24 07:21:00 UTC
Why not just use LOCAL/nox:snapshot then? It's more clear because it doesn't
use :n twice, e.g. ${MASTER_SITE_LOCAL}:snapshot + qemu/:release (from %SUBDIR%).

Here is a difference for `make fetch-urlall-list':

  @@ -3,4 +3,11 @@ http://mirror.lihnidos.org/GNU/savannah/
   http://ftp.twaren.net/Unix/NonGNU/qemu/qemu-0.13.0.tar.gz
   ftp://ftp.twaren.net/Unix/NonGNU/qemu/qemu-0.13.0.tar.gz
   http://download.savannah.gnu.org/releases-noredirect/qemu/qemu-0.13.0.tar.gz
  +ftp://ftp.FreeBSD.org/pub/FreeBSD/ports/local-distfiles/qemu/qemu-0.13.0.tar.gz
  +ftp://ftp.se.FreeBSD.org/pub/FreeBSD/ports/local-distfiles/qemu/qemu-0.13.0.tar.gz
  +ftp://ftp.uk.FreeBSD.org/pub/FreeBSD/ports/local-distfiles/qemu/qemu-0.13.0.tar.gz
  +ftp://ftp.ru.FreeBSD.org/pub/FreeBSD/ports/local-distfiles/qemu/qemu-0.13.0.tar.gz
  +ftp://ftp.jp.FreeBSD.org/pub/FreeBSD/ports/local-distfiles/qemu/qemu-0.13.0.tar.gz
  +ftp://ftp.tw.FreeBSD.org/pub/FreeBSD/ports/local-distfiles/qemu/qemu-0.13.0.tar.gz
  +ftp://ftp.cn.FreeBSD.org/pub/FreeBSD/ports/local-distfiles/qemu/qemu-0.13.0.tar.gz
   ftp://ftp.FreeBSD.org/pub/FreeBSD/ports/distfiles/qemu/qemu-0.13.0.tar.gz

--- a.diff begins here ---
Index: emulators/qemu-devel/Makefile
===================================================================
RCS file: /a/.cvsup/ports/emulators/qemu-devel/Makefile,v
retrieving revision 1.116
diff -u -p -r1.116 Makefile
--- emulators/qemu-devel/Makefile	21 Oct 2010 21:40:14 -0000	1.116
+++ emulators/qemu-devel/Makefile	24 Oct 2010 06:16:07 -0000
@@ -9,9 +9,9 @@ PORTNAME=	qemu
 PORTVERSION=	0.13.0
 CATEGORIES=	emulators
 MASTER_SITES=	SAVANNAH:release \
-		${MASTER_SITE_LOCAL}:snapshot \
+		LOCAL/qemu:release \
+		LOCAL/nox:snapshot \
 		http://people.freebsd.org/~nox/qemu/:snapshot
-MASTER_SITE_SUBDIR=	qemu/:release nox/:snapshot
 PKGNAMESUFFIX=	-devel
 DISTFILES=	${DISTNAME}${EXTRACT_SUFX}:release
 DIST_SUBDIR=	qemu
--- a.diff ends here ---
Comment 3 Sahil Tandon freebsd_committer 2010-10-24 07:51:17 UTC
TMTOWTDI.  Your solution looks fine to me, and I don't really care which
approach is taken (the ":n" usage is perfectly clear to me), as long as
the problem is fixed.  The maintainer shall decide.

-- 
Sahil Tandon <sahil@FreeBSD.org>
Comment 4 swell.k 2010-10-24 08:41:23 UTC
Sahil Tandon <sahil@FreeBSD.org> writes:

> TMTOWTDI.  Your solution looks fine to me, and I don't really care which
> approach is taken (the ":n" usage is perfectly clear to me), as long as
> the problem is fixed.  The maintainer shall decide.

What I meant is it's less confusing than having unused[*] qemu/:release
in MASTER_SITE_SUBDIR. And since it's unused your patch is just a no-op.

[*] `make -V MASTER_SITES' wouldn't show it
Comment 5 Sahil Tandon freebsd_committer 2010-10-24 16:29:08 UTC
"Anonymous", thanks for your clarification.

On Sun, 2010-10-24 at 11:41:23 +0400, Anonymous wrote:

> What I meant is it's less confusing than having unused[*] qemu/:release
> in MASTER_SITE_SUBDIR. And since it's unused your patch is just a no-op.

I do not share your confusion with the original patch, which pertains to
the propagation of the ":snapshot" suffix to all elements of
MASTER_SITE_LOCAL; furthermore, `make -V MASTER_SITES' before and after
application of the patch *would* show difference. 

> [*] `make -V MASTER_SITES' wouldn't show it

My patch has nothing to do with ":release" so yes, it would not show
what you are talking about, but - again - that is not the issue I was
addressing.  I'm simply trying to bring attention to the fact that the
":snapshot" postfix was not being properly affixed to all sites.  Just
because the snapshot MASTER_SITEs are not being used (since DISTFILES
only corresponds with ":release" archives) is not relevant to me. If you
review the history of this Makefile, you'll see this situation is a
result of a previous commit by the maintainer (from r1.104 -> 1.105)
that switched from using snapshot -> release DISTFILE, but explicitly
retained the snapshot-related MASTER_SITE entries.

Finally, now that the issue has been brough to nox's attention, he's
well-equipped to handle it how he wants.  Perhaps he will decide to just
remove all mention of ":snapshot"! :) 

-- 
Sahil Tandon <sahil@FreeBSD.org>
Comment 6 dfilter freebsd_committer 2010-10-24 16:51:38 UTC
nox         2010-10-24 15:51:33 UTC

  FreeBSD ports repository

  Modified files:
    emulators/qemu-devel Makefile 
  Log:
  Fix MASTER_SITES:snapshot usage in preparation for future updates
  that might use a snapshot distfile again (i.e. the change currently
  has no effect.)
  
  PR:             ports/151673
  Submitted by:   sahil
  
  Revision  Changes    Path
  1.117     +1 -1      ports/emulators/qemu-devel/Makefile
_______________________________________________
cvs-all@freebsd.org mailing list
http://lists.freebsd.org/mailman/listinfo/cvs-all
To unsubscribe, send any mail to "cvs-all-unsubscribe@freebsd.org"
Comment 7 Juergen Lock freebsd_committer 2010-10-24 16:52:08 UTC
State Changed
From-To: open->closed

Committed, with minor changes. Thanks!