Bug 151886 - multimedia/libxine fails to build
multimedia/libxine fails to build
Status: Closed FIXED
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s)
Latest
Any Any
: Normal Affects Only Me
Assigned To: Max Brazhnikov
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2010-11-02 14:10 UTC by j.ballantine
Modified: 2011-07-01 19:00 UTC (History)
0 users

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description j.ballantine 2010-11-02 14:10:11 UTC
When trying to do a portupgrade, libxine fails with:
Making all in libreal
gmake[2]: Entering directory `/usr/ports/multimedia/libxine/work/xine-lib-1.1.19/src/libreal'
/bin/sh ../../libtool  --tag=CC   --mode=compile cc -DHAVE_CONFIG_H -I. -I../../include -I../.. -I../../include -I../../include -I../../src -I../../src/xine-engine -I../../src/xine-engine -I../../src/xine-utils  -I../../src/input -I../../src/input  -I../../lib -I../../lib  -I/usr/local/include -I/usr/local/include/ffmpeg  -fvisibility=hidden -D_REENTRANT -D_FILE_OFFSET_BITS=64 -DXINE_COMPILE  -mtune=i386 -O3 -pipe -fomit-frame-pointer -falign-functions=4 -falign-loops=4 -falign-jumps=4   -fexpensive-optimizations -fschedule-insns2 -ffast-math -finline-functions  -Wpointer-arith -pipe -g -fno-force-addr -I/usr/local/include -I/usr/local/include/dvdread -I/usr/local/include/ffmeg -Wall -Wchar-subscripts -Wnested-externs -Wcast-align -Wmissing-declarations -Wmissing-prototypes -Wmissing-format-attribute -Wno-pointer-sign -Wformat=2 -Wno-format-zero-length -Wstrict-aliasing=2 -Werror=implicit-function-declaration -DNDEBUG -MT xineplug_decode_real_la-xine_real_video_decoder.lo -MD
  -MP -MF .deps/xineplug_decode_real_la-xine_real_video_decoder.Tpo -c -o xineplug_decode_real_la-xine_real_video_decoder.lo `test -f 'xine_real_video_decoder.c' || echo './'`xine_real_video_decoder.c
libtool: compile:  cc -DHAVE_CONFIG_H -I. -I../../include -I../.. -I../../include -I../../include -I../../src -I../../src/xine-engine -I../../src/xine-engine -I../../src/xine-utils -I../../src/input -I../../src/input -I../../lib -I../../lib -I/usr/local/include -I/usr/local/include/ffmpeg -fvisibility=hidden -D_REENTRANT -D_FILE_OFFSET_BITS=64 -DXINE_COMPILE -mtune=i386 -O3 -pipe -fomit-frame-pointer -falign-functions=4 -falign-loops=4 -falign-jumps=4 -fexpensive-optimizations -fschedule-insns2 -ffast-math -finline-functions -Wpointer-arith -pipe -g -fno-force-addr -I/usr/local/include -I/usr/local/include/dvdread -I/usr/local/include/ffmeg -Wall -Wchar-subscripts -Wnested-externs -Wcast-align -Wmissing-declarations -Wmissing-prototypes -Wmissing-format-attribute -Wno-pointer-sign -Wformat=2 -Wno-format-zero-length -Wstrict-aliasing=2 -Werror=implicit-function-declaration -DNDEBUG -MT xineplug_decode_real_la-xine_real_video_decoder.lo -MD -MP -MF .deps/xineplug_decode_real_la
 -xine_real_video_decoder.Tpo -c xine_real_video_decoder.c  -fPIC -DPIC -o .libs/xineplug_decode_real_la-xine_real_video_decoder.o
In file included from xine_real_video_decoder.c:49:
real_common.h:49: error: '__environ' defined both normally and as an alias
real_common.h:59: error: 'stderr' defined both normally and as an alias
gmake[2]: *** [xineplug_decode_real_la-xine_real_video_decoder.lo] Error 1
gmake[2]: Leaving directory `/usr/ports/multimedia/libxine/work/xine-lib-1.1.19/src/libreal'

This error has been occuring for since the release, and I sent the listed maintainer this issue also.

How-To-Repeat: Do a make in /usr/ports/multimedia/libxine
Comment 1 brucec freebsd_committer 2010-11-02 15:17:40 UTC
Responsible Changed
From-To: freebsd-bugs->freebsd-ports-bugs

Ports PR.
Comment 2 Edwin Groothuis freebsd_committer 2010-11-02 15:18:19 UTC
Responsible Changed
From-To: freebsd-ports-bugs->makc

Over to maintainer (via the GNATS Auto Assign Tool)
Comment 3 Max Brazhnikov freebsd_committer 2010-11-12 09:53:57 UTC
State Changed
From-To: open->feedback

Can't reproduce this. Do you build it with non-default optins? Could you 
also send me full build log?
Comment 4 Max Brazhnikov freebsd_committer 2011-03-12 20:28:42 UTC
State Changed
From-To: feedback->closed

Feedback timeout.
Comment 5 dfilter freebsd_committer 2011-07-01 18:51:52 UTC
nox         2011-07-01 17:51:38 UTC

  FreeBSD ports repository

  Modified files:
    multimedia/libxine   Makefile 
  Log:
  Fix build WITH_DEBUG.
  
  PR:             ports/151886
  Submitted by:   Jim Ballantine <j.ballantine@gmail.com>
  
  Revision  Changes    Path
  1.169     +5 -0      ports/multimedia/libxine/Makefile
_______________________________________________
cvs-all@freebsd.org mailing list
http://lists.freebsd.org/mailman/listinfo/cvs-all
To unsubscribe, send any mail to "cvs-all-unsubscribe@freebsd.org"