Bug 152532 - [MAINTAINER] x11/fbpanel: fix patch of configure script
Summary: [MAINTAINER] x11/fbpanel: fix patch of configure script
Status: Closed FIXED
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: Normal Affects Only Me
Assignee: Beech Rintoul
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2010-11-24 03:20 UTC by Charlie Kester
Modified: 2010-11-29 02:00 UTC (History)
0 users

See Also:


Attachments
fbpanel-6.1_1.diff (1.70 KB, patch)
2010-11-24 03:20 UTC, Charlie Kester
no flags Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Charlie Kester 2010-11-24 03:20:09 UTC
Existing port sets PREFIX in configure environment, in order to
force installation into proper directories.  This was a quick and
dirty workaround.  Wolfgang Jenkner did root cause analysis and
suggested the attached changes to fix the real problem.

My testing confirms his fix.

No need to bump PORTREVISION since this doesn't affect the resulting package.
Comment 1 Beech Rintoul freebsd_committer 2010-11-24 05:16:27 UTC
Responsible Changed
From-To: freebsd-ports-bugs->beech

I'll take it.
Comment 2 Beech Rintoul freebsd_committer 2010-11-25 00:15:35 UTC
State Changed
From-To: open->patched

Patch fails on 7.0 maintainer notified and solution being sought.
Comment 3 Beech Rintoul freebsd_committer 2010-11-28 00:37:37 UTC
State Changed
From-To: patched->open

Feedback received from maintainer, testing in progress.
Comment 4 dfilter service freebsd_committer 2010-11-29 01:54:11 UTC
beech       2010-11-29 01:54:06 UTC

  FreeBSD ports repository

  Modified files:
    x11/fbpanel          Makefile 
    x11/fbpanel/files    patch-configure 
  Log:
  Fix PREFIX in configure environment.
  
  PR:             ports/152532
  Submitted by:   Charlie Kester <corky1951@comcast.net> (maintainer)
  Approved by:    itetcu (implicit)
  
  Revision  Changes    Path
  1.24      +1 -1      ports/x11/fbpanel/Makefile
  1.2       +19 -10    ports/x11/fbpanel/files/patch-configure
_______________________________________________
cvs-all@freebsd.org mailing list
http://lists.freebsd.org/mailman/listinfo/cvs-all
To unsubscribe, send any mail to "cvs-all-unsubscribe@freebsd.org"
Comment 5 Beech Rintoul freebsd_committer 2010-11-29 01:55:09 UTC
State Changed
From-To: open->closed

Committed, Thanks!