Bug 153128 - graphics/ocaml-lablgl fails to build
Summary: graphics/ocaml-lablgl fails to build
Status: Closed FIXED
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: Normal Affects Only Me
Assignee: Brendan Fabeny
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2010-12-13 19:10 UTC by Anatoly Borodin
Modified: 2012-03-07 03:30 UTC (History)
0 users

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Anatoly Borodin 2010-12-13 19:10:08 UTC
graphics/ocaml-lablgl fails to build.

PS I don't know, but could tk86 be a reason?

How-To-Repeat: # cd /usr/ports/graphics/ocaml-lablgl && make
===>  License check disabled, port has not defined LICENSE
===>  Extracting for ocaml-lablgl-1.04
=> SHA256 Checksum OK for lablgl-1.04.tar.gz.
===>   ocaml-lablgl-1.04 depends on file: /usr/local/bin/ocamlc - found
===>  Patching for ocaml-lablgl-1.04
===>   ocaml-lablgl-1.04 depends on file: /usr/local/bin/ocamlc - found
===>  Applying FreeBSD patches for ocaml-lablgl-1.04
===>   ocaml-lablgl-1.04 depends on file: /usr/local/bin/ocamlc - found
===>   ocaml-lablgl-1.04 depends on executable: gmake - found
===>   ocaml-lablgl-1.04 depends on shared library: tk86 - found
===>   ocaml-lablgl-1.04 depends on shared library: glut.3 - found
===>  Configuring for ocaml-lablgl-1.04
===>  Building for ocaml-lablgl-1.04
cd src && gmake all LIBDIR="/usr/local/lib/ocaml"
gmake[1]: Entering directory `/usr/obj/usr/ports/graphics/ocaml-lablgl/work/lablGL-1.04/src'
ocamlc -pp camlp4o var2def.ml -o var2def
ocamlc -pp camlp4o var2switch.ml -o var2switch
ocamlrun ../src/var2def < gl_tags.var > gl_tags.h
ocamlrun ../src/var2switch -table GL_ < gl_tags.var > gl_tags.c
ocamlc -c -w s -ccopt "-c -O2 -pipe -march=native -fno-strict-aliasing  -I/usr/local/include" ml_gl.c
ml_gl.c: In function 'ml_glGetString':
ml_gl.c:225: warning: pointer targets in passing argument 1 of 'lablgl_copy_string_check' differ in signedness
ml_gl.c: In function 'ml_glGenTextures':
ml_gl.c:674: warning: pointer targets in passing argument 2 of 'glGenTextures' differ in signedness
ocamlrun ../src/var2def < glu_tags.var > glu_tags.h
ocamlrun ../src/var2switch GLU_ < glu_tags.var > glu_tags.c
ocamlc -c -w s -ccopt "-c -O2 -pipe -march=native -fno-strict-aliasing  -I/usr/local/include" ml_glu.c
ml_glu.c: In function 'ml_gluGetString':
ml_glu.c:96: warning: pointer targets in passing argument 1 of 'lablgl_copy_string_check' differ in signedness
ocamlrun ../src/var2def < raw_tags.var > raw_tags.h
ocamlc -c -w s -ccopt "-c -O2 -pipe -march=native -fno-strict-aliasing  -I/usr/local/include" ml_raw.c
ocamlc -c -w s -ccopt "-c -O2 -pipe -march=native -fno-strict-aliasing  -I/usr/local/include" ml_glarray.c
ocamlc -c -w s -ccopt "-c -O2 -pipe -march=native -fno-strict-aliasing  -I/usr/local/include" ml_glutess.c
ocamlc -c -w s -I +labltk raw.mli
ocamlc -c -w s -I +labltk raw.ml
ocamlc -c -w s -I +labltk gl.mli
ocamlc -c -w s -I +labltk gl.ml
ocamlc -c -w s -I +labltk glLight.mli
ocamlc -c -w s -I +labltk glLight.ml
ocamlc -c -w s -I +labltk glList.mli
ocamlc -c -w s -I +labltk glList.ml
ocamlc -c -w s -I +labltk glMap.mli
ocamlc -c -w s -I +labltk glMap.ml
ocamlc -c -w s -I +labltk glMat.mli
ocamlc -c -w s -I +labltk glMat.ml
ocamlc -c -w s -I +labltk glMisc.mli
ocamlc -c -w s -I +labltk glMisc.ml
ocamlc -c -w s -I +labltk glPix.mli
ocamlc -c -w s -I +labltk glPix.ml
ocamlc -c -w s -I +labltk glClear.mli
ocamlc -c -w s -I +labltk glClear.ml
ocamlc -c -w s -I +labltk glTex.mli
ocamlc -c -w s -I +labltk glTex.ml
ocamlc -c -w s -I +labltk glDraw.mli
ocamlc -c -w s -I +labltk glDraw.ml
ocamlc -c -w s -I +labltk glFunc.mli
ocamlc -c -w s -I +labltk glFunc.ml
ocamlc -c -w s -I +labltk gluMisc.mli
ocamlc -c -w s -I +labltk gluMisc.ml
ocamlc -c -w s -I +labltk gluNurbs.mli
ocamlc -c -w s -I +labltk gluNurbs.ml
ocamlc -c -w s -I +labltk gluQuadric.mli
ocamlc -c -w s -I +labltk gluQuadric.ml
ocamlc -c -w s -I +labltk gluTess.mli
ocamlc -c -w s -I +labltk gluTess.ml
ocamlc -c -w s -I +labltk gluMat.mli
ocamlc -c -w s -I +labltk gluMat.ml
ocamlc -c -w s -I +labltk glArray.mli
ocamlc -c -w s -I +labltk glArray.ml
ocamlmklib -o lablgl ml_gl.o    ml_glu.o        ml_raw.o ml_glarray.o ml_glutess.o raw.cmo gl.cmo               glLight.cmo     glList.cmo      glMap.cmo glMat.cmo     glMisc.cmoglPix.cmo        glClear.cmo glTex.cmo   glDraw.cmo      glFunc.cmo      gluMisc.cmo gluNurbs.cmo        gluQuadric.cmo  gluTess.cmo     gluMat.cmo glArray.cmo -lGL -lGLU -L/usr/local/lib -lXext -lXmu -lX11
gmake[1]: Leaving directory `/usr/obj/usr/ports/graphics/ocaml-lablgl/work/lablGL-1.04/src'
cd Togl/src && gmake all
gmake[1]: Entering directory `/usr/obj/usr/ports/graphics/ocaml-lablgl/work/lablGL-1.04/Togl/src'
ocamlc -c -w s -I +labltk -I ../../src togl.mli
File "togl.mli", line 4, characters 14-29:
Error: Unbound type constructor Widget.widget
gmake[1]: *** [togl.cmi] Error 2
gmake[1]: Leaving directory `/usr/obj/usr/ports/graphics/ocaml-lablgl/work/lablGL-1.04/Togl/src'
gmake: *** [togl] Error 2
*** Error code 1

Stop in /usr/ports/graphics/ocaml-lablgl.
Comment 1 Edwin Groothuis freebsd_committer 2010-12-13 19:10:15 UTC
Responsible Changed
From-To: freebsd-ports-bugs->stas

Over to maintainer (via the GNATS Auto Assign Tool)
Comment 2 Guido Falsi freebsd_committer 2010-12-15 13:58:57 UTC
This problem does not show up when tk85 is installed, so the idea that
it is caused by tk86 looks right.

-- 
Guido Falsi <mad@madpilot.net>
Comment 3 Anatoly Borodin 2010-12-15 15:12:59 UTC
Could http://www.freebsd.org/cgi/query-pr.cgi?pr=133113 be helpful then?
Comment 4 Martin Laabs 2011-04-03 20:36:59 UTC
Fixup: (Re)Build lang/ocaml with X11, TK and (maybe) THREADS support. 
Rebuild ocaml-lablgl afterwards.

Greetings,
  Martin Laabs
Comment 5 Doug Barton freebsd_committer 2011-10-06 05:23:58 UTC
Confirmed that adding tk (85) and x11 to lang/ocaml allowed this port to
build. The THREADS option in lang/ocaml is necessary to avoid a package
failure there.

A CONFLICTS_BUILD no ocaml-notk in this port would probably be a good
start here.


hth,

Doug

-- 

	Nothin' ever doesn't change, but nothin' changes much.
			-- OK Go

	Breadth of IT experience, and depth of knowledge in the DNS.
	Yours for the right price.  :)  http://SupersetSolutions.com/
Comment 6 Thomas Abthorpe freebsd_committer 2011-11-05 04:12:30 UTC
Responsible Changed
From-To: stas->freebsd-ports-bugs

- back to the heap
Comment 7 Brendan Fabeny freebsd_committer 2011-11-19 10:29:07 UTC
Responsible Changed
From-To: freebsd-ports-bugs->bf

I'll take it.
Comment 8 dfilter service freebsd_committer 2012-03-07 03:22:53 UTC
bf          2012-03-07 03:21:42 UTC

  FreeBSD ports repository

  Modified files:
    graphics/ocaml-lablgl Makefile distinfo pkg-descr pkg-plist 
  Removed files:
    graphics/ocaml-lablgl/files patch-Togl_src_Togl_togl.c 
  Log:
  update to 20120306; fix Tcl/Tk dependencies and CONFLICTS [1];
  add LICENSE and WWW
  
  PR:             153128 [1]
  
  Revision  Changes    Path
  1.28      +27 -14    ports/graphics/ocaml-lablgl/Makefile
  1.10      +2 -2      ports/graphics/ocaml-lablgl/distinfo
  1.2       +0 -11     ports/graphics/ocaml-lablgl/files/patch-Togl_src_Togl_togl.c (dead)
  1.3       +2 -0      ports/graphics/ocaml-lablgl/pkg-descr
  1.7       +9 -0      ports/graphics/ocaml-lablgl/pkg-plist
_______________________________________________
cvs-all@freebsd.org mailing list
http://lists.freebsd.org/mailman/listinfo/cvs-all
To unsubscribe, send any mail to "cvs-all-unsubscribe@freebsd.org"
Comment 9 Brendan Fabeny freebsd_committer 2012-03-07 03:23:27 UTC
State Changed
From-To: open->closed

The problem should be fixed now.  Thanks!