Bug 153244 - [em] em(4) fails to send UDP to port 0xffff
Summary: [em] em(4) fails to send UDP to port 0xffff
Status: Closed Unable to Reproduce
Alias: None
Product: Base System
Classification: Unclassified
Component: kern (show other bugs)
Version: 8.1-STABLE
Hardware: Any Any
: Normal Affects Only Me
Assignee: freebsd-net mailing list
URL:
Keywords: IntelNetworking
Depends on:
Blocks:
 
Reported: 2010-12-17 10:20 UTC by danny
Modified: 2015-08-04 16:11 UTC (History)
1 user (show)

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description danny 2010-12-17 10:20:06 UTC
	with TXCSUM on, the em failes to send a UDP packet to port (short)-1 (0xffff)

Fix: 

workaround: ifconfig em0 -txcsum
How-To-Repeat: 	nc -u some-host 65535
	and watch via wireshark
Comment 1 Mark Linimon freebsd_committer freebsd_triage 2010-12-20 08:43:36 UTC
Responsible Changed
From-To: freebsd-bugs->freebsd-net

Over to maintainer(s).
Comment 2 Sean Bruno freebsd_committer 2015-08-04 16:11:38 UTC
I've fired off this exact test on my 82574L based host (em) and it works for me.