Bug 153816 - [ixgbe] ixgbe doesn't work properly with the Intel 10gigabit CX4 Dual Port network card
Summary: [ixgbe] ixgbe doesn't work properly with the Intel 10gigabit CX4 Dual Port ne...
Status: Closed Overcome By Events
Alias: None
Product: Base System
Classification: Unclassified
Component: kern (show other bugs)
Version: unspecified
Hardware: Any Any
: Normal Affects Only Me
Assignee: freebsd-net mailing list
URL:
Keywords: IntelNetworking
Depends on:
Blocks:
 
Reported: 2011-01-09 14:50 UTC by Jean De Gyns
Modified: 2015-08-03 16:50 UTC (History)
1 user (show)

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Jean De Gyns 2011-01-09 14:50:05 UTC
I'm running on a computer with an Intel 10gigabit CX4 Dual Port network card. The FreeBSD version is 8.1 (but I also tried the 8.2) with the latest version of the ixgbe driver 2.2.3 got from the intel website.

The problem is the interface never goes up. An ifconfig shows "no carrier" for both ix0 and ix1 interface while the switch shows a functional 10gb link.

The nic works just fine with windows 7 and ubuntu 10.10 on the same computer.

I read somewhere, you needed to assign an IP to the interface in order to bring it up, doesn't work.

The man page states, I should contact "freebsdnic@mailbox.intel.com" if there are problems to report with the drivers but this email address doesn't work anymore.

How-To-Repeat: Just load the ixgbe driver and try to bring the interface up.
Comment 1 Mark Linimon freebsd_committer freebsd_triage 2011-01-09 14:53:21 UTC
Responsible Changed
From-To: freebsd-bugs->freebsd-net

Over to maintainer(s).
Comment 2 Sean Bruno freebsd_committer 2015-07-25 22:30:18 UTC
This should no longer be happening with FreeBSD 10.1 and 10.2r.  If you can retest, we'd appreciate it.
Comment 3 Sean Bruno freebsd_committer 2015-08-03 16:50:25 UTC
If you are still having issues with this Intel card, please reopen this ticket and we'll figure out what's up.