Bug 154214 - [stf] [pf] [panic] Panic when creating stf interface
Summary: [stf] [pf] [panic] Panic when creating stf interface
Status: Closed DUPLICATE of bug 218895
Alias: None
Product: Base System
Classification: Unclassified
Component: kern (show other bugs)
Version: 9.0-CURRENT
Hardware: Any Any
: Normal Affects Only Me
Assignee: freebsd-bugs (Nobody)
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2011-01-22 00:30 UTC by vladislav V. Prodan
Modified: 2018-01-03 09:55 UTC (History)
2 users (show)

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description vladislav V. Prodan 2011-01-22 00:30:08 UTC
After entering the command "ifconfig stf create" - we panic

# kldstat -v | grep stf
                226 if_stf

On the internal interface are given two networks ipv6 - /64 and /48.
Service works rtadvd.
Wanted to create a service 6to4.

http://img521.imageshack.us/img521/8142/dsc00571in.jpg

How-To-Repeat: ifconfig stf create
Comment 1 Mark Linimon freebsd_committer freebsd_triage 2011-01-23 21:37:53 UTC
Responsible Changed
From-To: freebsd-amd64->freebsd-bugs

reclassify.
Comment 2 vladislav V. Prodan 2011-01-24 03:47:55 UTC
By then it is better to freebsd-net
Comment 3 Mark Linimon freebsd_committer freebsd_triage 2011-01-24 05:04:52 UTC
Responsible Changed
From-To: freebsd-bugs->freebsd-net

Over to maintainer(s).
Comment 4 John Baldwin freebsd_committer freebsd_triage 2011-01-24 13:11:31 UTC
On Friday, January 21, 2011 7:24:08 pm Vladislav V. Prodan wrote:
> 
> >Number:         154214
> >Category:       amd64
> >Synopsis:       Panic when creating stf interface
> >Confidential:   no
> >Severity:       serious
> >Priority:       high
> >Responsible:    freebsd-amd64
> >State:          open
> >Quarter:        
> >Keywords:       
> >Date-Required:
> >Class:          sw-bug
> >Submitter-Id:   current-users
> >Arrival-Date:   Sat Jan 22 00:30:08 UTC 2011
> >Closed-Date:
> >Last-Modified:
> >Originator:     Vladislav V. Prodan
> >Release:        9.0-CURRENT  amd64
> >Organization:
> >Environment:
> FreeBSD mary-teresa.ZZZ 9.0-CURRENT FreeBSD 9.0-CURRENT #0: Sun Aug 29 
19:00:25 EEST 2010     vlad11@mary-teresa.ZZZ:/usr/obj/usr/src/sys/mary-
teresa.24  amd64
> 
> >Description:
> After entering the command "ifconfig stf create" - we panic
> 
> # kldstat -v | grep stf
>                 226 if_stf
> 
> On the internal interface are given two networks ipv6 - /64 and /48.
> Service works rtadvd.
> Wanted to create a service 6to4.
> 
> http://img521.imageshack.us/img521/8142/dsc00571in.jpg

The picture shows a double fault (likely due to infinite recursion on the 
stack or some code putting too large of an object onto the stack).  Can you 
get a backtrace via 'tr' at the db> prompt and reply with the output?

-- 
John Baldwin
Comment 5 Eitan Adler freebsd_committer freebsd_triage 2017-12-31 07:59:39 UTC
For bugs matching the following criteria:

Status: In Progress Changed: (is less than) 2014-06-01

Reset to default assignee and clear in-progress tags.

Mail being skipped
Comment 6 Kristof Provost freebsd_committer 2018-01-03 08:57:17 UTC
This is likely the same problem as #218895.

As a workaround either don't load pf, or don't create interfaces with names that are also group names (the easiest way to ensure this is to always append a number to the interface names, so stf0 iso. stf).
Comment 7 Eugene Grosbein freebsd_committer 2018-01-03 09:55:07 UTC

*** This bug has been marked as a duplicate of bug 218895 ***