Bug 154742 - [PATCH] math/py-numpy: respect CC, minor clean-ups
Summary: [PATCH] math/py-numpy: respect CC, minor clean-ups
Status: Closed FIXED
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: Normal Affects Only Me
Assignee: Brendan Fabeny
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2011-02-13 17:00 UTC by Brendan Fabeny
Modified: 2011-03-05 00:49 UTC (History)
0 users

See Also:


Attachments
file.diff (4.12 KB, patch)
2011-02-13 17:00 UTC, Brendan Fabeny
no flags Details | Diff
bsd.python.mk.diff (911 bytes, patch)
2011-02-14 14:26 UTC, b. f.
no flags Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Brendan Fabeny freebsd_committer 2011-02-13 17:00:19 UTC
The port is mixing different toolchains, with undesirable consequences (linking failures for some users, etc.).

Fix: Patch attached with submission follows:
Comment 1 Edwin Groothuis freebsd_committer 2011-02-13 17:00:27 UTC
Responsible Changed
From-To: freebsd-ports-bugs->bf

Submitter has GNATS access (via the GNATS Auto Assign Tool)
Comment 2 Edwin Groothuis freebsd_committer 2011-02-13 17:00:35 UTC
Maintainer of math/py-numpy,

Please note that PR ports/154742 has just been submitted.

If it contains a patch for an upgrade, an enhancement or a bug fix
you agree on, reply to this email stating that you approve the patch
and a committer will take care of it.

The full text of the PR can be found at:
    http://www.freebsd.org/cgi/query-pr.cgi?pr=ports/154742

-- 
Edwin Groothuis via the GNATS Auto Assign Tool
edwin@FreeBSD.org
Comment 3 Edwin Groothuis freebsd_committer 2011-02-13 17:00:39 UTC
State Changed
From-To: open->feedback

Awaiting maintainers feedback (via the GNATS Auto Assign Tool)
Comment 4 Li-Lun Wang 2011-02-13 22:48:21 UTC
-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA1

I approve this patch.  Thank you.

- -- llwang
-----BEGIN PGP SIGNATURE-----
Version: GnuPG v2.0.12 (FreeBSD)

iD8DBQFNWF+zCQM7t5B2mhARAjNTAJ9Y5rooNYiCn1B5ZMca7HMktEF3zQCfaQ+m
puIXjU88O8vLR7i4pC8g2Qg=
=Gb/U
-----END PGP SIGNATURE-----
Comment 5 b. f. 2011-02-14 12:30:52 UTC
On 2/13/11, Li-Lun Wang (Leland Wang) <llwang@infor.org> wrote:
> -----BEGIN PGP SIGNED MESSAGE-----
> Hash: SHA1
>
> I approve this patch.  Thank you.

Sure.  But upon further reflection, I am wondering if the problem is
shared by some other ports, and if perhaps the addition of LDSHARED to
MAKE_ENV should be made in bsd.python.mk instead.  I'll look into it.

b.
Comment 6 b. f. 2011-02-14 14:26:29 UTC
Martin:

I saw that you were preparing to change the default Python version,
and I was wondering if, while you are conducting tests for this
change, you would be willing to test another change that is needed:

Ports that USE_PYDISTUTILS are not necessarily respecting CC, because
many are inheriting default values for the commands used to link
shared libraries from

${PYTHON_LIBDIR}/distutils/ccompiler.py

or

${PYTHON_LIBDIR}/distutils/unixccompiler.py

This is most noticeable with the ports that USE_PYDISTUTILS and
USE_FORTRAN, like math/py-numpy and science/py-scipy, where you can
see instances of 'cc -shared' (and sometimes '/usr/bin/ld') in build
logs where there should only be 'gcc45 -shared' (and
'/usr/local/bin/ld').  But it may also show up in other ports when the
user sets CC !=cc,  like, for example, math/py-gmpy.  It is
undesirable to mix these toolchains (we have been trying to solve
similar problems in a number of other PRs), and breaks the build in
some cases.  Rather than patching a large number of individual ports,
it would be best to address this problem in bsd.python.mk.  Would you
be wiling to try the attached patch? (It makes the necessary addition
to MAKE_ENV and corrects a typo that I saw while I was there.)

b.
Comment 7 dfilter service freebsd_committer 2011-02-22 18:38:02 UTC
bf          2011-02-22 18:37:57 UTC

  FreeBSD ports repository

  Modified files:
    math/py-numpy        Makefile distinfo 
  Log:
  - Slightly simplify the fenv fix, and note that FreeBSD
  7.3 and 7.4 no longer need the fix after the MFC of r203441 on
  17 February 2010
  
  - While here, remove MD5 checksums in distinfo
  
  PR:             154742
  Approved by:    makc, miwi (mentors, implicit)
                  Li-Lun Wang (maintainer)
  
  Revision  Changes    Path
  1.33      +11 -4     ports/math/py-numpy/Makefile
  1.18      +0 -7      ports/math/py-numpy/distinfo
_______________________________________________
cvs-all@freebsd.org mailing list
http://lists.freebsd.org/mailman/listinfo/cvs-all
To unsubscribe, send any mail to "cvs-all-unsubscribe@freebsd.org"
Comment 8 Eitan Adler freebsd_committer freebsd_triage 2011-02-27 02:19:35 UTC
State Changed
From-To: feedback->closed

Committed already
Comment 9 Eitan Adler freebsd_committer freebsd_triage 2011-02-27 05:17:05 UTC
State Changed
From-To: closed->open

Only part of the patch was committed
Comment 10 dfilter service freebsd_committer 2011-03-05 00:39:42 UTC
bf          2011-03-05 00:39:33 UTC

  FreeBSD ports repository

  Modified files:
    Mk                   bsd.python.mk 
  Log:
  Tell ports that USE_PYDISTUTILS to link shared objects
  with the same compiler used to build them. While here,
  fix a typo.
  
  PR:             154742
  Approved by:    miwi
  
  Revision  Changes    Path
  1.129     +5 -2      ports/Mk/bsd.python.mk
_______________________________________________
cvs-all@freebsd.org mailing list
http://lists.freebsd.org/mailman/listinfo/cvs-all
To unsubscribe, send any mail to "cvs-all-unsubscribe@freebsd.org"
Comment 11 Brendan Fabeny freebsd_committer 2011-03-05 00:49:28 UTC
State Changed
From-To: open->closed

Committed. Thanks!