Bug 154840 - [MAINTAINER] devel/gwenhywfar, finance/aqbanking, finance/kmymoney-kde4: Aqbanking 5.x update
Summary: [MAINTAINER] devel/gwenhywfar, finance/aqbanking, finance/kmymoney-kde4: Aqba...
Status: Closed FIXED
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: Normal Affects Only Me
Assignee: Koop Mast
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2011-02-17 09:10 UTC by Jason E. Hale
Modified: 2011-02-28 19:53 UTC (History)
1 user (show)

See Also:


Attachments
2011-02-17.tar.gz (16.93 KB, text/plain)
2011-02-17 09:10 UTC, Jason E. Hale
no flags Details

Note You need to log in before you can comment on or make changes to this bug.
Description Jason E. Hale 2011-02-17 09:10:10 UTC
- Update devel/gwenhywfar to 4.0.7
- Update finance/aqbanking to 5.0.4
- Update finance/kmymoney-kde4 to 4.5.3

This is all in one PR because these ports need updated together.

*** finance/gnucash needs updated to 2.4.2 as well. Version 2.2.9 currently in
the ports tree does not support aqbanking 5.x. 
I have prepared a separate PR with an update for GnuCash since I am not the
maintainer. (It should be the very next PR after this.)
---------------------------------------------
devel/gwenhywfar:
- Update to 4.0.7
- Gwenhywfar now contains GUI support instead of AqBanking (GTK and QT4 enabled by default)
- Add LICENSE (LGPL21)

Removed files:
files/patch-Makefile.in (use gnomehack instead)
----------------------------------------------
finance/aqbanking:
- Update to 5.0.4
- Remove all GUI stuff, it is in Gwenhywfar now
- Add LICENSE (GPLv2) (The PayPal backend is also GPLv2, but can only be used
  with certain programs. GnuCash and KMyMoney are allowed to use it.)

Removed files:
files/patch-Makefile.in (use gnomehack instead)
files/patch-configure (not needed)
files/patch-mksymlinks.in.sh (not needed)
files/patch-src__plugins__backends__aqofxconnect__ui__qt4__libs__Makefile.in (irrelavent)
pkg-message (contains really old info, not needed anymore)
----------------------------------------------
finance/kmymoney-kde4:
- Update to 4.5.3
- Add kde to CATEGORIES
- Requires aqbanking 5.x, no longer supports aqbanking 4.x

Removed files:
files/patch-cmake__modules__FindAqBanking.cmake (for older aqbanking, new version gets detected properly)
files/patch-cmake__modules__FindGwenhywfar.cmake (for older gwenhywfar, new version get detected properly)
----------------------------------------------

How-To-Repeat: Extract the attached tar.gz archive and apply the appropriate diffs.
Comment 1 Martin Wilke freebsd_committer 2011-02-17 14:50:16 UTC
Responsible Changed
From-To: freebsd-ports-bugs->miwi

I'll take it.
Comment 2 Martin Wilke freebsd_committer 2011-02-17 15:17:42 UTC
Responsible Changed
From-To: miwi->kwm

over to deal with that together with gnucash
Comment 3 Koop Mast freebsd_committer 2011-02-28 19:52:03 UTC
State Changed
From-To: open->closed

Committed thanks! I added a little test in kmymoney-kde4 to check if  
the qt4 library from gwenhywfar is there. Let me know if this isn't done right.