Bug 155430 - [MAINTAINER] UPDATE graphics/libjpeg-turbo: update to 1.1.0
[MAINTAINER] UPDATE graphics/libjpeg-turbo: update to 1.1.0
Status: Closed FIXED
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s)
Any Any
: Normal Affects Only Me
Assigned To: Sunpoet Po-Chuan Hsieh
Depends on:
  Show dependency treegraph
Reported: 2011-03-10 12:20 UTC by bytestore
Modified: 2011-03-11 15:20 UTC (History)
0 users

See Also:

file.shar (3.54 KB, text/plain)
2011-03-10 12:20 UTC, bytestore
no flags Details

Note You need to log in before you can comment on or make changes to this bug.
Description bytestore 2011-03-10 12:20:12 UTC
Significant changes since 1.0.90 (1.1 beta1)

[1] The algorithm used by the SIMD quantization function cannot produce correct
results when the JPEG quality is >= 98 and the fast integer forward DCT is
used.  Thus, the non-SIMD quantization function is now used for those cases,
and libjpeg-turbo should now produce identical output to libjpeg v6b in all

[2] Despite the above, the fast integer forward DCT still degrades somewhat for
JPEG qualities greater than 95, so TurboJPEG/OSS will now automatically use the
slow integer forward DCT when generating JPEG images of quality 96 or greater.
This reduces compression performance by as much as 15% for these high-quality
images but is necessary to ensure that the images are perceptually lossless.
It also ensures that the library can avoid the performance pitfall created by

[3] Ported jpgtest.cxx to pure C to avoid the need for a C++ compiler.

[4] Fixed visual artifacts in grayscale JPEG compression caused by a typo in
the RGB-to-chrominance lookup tables.

[5] The Windows distribution packages now include the libjpeg run-time programs
(cjpeg, etc.)

[6] ALl Packages now include jpgtest.

[7] The TurboJPEG dynamic library now uses versioned symbols.

[8] Added two new TurboJPEG API functions, tjEncodeYUV() and
tjDecompressToYUV(), to replace the somewhat hackish TJ_YUV flag.

Fix: Patch attached with submission follows:
Comment 1 Edwin Groothuis freebsd_committer 2011-03-10 12:20:22 UTC
Class Changed
From-To: update->maintainer-update

Fix category (submitter is maintainer) (via the GNATS Auto Assign Tool)
Comment 2 Sunpoet Po-Chuan Hsieh freebsd_committer 2011-03-11 04:55:28 UTC
Responsible Changed
From-To: freebsd-ports-bugs->sunpoet

I will take it.
Comment 3 dfilter freebsd_committer 2011-03-11 15:11:15 UTC
sunpoet     2011-03-11 15:11:06 UTC

  FreeBSD ports repository

  Modified files:
    graphics/libjpeg-turbo Makefile distinfo pkg-plist 
  - Update to 1.1.0
  - Cleanup MASTER_SITES
  Changes:        http://libjpeg-turbo.svn.sourceforge.net/viewvc/libjpeg-turbo/tags/1.1.0/ChangeLog.txt
  PR:             ports/155430
  Submitted by:   Denis Podolskiy <bytestore@yandex.ru> (maintainer)
  Revision  Changes    Path
  1.13      +2 -4      ports/graphics/libjpeg-turbo/Makefile
  1.5       +2 -3      ports/graphics/libjpeg-turbo/distinfo
  1.3       +1 -0      ports/graphics/libjpeg-turbo/pkg-plist
cvs-all@freebsd.org mailing list
To unsubscribe, send any mail to "cvs-all-unsubscribe@freebsd.org"
Comment 4 Sunpoet Po-Chuan Hsieh freebsd_committer 2011-03-11 15:11:22 UTC
State Changed
From-To: open->closed

Committed, with minor changes. Thanks!