Bug 156119 - x11-fonts/font-manager: ignore a problem caused by the locale module
Summary: x11-fonts/font-manager: ignore a problem caused by the locale module
Status: Closed FIXED
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: Normal Affects Only Me
Assignee: Eitan Adler
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2011-04-02 02:40 UTC by lichray
Modified: 2011-09-26 10:50 UTC (History)
0 users

See Also:


Attachments
patch-font-manager-0.5.7_1 (5.55 KB, text/plain)
2011-04-02 02:40 UTC, lichray
no flags Details

Note You need to log in before you can comment on or make changes to this bug.
Description lichray 2011-04-02 02:40:09 UTC
	
	And old issue was reported here:
	https://code.google.com/p/font-manager/issues/detail?id=57

Fix: Some Python builds on FreeBSD/OpenBSD does not have the function 'bindtextdomain'. But the call to locale.bindtextdomain is not needed actually, since the subsequent call to gettext.bindtextdomain will handle everything. So it's safe to just ignore this error. 

	Note that, in this patch, I used PORTDATA to replace the long static list in pkg-plist.
Comment 1 dfilter service freebsd_committer 2011-04-04 10:37:38 UTC
bapt        2011-04-04 09:37:24 UTC

  FreeBSD ports repository

  Modified files:
    devel/cgit           Makefile 
  Log:
  Add PORTNAME to SUB_LIST
  
  PR:             ports/156119
  Submitted by:   Philippe Pepiot <phil _at_ philpep.org>
  
  Revision  Changes    Path
  1.19      +1 -0      ports/devel/cgit/Makefile
_______________________________________________
cvs-all@freebsd.org mailing list
http://lists.freebsd.org/mailman/listinfo/cvs-all
To unsubscribe, send any mail to "cvs-all-unsubscribe@freebsd.org"
Comment 2 Chris Rees 2011-06-18 15:29:48 UTC
Hi!

Are you sure we need to bump PORTREVISION?

Looks like a build fix to me -- is the patched file actually installed?

Chris
Comment 3 Eitan Adler freebsd_committer freebsd_triage 2011-09-07 16:15:17 UTC
Responsible Changed
From-To: freebsd-ports-bugs->eadler

I'll take it.
Comment 4 dfilter service freebsd_committer 2011-09-23 04:07:10 UTC
eadler      2011-09-23 03:06:56 UTC

  FreeBSD ports repository

  Modified files:
    x11-fonts/font-manager Makefile pkg-plist 
  Log:
  - use PORTDATA instead of long pkg-plist
  - fix error with locale.bindtextdomain
  
  PR:             ports/156119
  Submitted by:   Zhihao Yuan <lichray@gmail.com> (maintainer)
  Approved by:    sahil (mentor)
  
  Revision  Changes    Path
  1.2       +2 -0      ports/x11-fonts/font-manager/Makefile
  1.2       +0 -126    ports/x11-fonts/font-manager/pkg-plist
_______________________________________________
cvs-all@freebsd.org mailing list
http://lists.freebsd.org/mailman/listinfo/cvs-all
To unsubscribe, send any mail to "cvs-all-unsubscribe@freebsd.org"
Comment 5 Eitan Adler freebsd_committer freebsd_triage 2011-09-23 04:08:23 UTC
State Changed
From-To: open->closed

Committed. Thanks!
Comment 6 dfilter service freebsd_committer 2011-09-26 10:48:11 UTC
dougb       2011-09-26 09:47:57 UTC

  FreeBSD ports repository

  Modified files:
    x11-fonts/font-manager Makefile 
  Added files:
    x11-fonts/font-manager/files patch-src-constants.py.in 
  Log:
  Finish applying actual patch
  
  PR:             ports/156119
  Submitted by:   maintainer
  
  Revision  Changes    Path
  1.3       +5 -1      ports/x11-fonts/font-manager/Makefile
  1.1       +11 -0     ports/x11-fonts/font-manager/files/patch-src-constants.py.in (new)
_______________________________________________
cvs-all@freebsd.org mailing list
http://lists.freebsd.org/mailman/listinfo/cvs-all
To unsubscribe, send any mail to "cvs-all-unsubscribe@freebsd.org"