Bug 156253 - [exp-run] [patch] Update devel/boost-* from 1.45 to 1.46.1
[exp-run] [patch] Update devel/boost-* from 1.45 to 1.46.1
Status: Closed FIXED
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s)
Latest
Any Any
: Normal Affects Only Me
Assigned To: Max Brazhnikov
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2011-04-07 15:40 UTC by churanov.port.maintainer
Modified: 2012-05-16 17:11 UTC (History)
0 users

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description churanov.port.maintainer 2011-04-07 15:40:08 UTC
This is the update for devel/boost-* ports from maintainer. The patch updates Boost ports and fixes dependent applications as well.

The patch is based on ports snapshotted at March 2, 2011. There is a chance some parts of the patch will not apply cleanly due to possible changes happened since that date. An exp-run is required.

The applications were only built on x86-32.

Fix: 

http://alexanderchuranov.com/boost-port/boost-1.45-to-1.46.1_attempt05.diff
Comment 1 Matthias Andree freebsd_committer 2011-04-13 12:45:09 UTC
Responsible Changed
From-To: freebsd-ports-bugs->mandree

I'll take it.
Comment 2 Matthias Andree freebsd_committer 2011-04-13 12:46:56 UTC
Responsible Changed
From-To: mandree->freebsd-ports-bugs

sorry, no time to tend to upgrades that require -exp runs.
Comment 3 Max Brazhnikov freebsd_committer 2011-06-16 21:07:30 UTC
Responsible Changed
From-To: freebsd-ports-bugs->makc

I'll take it.
Comment 4 Max Brazhnikov freebsd_committer 2011-06-17 19:08:18 UTC
Responsible Changed
From-To: makc->portmgr

Exp run is required. Please use the following patch: 
http://people.freebsd.org/~makc/patches/boost-20110617.diff
Comment 5 pav freebsd_committer 2011-07-15 09:27:19 UTC
Responsible Changed
From-To: portmgr->pav

Take for exp
Comment 7 bertjw 2011-09-02 23:12:07 UTC
Has there been any movement on this?

Software I am writing is targeting boost 1.46/1.47 and it would be
nice to have the latest version of  boost from ports rather than
installing it by hand.

Thanks,
Bert JW Regeer
Comment 8 dev 2011-11-08 15:02:28 UTC
Hi

It seems most (all?) listed ports are broken because boost::filesystem
interface change. Which can be easily fixed by building obsolete ports
with -DBOOST_FILESYSTEM_VERSION=2 (to use older boost::filesystem
interface).

-- 
Amicus certus in re incerta cernitur.
Comment 9 nicolai 2011-11-25 20:46:12 UTC
Just to follow up. What is the status, can anyone maybe update to 1.48 ?
Or maybe just do an -exp run with 1.48 and I can maybe look at fixing 
breakage.

---
Nicolai Petri
zrouter.org
Comment 10 alexanderchuranov 2011-12-02 15:24:37 UTC
2011/11/26 Nicolai Petri <nicolai@petri.cc>:
> Just to follow up. What is the status, can anyone maybe update to 1.48 ?
> Or maybe just do an -exp run with 1.48 and I can maybe look at fixing
> breakage.

I've just started working on 1.48. I am going to attach the patch here
when it is tested.

Alexander Churanov,
maintainter of devel/boost-*
Comment 11 Baptiste Daroussin freebsd_committer 2012-01-23 17:51:43 UTC
Hi, 

I have written this patch: http://people.freebsd.org/~bapt/boost-1.48.diff it
seems to work for more, if you agree with it I can run an exp-run about it,
otherwise I'll wait for your own patches :)

regards,
Bapt
Comment 12 Max Brazhnikov freebsd_committer 2012-01-23 19:41:10 UTC
Responsible Changed
From-To: makc->bapt

Assign to more interested committer
Comment 13 alexanderchuranov 2012-01-24 15:54:04 UTC
Baptiste,

Thank you for your attention to Boost.
I am currently testing my patch to update boost ports.

Your patch is mostly the same, however there are differences. I've
focused to getting an update as soon as possible to minimize the
version lag. I am planning to continue working on Boost ports after
that. That's why I am not modifying the way Boost is installed,
keeping the process as it was for stability.

As for the exp-run, it would be great, since the hardware requirements
always were an obstacle in updating Boost. Currently I have access to
a reasonably fast server, but even with that it takes 50 hours to
rebuild all directly dependent packages for a single combination of
FreeBSD version and machine architecture. I am not sure that I will be
able to test patch correctness for all supported OS versions and
machine types - which was the reason update to 1.46 was declined in
the first place.

My patch is located at
http://alexanderchuranov.com/boost-port/boost-145-to-148-v03.diff

Review and help with testing is always welcomed.

Alexander Churanov,
maintainer of devel/boost-*
Comment 14 pav freebsd_committer 2012-01-27 09:01:49 UTC
Responsible Changed
From-To: bapt->pav

Take for exp-run
Comment 15 pav freebsd_committer 2012-01-29 19:43:51 UTC
Responsible Changed
From-To: pav->bapt

Failures: 

http://pointyhat.FreeBSD.org/errorlogs/amd64-errorlogs/a.8-exp.20120127093941/aqsis-1.6.0_3.log 
http://pointyhat.FreeBSD.org/errorlogs/amd64-errorlogs/a.8-exp.20120127093941/cgal-3.6.1.log 
http://pointyhat.FreeBSD.org/errorlogs/amd64-errorlogs/a.8-exp.20120127093941/eiskaltdcpp-lib-2.2.4_1.log 
http://pointyhat.FreeBSD.org/errorlogs/amd64-errorlogs/a.8-exp.20120127093941/galaxyhack-1.74_9.log 
http://pointyhat.FreeBSD.org/errorlogs/amd64-errorlogs/a.8-exp.20120127093941/gigi-0.8.0.1048_1,1.log 
http://pointyhat.FreeBSD.org/errorlogs/amd64-errorlogs/a.8-exp.20120127093941/gstreamer-qt4-0.10.1_1.log 
http://pointyhat.FreeBSD.org/errorlogs/amd64-errorlogs/a.8-exp.20120127093941/lander-0.6.2.log 
http://pointyhat.FreeBSD.org/errorlogs/amd64-errorlogs/a.8-exp.20120127093941/libYGP-0.9.42.log 
http://pointyhat.FreeBSD.org/errorlogs/amd64-errorlogs/a.8-exp.20120127093941/libreoffice-3.4.5.log 
http://pointyhat.FreeBSD.org/errorlogs/amd64-errorlogs/a.8-exp.20120127093941/libtorrent-rasterbar-0.14.12_1.log 
http://pointyhat.FreeBSD.org/errorlogs/amd64-errorlogs/a.8-exp.20120127093941/luxrender-0.7.1.log 
http://pointyhat.FreeBSD.org/errorlogs/amd64-errorlogs/a.8-exp.20120127093941/merkaartor-0.17.2_2.log 
http://pointyhat.FreeBSD.org/errorlogs/amd64-errorlogs/a.8-exp.20120127093941/mkvtoolnix-5.0.1.log 
http://pointyhat.FreeBSD.org/errorlogs/amd64-errorlogs/a.8-exp.20120127093941/openlierox-0.59.b9.log 
http://pointyhat.FreeBSD.org/errorlogs/amd64-errorlogs/a.8-exp.20120127093941/openvrml-0.18.6_1.log 
http://pointyhat.FreeBSD.org/errorlogs/amd64-errorlogs/a.8-exp.20120127093941/plee-the-bear-0.3.1_5.log 
http://pointyhat.FreeBSD.org/errorlogs/amd64-errorlogs/a.8-exp.20120127093941/ros-common-1.4.3.log 
http://pointyhat.FreeBSD.org/errorlogs/amd64-errorlogs/a.8-exp.20120127093941/scribe-2.2.2011.07.27.log 
http://pointyhat.FreeBSD.org/errorlogs/amd64-errorlogs/a.8-exp.20120127093941/simgear-2.4.0.log 
http://pointyhat.FreeBSD.org/errorlogs/amd64-errorlogs/a.8-exp.20120127093941/springlobby-0.130.log 
http://pointyhat.FreeBSD.org/errorlogs/amd64-errorlogs/a.8-exp.20120127093941/wesnoth-1.8.6.log
Comment 16 Sergey Matveychuk freebsd_committer 2012-02-25 12:04:03 UTC
May be it's a time to give up and make a new port(s) for boost 1.49? And 
leave the old port untouch. You should not change all ports that depend 
on the old version.
Comment 17 Andriy Gapon freebsd_committer 2012-03-03 14:35:52 UTC
Just a note that 1.49 has been released.

Regarding the exp-run results and this comment
http://www.freebsd.org/cgi/query-pr.cgi?pr=ports/156253#reply7 -  I think that the
number of the failing ports is sufficiently small and the current boost version is
sufficiently outdated to justify breaking those ports and putting onus on their
maintainers and upstreams.

I suspect that in some case just updating the ports to the latest upstreams could
fix the problems.


http://pointyhat.FreeBSD.org/errorlogs/amd64-errorlogs/a.8-exp.20120127093941/libreoffice-3.4.5.log
This bug report seems to describe the same issue and has fixes:
https://qa.mandriva.com/show_bug.cgi?id=64945
https://bugs.freedesktop.org/show_bug.cgi?id=43139

http://pointyhat.freebsd.org/errorlogs/amd64-errorlogs/a.8-exp.20120127093941/gstreamer-qt4-0.10.1_1.log
http://pointyhat.freebsd.org/errorlogs/amd64-errorlogs/a.8-exp.20120127093941/wesnoth-1.8.6.log
Googling for <error: 'boost::BOOST_FOREACH' has not been declared> provides a
number of recipes for a fix - the problem seems to be universally caused by
#define foreach BOOST_FOREACH somewhere in (non-boost) source code.

http://pointyhat.freebsd.org/errorlogs/amd64-errorlogs/a.8-exp.20120127093941/gstreamer-qt4-0.10.1_1.log
Again google helps (<Parse error at "BOOST_JOIN">):
https://bugreports.qt-project.org//browse/QTBUG-22829

Every problem seems to have a solution already.  We are not the first to use newer
boost :-)
But it's unreasonable to expect that a single person should fix all the problems
in advance.  The task should be parallelized among maintainers of the dependent
ports (and their users with hacking skills).

-- 
Andriy Gapon
Comment 18 Baptiste Daroussin freebsd_committer 2012-03-03 14:49:55 UTC
Responsible Changed
From-To: bapt->freebsd-port-bugs

back to the pool, sorry but pkgng is taking me too much time to finish 
working on this
Comment 19 linimon 2012-03-04 07:34:12 UTC
On Sat, Mar 03, 2012 at 04:35:52PM +0200, Andriy Gapon wrote:
> Re http://www.freebsd.org/cgi/query-pr.cgi?pr=ports/156253#reply7 -  I think that the
> number of the failing ports is sufficiently small

true, but ...
 
> http://pointyhat.FreeBSD.org/errorlogs/amd64-errorlogs/a.8-exp.20120127093941/libreoffice-3.4.5.log

This is a very high-profile port.  I would much rather see it fixed
before the boost update goes in, no matter how stale boost is.

Many of the other ports are either unmaintained, or have few dependencies,
but this one is a sticking point.

I'm willing to try another -exp to see if the latest version has fixed it.

> But it's unreasonable to expect that a single person should fix all the problems
> in advance.  The task should be parallelized among maintainers of the dependent
> ports (and their users with hacking skills).

OK.  I will forward your email to the following maintainers for comment:

aqsis-                  gahr@FreeBSD.org
cgal-                   wenheping@gmail.com
eiskaltdcpp-lib-        gelraen.ua@gmail.com
galaxyhack-             ports@FreeBSD.org
gigi-                   oliver@FreeBSD.org
gstreamer-qt4-          fluffy@FreeBSD.org
lander-                 amdmi3@FreeBSD.org
libYGP-                 ports@FreeBSD.org
libreoffice-            office@FreeBSD.org
libtorrent-rasterbar-   dougb@FreeBSD.org
luxrender-              danfe@FreeBSD.org
merkaartor-             dev2@heesakkers.info
mkvtoolnix-             multimedia@FreeBSD.org
openlierox-             amdmi3@FreeBSD.org
openvrml-               ports@FreeBSD.org
plee-the-bear-          amdmi3@FreeBSD.org
ros-common-             rene@FreeBSD.org
scribe-                 jnlin@csie.nctu.edu.tw
simgear-                martymac@FreeBSD.org
springlobby-            amdmi3@FreeBSD.org
wesnoth-                philip@FreeBSD.org

mcl
Comment 20 Ganael LAPLANCHE freebsd_committer 2012-03-05 08:36:34 UTC
On Sat, 03 Mar 2012 16:35:52 +0200, Andriy Gapon wrote

Hi Mark, hi Andriy,

> Just a note that 1.49 has been released.
>
> Regarding the exp-run results and this comment
> http://www.freebsd.org/cgi/query-pr.cgi?pr=ports/156253#reply7 
> -  I think that the number of the failing ports is 
> sufficiently small and the current boost version is 
> sufficiently outdated to justify breaking those ports and 
> putting onus on their maintainers and upstreams.
> [...]

Thanks for your mail.

Simgear 2.6.0 is out (and should hopefully build with latest boost) but
depends on graphics/osg >= 3.0.0 which is not yet available in ports. I
have contacted amdmi3@ ; he should be able to update the port soon. I'll
then update the Simgear + Flightgear ports.

If this update takes too much time, I'll try to fix current Simgear to
make it build with newer boost. Meanwhile, feel free to mark current
Simgear as BROKEN if this is necessary to have a newer boost in ports.

Best regards,

--
Ganael LAPLANCHE <ganael.laplanche@martymac.org>
http://www.martymac.org | http://contribs.martymac.org
FreeBSD: martymac <martymac@FreeBSD.org>, http://www.FreeBSD.org
Comment 21 Mark Linimon freebsd_committer 2012-03-05 08:50:10 UTC
Responsible Changed
From-To: freebsd-port-bugs->freebsd-ports-bugs

fix bogus assignment.
Comment 22 Oliver Heesakkers 2012-03-06 11:30:53 UTC
Thanks for the heads-up. I submitted an update for Merkaartor here:

http://www.freebsd.org/cgi/query-pr.cgi?pr=165767

This update removes the dependency on boost for Merkaartor.
Comment 23 Mark Linimon freebsd_committer 2012-03-09 04:40:11 UTC
State Changed
From-To: open->analyzed

take for -exp run. 


Comment 24 Mark Linimon freebsd_committer 2012-03-09 04:40:11 UTC
Responsible Changed
From-To: freebsd-ports-bugs->linimon
Comment 26 Mark Linimon freebsd_committer 2012-03-12 01:54:45 UTC
State Changed
From-To: analyzed->suspended

Results from first run: 

http://pointyhat-west.isc.freebsd.org/errorlogs/amd64-errorlogs/e.8-exp.20120309050246.pointyhat-west/ 

mark suspended awaiting updated patches for second run to fix 
devel/boost-libs among others.
Comment 27 Ganael LAPLANCHE freebsd_committer 2012-03-15 12:05:32 UTC
Hi Dmitry,

> graphics/osg update which is required to update simgear is ready:
> http://people.freebsd.org/~amdmi3/osg.patch

Thanks !

Simgear+Flightgear update is now also ready :

http://people.freebsd.org/~martymac/patches/20120315-patch-flightgear-2.6.0.txt

New Simgear builds fine with both old and new boost.

Best regards,

--
Ganael LAPLANCHE <ganael.laplanche@martymac.org>
http://www.martymac.org | http://contribs.martymac.org
FreeBSD: martymac <martymac@FreeBSD.org>, http://www.FreeBSD.org
Comment 28 alexanderchuranov 2012-04-26 17:55:55 UTC
Folks,

Let's try updating boost ports using this patch:
http://alexanderchuranov.com/boost-port/boost-145-to-148-v06.diff

As I know at present most dependent ports are either OK with newer
boost or have fixes by maintainers. In some cases it was suggested to
not pay any attention to failures (e.g. for libre office).

For this patch I've verified everything that I was able to.
Unfortunately it's not building every dependent package on every
supported FreeBSD version and architecture. I had hard time even
building direct dependencies on i386 and amd64 for 8.0.

That's why I suggest applying this patch now and fixing critical
issues as soon as they are detected. I am going to prepeare update to
most recent verision of Boost after that - it should be much easier
due to minor verison lag.

Alexander Churanov,
maintainer of devel/boost-*
Comment 29 Ganael LAPLANCHE freebsd_committer 2012-04-27 16:25:22 UTC
Hi,

> Simgear+Flightgear update is now also ready :
> [...]

FYI, I've committed the update to Simgear and Flightgear ; Simgear
should now build fine with new boost.

Best regards,

--
Ganael LAPLANCHE <ganael.laplanche@martymac.org>
http://www.martymac.org | http://contribs.martymac.org
FreeBSD: martymac <martymac@FreeBSD.org>, http://www.FreeBSD.org
Comment 30 Max Brazhnikov freebsd_committer 2012-04-27 22:00:38 UTC
On Thu, 26 Apr 2012 20:55:55 +0400, Alexander Churanov wrote:
> Folks,
> 
> Let's try updating boost ports using this patch:
> http://alexanderchuranov.com/boost-port/boost-145-to-148-v06.diff
> 
> As I know at present most dependent ports are either OK with newer
> boost or have fixes by maintainers. In some cases it was suggested to
> not pay any attention to failures (e.g. for libre office).
> 
> For this patch I've verified everything that I was able to.
> Unfortunately it's not building every dependent package on every
> supported FreeBSD version and architecture. I had hard time even
> building direct dependencies on i386 and amd64 for 8.0.

Alexander, thank you very much for you hard work!
however, you don't need to test all ports alone!

Mark, can you schedule new exp-run?

Cheers,
Max
Comment 31 Max Brazhnikov freebsd_committer 2012-05-01 16:49:46 UTC
State Changed
From-To: suspended->open

Request for exp-run with new patch: 
http://alexanderchuranov.com/boost-port/boost-145-to-148-v06.diff 


Comment 32 Max Brazhnikov freebsd_committer 2012-05-01 16:49:46 UTC
Responsible Changed
From-To: linimon->portmgr

Request for exp-run with new patch: 
http://alexanderchuranov.com/boost-port/boost-145-to-148-v06.diff
Comment 33 linimon 2012-05-03 04:07:03 UTC
On Fri, Apr 27, 2012 at 09:10:11PM +0000, Max Brazhnikov wrote:
>  Mark, can you schedule new exp-run?

I'll try to see if I can get this done before BSDCan.  No promises.

mcl
Comment 34 Mark Linimon freebsd_committer 2012-05-03 04:07:14 UTC
Responsible Changed
From-To: portmgr->linimon

try to pick this up for another run.
Comment 35 linimon 2012-05-11 19:16:34 UTC
Dear port meisters,

so what's holding back the boost upgrade?
Is there a hope that it is done by 9.1 release time?

-- 
Andriy Gapon
Comment 36 linimon 2012-05-11 19:16:59 UTC
I re-did it recently with the latest patches but wound up getting
on the plane for BSDCan before being able to analyze the results.
It will be a few more days before I can do that.

mcl
Comment 37 linimon 2012-05-11 20:28:01 UTC
OK, here are the results (hand-edited to remove things known to be
broken on some other build):

  http://pointyhat-west.isc.freebsd.org/errorlogs/amd64-8-exp-latest/index_edited.html

I'm not sure about graphics/raster3d.  Even though it doesn't fail
anywhere else that I see, it doesn't seem to have anything to do with
boost.  OTOH I don't have the cycles to analyze further today.  However,
a quick scan suggests the others are true positives for boost regressions.

I'd prefer to run another take with more patches, but if you think that
we're in more danger of drift as other commits come in in the meantime,
we could go ahead and do the commit and mark these ports as known-broken
in the meantime.  They do seem to have few dependencies.

mcl
Comment 38 Mark Linimon freebsd_committer 2012-05-11 20:29:59 UTC
State Changed
From-To: open->analyzed

Note that a new run has been completed and the errors analyzed (email 
to follow).
Comment 39 Andriy Gapon freebsd_committer 2012-05-11 20:53:46 UTC
on 11/05/2012 22:28 Mark Linimon said the following:
> OK, here are the results (hand-edited to remove things known to be
> broken on some other build):
> 
>   http://pointyhat-west.isc.freebsd.org/errorlogs/amd64-8-exp-latest/index_edited.html
> 
> I'm not sure about graphics/raster3d.  Even though it doesn't fail
> anywhere else that I see, it doesn't seem to have anything to do with
> boost.  OTOH I don't have the cycles to analyze further today.  However,
> a quick scan suggests the others are true positives for boost regressions.
> 
> I'd prefer to run another take with more patches, but if you think that
> we're in more danger of drift as other commits come in in the meantime,
> we could go ahead and do the commit and mark these ports as known-broken
> in the meantime.  They do seem to have few dependencies.

I can offer my help with fixing the post-commit damage.

-- 
Andriy Gapon
Comment 40 Max Brazhnikov freebsd_committer 2012-05-14 10:45:23 UTC
Responsible Changed
From-To: linimon->makc

I'll take it again.
Comment 41 dfilter freebsd_committer 2012-05-16 17:07:37 UTC
makc        2012-05-16 16:07:24 UTC

  FreeBSD ports repository

  Modified files:
    devel/boost-all      common.mk 
    devel/boost-docs     distinfo pkg-plist 
    devel/boost-jam      Makefile distinfo 
    devel/boost-libs     Makefile distinfo pkg-plist 
    devel/boost-libs/files 
                           patch-libs_filesystem__v3__src__path.cpp 
                           patch-tools_build_v2_tools_gcc.jam 
    devel/boost-python-libs Makefile distinfo 
    devel/boost-python-libs/files 
                                  patch-tools_build_v2_tools_gcc.jam 
  Added files:
    devel/boost-libs/files patch-boost-foreach.hpp 
                           patch-boost-foreach_fwd.hpp 
                           patch-boost_pool_pool.hpp 
                           patch-boostcpp.jam 
                           patch-tools_build_v2_engine_build.jam 
    devel/boost-python-libs/files patch-boostcpp.jam 
                                  patch-tools_build_v2_engine_build.jam 
  Removed files:
    devel/boost-libs/files patch-Jamroot 
                           patch-libs_random_src_random_device.cpp 
                           patch-tools_build_v2_engine_src_build.jam 
    devel/boost-python-libs/files patch-Jamroot 
                                  patch-tools_build_v2_engine_src_build.jam 
  Log:
  Update boost ports to 1.48.0
  
  PR:             ports/156253
  Submitted by:   Alexander Churanov (maintainer)
  Approved by:    portmgr (linimon)
  
  Revision  Changes     Path
  1.5       +1 -1       ports/devel/boost-all/common.mk
  1.6       +2 -2       ports/devel/boost-docs/distinfo
  1.5       +4493 -992  ports/devel/boost-docs/pkg-plist
  1.4       +4 -1       ports/devel/boost-jam/Makefile
  1.6       +2 -2       ports/devel/boost-jam/distinfo
  1.12      +0 -3       ports/devel/boost-libs/Makefile
  1.6       +2 -2       ports/devel/boost-libs/distinfo
  1.3       +0 -11      ports/devel/boost-libs/files/patch-Jamroot (dead)
  1.1       +16 -0      ports/devel/boost-libs/files/patch-boost-foreach.hpp (new)
  1.1       +40 -0      ports/devel/boost-libs/files/patch-boost-foreach_fwd.hpp (new)
  1.1       +11 -0      ports/devel/boost-libs/files/patch-boost_pool_pool.hpp (new)
  1.1       +11 -0      ports/devel/boost-libs/files/patch-boostcpp.jam (new)
  1.2       +5 -5       ports/devel/boost-libs/files/patch-libs_filesystem__v3__src__path.cpp
  1.2       +0 -11      ports/devel/boost-libs/files/patch-libs_random_src_random_device.cpp (dead)
  1.1       +11 -0      ports/devel/boost-libs/files/patch-tools_build_v2_engine_build.jam (new)
  1.2       +0 -11      ports/devel/boost-libs/files/patch-tools_build_v2_engine_src_build.jam (dead)
  1.2       +31 -13     ports/devel/boost-libs/files/patch-tools_build_v2_tools_gcc.jam
  1.5       +1626 -90   ports/devel/boost-libs/pkg-plist
  1.12      +0 -1       ports/devel/boost-python-libs/Makefile
  1.6       +2 -2       ports/devel/boost-python-libs/distinfo
  1.3       +0 -11      ports/devel/boost-python-libs/files/patch-Jamroot (dead)
  1.1       +11 -0      ports/devel/boost-python-libs/files/patch-boostcpp.jam (new)
  1.1       +11 -0      ports/devel/boost-python-libs/files/patch-tools_build_v2_engine_build.jam (new)
  1.2       +0 -11      ports/devel/boost-python-libs/files/patch-tools_build_v2_engine_src_build.jam (dead)
  1.3       +31 -13     ports/devel/boost-python-libs/files/patch-tools_build_v2_tools_gcc.jam
_______________________________________________
cvs-all@freebsd.org mailing list
http://lists.freebsd.org/mailman/listinfo/cvs-all
To unsubscribe, send any mail to "cvs-all-unsubscribe@freebsd.org"
Comment 42 dfilter freebsd_committer 2012-05-16 17:08:20 UTC
makc        2012-05-16 16:08:12 UTC

  FreeBSD ports repository

  Modified files:
    x11-toolkits/gigi    Makefile 
  Added files:
    x11-toolkits/gigi/files patch-GG-adobe-adam.hpp 
                            patch-GG-adobe-any_regular.hpp 
                            patch-GG-adobe-array.hpp 
                            patch-GG-adobe-closed_hash.hpp 
                            patch-GG-adobe-move.hpp 
                            patch-GG-adobe-string.hpp 
                            patch-GG-adobe-utility-pair.hpp 
                            patch-GG-adobe-vector.hpp 
                            patch-src-EveLayout.cpp 
  Log:
  Add patches to fix build with boost-1.48.0
  
  PR:             ports/156253
  Submitted by:   Alexander Churanov
  Approved by:    oliver (maintainer)
  
  Revision  Changes    Path
  1.32      +1 -1      ports/x11-toolkits/gigi/Makefile
  1.1       +20 -0     ports/x11-toolkits/gigi/files/patch-GG-adobe-adam.hpp (new)
  1.1       +29 -0     ports/x11-toolkits/gigi/files/patch-GG-adobe-any_regular.hpp (new)
  1.1       +11 -0     ports/x11-toolkits/gigi/files/patch-GG-adobe-array.hpp (new)
  1.1       +44 -0     ports/x11-toolkits/gigi/files/patch-GG-adobe-closed_hash.hpp (new)
  1.1       +20 -0     ports/x11-toolkits/gigi/files/patch-GG-adobe-move.hpp (new)
  1.1       +62 -0     ports/x11-toolkits/gigi/files/patch-GG-adobe-string.hpp (new)
  1.1       +17 -0     ports/x11-toolkits/gigi/files/patch-GG-adobe-utility-pair.hpp (new)
  1.1       +29 -0     ports/x11-toolkits/gigi/files/patch-GG-adobe-vector.hpp (new)
  1.1       +11 -0     ports/x11-toolkits/gigi/files/patch-src-EveLayout.cpp (new)
_______________________________________________
cvs-all@freebsd.org mailing list
http://lists.freebsd.org/mailman/listinfo/cvs-all
To unsubscribe, send any mail to "cvs-all-unsubscribe@freebsd.org"
Comment 43 dfilter freebsd_committer 2012-05-16 17:09:27 UTC
makc        2012-05-16 16:09:15 UTC

  FreeBSD ports repository

  Modified files:
    net-p2p/eiskaltdcpp-lib Makefile 
    net-p2p/libtorrent-rasterbar-14 Makefile 
    graphics/aqsis       Makefile 
    games/frogatto       Makefile 
    devel/sdts++         Makefile 
    devel/sdts++/files   patch-ab 
  Added files:
    net-p2p/eiskaltdcpp-lib/files patch-dcpp-Atomic.h 
    net-p2p/libtorrent-rasterbar-14/files 
                                          patch-include-libtorrent-create_torrent.hpp 
                                          patch-include-libtorrent-debug.hpp 
                                          patch-src-create_torrent.cpp 
                                          patch-src-file.cpp 
                                          patch-src-file_storage.cpp 
                                          patch-src-logger.cpp 
                                          patch-src-storage.cpp 
                                          patch-src-torrent_info.cpp 
    graphics/aqsis/files patch-libs-core-api-ri.cpp 
                         patch-libs-core-ddmanager-ddmanager.cpp 
                         patch-libs-core-geometry-blobby.cpp 
                         patch-libs-core-geometry-procedural.cpp 
                         patch-libs-core-renderer.cpp 
                         patch-libs-core-texturing_old-texturemap_old.cpp 
                         patch-libs-shadervm-dsoshadeops.cpp 
                         patch-libs-tex-io-exrinputfile.cpp 
                         patch-libs-tex-io-magicnumber.cpp 
                         patch-libs-tex-io-tiffdirhandle.cpp 
                         patch-libs-tex-io-zinputfile.cpp 
                         patch-libs-tex-maketexture-maketexture.cpp 
                         patch-tools-piqsl-displayserverimage.cpp 
                         patch-tools-piqsl-piqslmainwindow.cpp 
    games/frogatto/files patch-src-server.cpp 
    devel/sdts++/files   patch-configure.in 
                         patch-sdts++-io-sio_8211Converter.h 
  Log:
  Add patches to fix build with boost-1.48.0
  
  PR:             ports/156253
  Submitted by:   Alexander Churanov
  Approved by:    portmgr (linimon)
  
  Revision  Changes    Path
  1.27      +1 -1      ports/devel/sdts++/Makefile
  1.3       +5 -4      ports/devel/sdts++/files/patch-ab
  1.1       +31 -0     ports/devel/sdts++/files/patch-configure.in (new)
  1.1       +54 -0     ports/devel/sdts++/files/patch-sdts++-io-sio_8211Converter.h (new)
  1.9       +1 -1      ports/games/frogatto/Makefile
  1.1       +11 -0     ports/games/frogatto/files/patch-src-server.cpp (new)
  1.49      +1 -1      ports/graphics/aqsis/Makefile
  1.1       +44 -0     ports/graphics/aqsis/files/patch-libs-core-api-ri.cpp (new)
  1.1       +11 -0     ports/graphics/aqsis/files/patch-libs-core-ddmanager-ddmanager.cpp (new)
  1.1       +11 -0     ports/graphics/aqsis/files/patch-libs-core-geometry-blobby.cpp (new)
  1.1       +20 -0     ports/graphics/aqsis/files/patch-libs-core-geometry-procedural.cpp (new)
  1.1       +11 -0     ports/graphics/aqsis/files/patch-libs-core-renderer.cpp (new)
  1.1       +20 -0     ports/graphics/aqsis/files/patch-libs-core-texturing_old-texturemap_old.cpp (new)
  1.1       +18 -0     ports/graphics/aqsis/files/patch-libs-shadervm-dsoshadeops.cpp (new)
  1.1       +11 -0     ports/graphics/aqsis/files/patch-libs-tex-io-exrinputfile.cpp (new)
  1.1       +11 -0     ports/graphics/aqsis/files/patch-libs-tex-io-magicnumber.cpp (new)
  1.1       +11 -0     ports/graphics/aqsis/files/patch-libs-tex-io-tiffdirhandle.cpp (new)
  1.1       +11 -0     ports/graphics/aqsis/files/patch-libs-tex-io-zinputfile.cpp (new)
  1.1       +13 -0     ports/graphics/aqsis/files/patch-libs-tex-maketexture-maketexture.cpp (new)
  1.1       +13 -0     ports/graphics/aqsis/files/patch-tools-piqsl-displayserverimage.cpp (new)
  1.1       +11 -0     ports/graphics/aqsis/files/patch-tools-piqsl-piqslmainwindow.cpp (new)
  1.5       +1 -1      ports/net-p2p/eiskaltdcpp-lib/Makefile
  1.1       +25 -0     ports/net-p2p/eiskaltdcpp-lib/files/patch-dcpp-Atomic.h (new)
  1.47      +1 -1      ports/net-p2p/libtorrent-rasterbar-14/Makefile
  1.1       +11 -0     ports/net-p2p/libtorrent-rasterbar-14/files/patch-include-libtorrent-create_torrent.hpp (new)
  1.1       +11 -0     ports/net-p2p/libtorrent-rasterbar-14/files/patch-include-libtorrent-debug.hpp (new)
  1.1       +11 -0     ports/net-p2p/libtorrent-rasterbar-14/files/patch-src-create_torrent.cpp (new)
  1.1       +11 -0     ports/net-p2p/libtorrent-rasterbar-14/files/patch-src-file.cpp (new)
  1.1       +14 -0     ports/net-p2p/libtorrent-rasterbar-14/files/patch-src-file_storage.cpp (new)
  1.1       +11 -0     ports/net-p2p/libtorrent-rasterbar-14/files/patch-src-logger.cpp (new)
  1.1       +90 -0     ports/net-p2p/libtorrent-rasterbar-14/files/patch-src-storage.cpp (new)
  1.1       +11 -0     ports/net-p2p/libtorrent-rasterbar-14/files/patch-src-torrent_info.cpp (new)
_______________________________________________
cvs-all@freebsd.org mailing list
http://lists.freebsd.org/mailman/listinfo/cvs-all
To unsubscribe, send any mail to "cvs-all-unsubscribe@freebsd.org"
Comment 44 Max Brazhnikov freebsd_committer 2012-05-16 17:11:47 UTC
State Changed
From-To: analyzed->closed

Committed. Thanks!