Bug 156442 - [MAINTAINER-UPDATE] from net-mgmt/vidalia 0.2.10 to 0.2.12
Summary: [MAINTAINER-UPDATE] from net-mgmt/vidalia 0.2.10 to 0.2.12
Status: Closed FIXED
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: Normal Affects Only Me
Assignee: Beech Rintoul
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2011-04-16 13:30 UTC by Fabian Keil
Modified: 2011-04-19 17:30 UTC (History)
0 users

See Also:


Attachments
file.diff (1.06 KB, patch)
2011-04-16 13:30 UTC, Fabian Keil
no flags Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Fabian Keil 2011-04-16 13:30:10 UTC
The attached patch updates net-mgmt/vidalia from 0.2.10 to 0.2.12.
As far as I can tell there was no stable 0.2.11 release.

The ChangeLog is available at:
https://blog.torproject.org/blog/vidalia-0212-released

It mentions the following FreeBSD-specific change:
| Remove Vidalia's direct dependency on OpenSSL. This dependency had
| caused Vidalia to fail to run on FreeBSD (due to a bug in the FreeBSD
| ports collection) and Fedora 14 (due to an incompatibility between
| OpenSSL and Fedora's SELinux configuration). Resolves bug 2287 and 2611.

The ticket URL is:
https://trac.torproject.org/projects/tor/ticket/2287

I haven't experienced the problem myself and haven't
heard about the problem before either.

Note that due to a recent Qt change Vidalia may dump core on
exit when build with WITH_DEBUG=yes. I'll look into this,
but as the problem is present in 0.2.10, too, I see no reason
why this should block the update.

Fix: Patch attached with submission follows:
Comment 1 Edwin Groothuis freebsd_committer 2011-04-16 13:30:24 UTC
Class Changed
From-To: sw-bug->maintainer-update

Fix category (submitter is maintainer) (via the GNATS Auto Assign Tool)
Comment 2 Beech Rintoul freebsd_committer 2011-04-17 01:30:19 UTC
Responsible Changed
From-To: freebsd-ports-bugs->beech

I'll take it
Comment 3 dfilter service freebsd_committer 2011-04-19 17:28:52 UTC
beech       2011-04-19 16:28:37 UTC

  FreeBSD ports repository

  Modified files:
    net-mgmt/vidalia     Makefile distinfo 
  Log:
  Update to 0.2.12
  
  The ChangeLog is available at:
  https://blog.torproject.org/blog/vidalia-0212-released
  
  PR:             ports/156442
  Submitted by:   Fabian Keil (fk@fabiankeil.de) (maintainer)
  Approved by:    itetcu (mentor)(explicit)
  
  Revision  Changes    Path
  1.25      +2 -2      ports/net-mgmt/vidalia/Makefile
  1.17      +2 -2      ports/net-mgmt/vidalia/distinfo
_______________________________________________
cvs-all@freebsd.org mailing list
http://lists.freebsd.org/mailman/listinfo/cvs-all
To unsubscribe, send any mail to "cvs-all-unsubscribe@freebsd.org"
Comment 4 Beech Rintoul freebsd_committer 2011-04-19 17:29:24 UTC
State Changed
From-To: open->closed

Committed, Thanks!