Bug 156876 - update to comms/uarduno port for 9.0-CURRENT
Summary: update to comms/uarduno port for 9.0-CURRENT
Status: Closed FIXED
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: Normal Affects Only Me
Assignee: freebsd-ports-bugs mailing list
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2011-05-08 09:50 UTC by Bob Frazier
Modified: 2011-08-08 20:40 UTC (History)
0 users

See Also:


Attachments
file.shar (6.72 KB, text/plain)
2011-05-08 09:50 UTC, Bob Frazier
no flags Details
uarduno.shar.txt (6.72 KB, text/plain)
2011-07-05 20:55 UTC, Bob Frazier
no flags Details
uarduno.patch.txt (1.12 KB, text/plain)
2011-07-29 03:49 UTC, Bob Frazier
no flags Details
uarduno.1.02a.patch.txt (1.35 KB, text/plain)
2011-07-29 04:17 UTC, Bob Frazier
no flags Details

Note You need to log in before you can comment on or make changes to this bug.
Description Bob Frazier 2011-05-08 09:50:07 UTC
version 1.0 will not build properly on 9.0-CURRENT .  This update to the comms/uarduno port includes updated source that addresses the build issue.  Updated source is reported to have worked properly under 9.0-CURRENT.  Port revision bump to 1.01 .

Fix: see attached 'shar' archive for update

Patch attached with submission follows:
Comment 1 Bob Frazier 2011-07-05 20:55:41 UTC
Port NOW fails to build on 8-CURRENT.  This is caused by a change to 
8-CURRENT source at the same time the PR was submitted (8-STABLE API now 
matches 9-CURRENT), requiring another update to correct build errors on 
8-STABLE as well as 9-CURRENT.  New SHAR file attached, new source 
available online.  Please use the new SHAR file and not the one 
previously submitted.  Version bump to 1.02 .

also request priority change from medium to high since it now affects 
8-CURRENT as well.

NEW shar file attached
Comment 2 Chris Rees freebsd_committer 2011-07-28 22:12:12 UTC
Hi,

Please would you post a patch, not a shar?

You can do this by:

# cd ~/where_I_kept_the_port
# diff -ruN /usr/ports/comms/uarduno . >~/patch.txt

Chris
Comment 3 Bob Frazier 2011-07-29 03:49:39 UTC
submitting patch file (existing version is left-hand file, updated 
version is right-hand file)
Comment 4 Bob Frazier 2011-07-29 04:17:45 UTC
slightly modified patch, includes another bug fix (added NO_MTREE=yes to 
Makefile).  Please use THIS patch, thanks.

Comment 5 Tilman Keskinoz freebsd_committer 2011-08-08 20:37:51 UTC
State Changed
From-To: open->closed

committed, thanks!
Comment 6 dfilter service freebsd_committer 2011-08-08 20:37:53 UTC
arved       2011-08-08 19:37:29 UTC

  FreeBSD ports repository

  Modified files:
    comms/uarduno        Makefile distinfo 
  Log:
  Update to 1.02
  
  PR:             156876
  Submitted by:   maintainer
  
  Revision  Changes    Path
  1.2       +5 -2      ports/comms/uarduno/Makefile
  1.2       +2 -2      ports/comms/uarduno/distinfo
_______________________________________________
cvs-all@freebsd.org mailing list
http://lists.freebsd.org/mailman/listinfo/cvs-all
To unsubscribe, send any mail to "cvs-all-unsubscribe@freebsd.org"