Bug 157275 - www/webkit-gtk2 does not install
Summary: www/webkit-gtk2 does not install
Status: Closed FIXED
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: Normal Affects Only Me
Assignee: freebsd-gnome (Nobody)
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2011-05-23 18:30 UTC by hardy.schumacher
Modified: 2011-05-28 00:30 UTC (History)
0 users

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description hardy.schumacher 2011-05-23 18:30:10 UTC
While installing all ports new (incl. xorg and gnome2) webkit-gtk2 breaks up with following error:
===>  Building for webkit-gtk2-1.2.7_1
  GEN    DerivedSources/HTMLElementFactory.cpp
Can't locate Switch.pm in @INC (@INC contains: ./WebCore/bindings/scripts /usr/local/lib/perl5/5.14.0/BSDPAN /usr/local/lib/perl5/site_perl/5.14.0/mach /usr/local/lib/perl5/site_perl/5.14.0 /usr/local/lib/perl5/5.14.0/mach /usr/local/lib/perl5/5.14.0 .) at WebCore/dom/make_names.pl line 38.
BEGIN failed--compilation aborted at WebCore/dom/make_names.pl line 38.
gmake: *** [DerivedSources/HTMLElementFactory.cpp] Error 2

Fix: 

n/a
How-To-Repeat: Install perl-5.14, xorg, gnome2 from scratch.
The error occurs always.
Comment 1 Edwin Groothuis freebsd_committer 2011-05-23 18:30:21 UTC
Responsible Changed
From-To: freebsd-ports-bugs->gnome

Over to maintainer (via the GNATS Auto Assign Tool)
Comment 2 Matthias Andree freebsd_committer 2011-05-28 00:21:56 UTC
State Changed
From-To: open->closed

Duplicate of ports/157236
Comment 3 dfilter service freebsd_committer 2011-05-28 00:29:16 UTC
mandree     2011-05-27 23:28:59 UTC

  FreeBSD ports repository

  Modified files:
    www/webkit-gtk2      Makefile 
  Log:
  Fix build with Perl >= 5.14.
  
  Perl 5.14 has deprecated Switch.pm, as announced since Perl 5.10.1.
  The webkit build script requires Switch though, so add it to BUILD_DEPENDS on
  newer Perl versions.
  
  Submitted by: Christoph Moench-Tegeder (including patch) [1]
  Approved by:  Jeremy Messenger (mezz@) in
      http://lists.freebsd.org/pipermail/freebsd-gnome/2011-May/026025.html
  PR:           ports/157236 [1]
  PR:           ports/157275 (duplicate by Hardy Schumacher)
  PR:           ports/157288 (copy of 157236)
  
  Revision  Changes    Path
  1.39      +4 -0      ports/www/webkit-gtk2/Makefile
_______________________________________________
cvs-all@freebsd.org mailing list
http://lists.freebsd.org/mailman/listinfo/cvs-all
To unsubscribe, send any mail to "cvs-all-unsubscribe@freebsd.org"