Bug 157288 - fix build of www/webkit-gtk2 with perl 5.14
Summary: fix build of www/webkit-gtk2 with perl 5.14
Status: Closed FIXED
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: Normal Affects Only Me
Assignee: freebsd-gnome (Nobody)
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2011-05-24 09:50 UTC by Jacques
Modified: 2011-05-28 00:30 UTC (History)
0 users

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Jacques 2011-05-24 09:50:05 UTC
As mentioned in the Perl 5.10.1 release notes (perl5101delta(1)) and the 5.14.0 release notes (perl5140delta(1)) Switch.pm was deprecated and removed from the core perl distribution. www/webkit-gtk2 ships with a build script requiring Switch.pm, so we need lang/p5-Switch when building with perl 5.14.0.

This also happens on chromium (see PR 157237) and could happen on other ports.

Fix: 

Add the following lines to Makefile

.if ${PERL_LEVEL} >= 501400
BUILD_DEPENDS+=	p5-Switch>=0:${PORTSDIR}/lang/p5-Switch
.endif
How-To-Repeat: Upgrade to perl 5.14 and try to build webkit-gtk2
Comment 1 Edwin Groothuis freebsd_committer 2011-05-24 09:50:14 UTC
Responsible Changed
From-To: freebsd-ports-bugs->gnome

Over to maintainer (via the GNATS Auto Assign Tool)
Comment 2 Matthias Andree freebsd_committer 2011-05-28 00:21:33 UTC
State Changed
From-To: open->closed

Duplicate of ports/157236.
Comment 3 dfilter service freebsd_committer 2011-05-28 00:29:16 UTC
mandree     2011-05-27 23:28:59 UTC

  FreeBSD ports repository

  Modified files:
    www/webkit-gtk2      Makefile 
  Log:
  Fix build with Perl >= 5.14.
  
  Perl 5.14 has deprecated Switch.pm, as announced since Perl 5.10.1.
  The webkit build script requires Switch though, so add it to BUILD_DEPENDS on
  newer Perl versions.
  
  Submitted by: Christoph Moench-Tegeder (including patch) [1]
  Approved by:  Jeremy Messenger (mezz@) in
      http://lists.freebsd.org/pipermail/freebsd-gnome/2011-May/026025.html
  PR:           ports/157236 [1]
  PR:           ports/157275 (duplicate by Hardy Schumacher)
  PR:           ports/157288 (copy of 157236)
  
  Revision  Changes    Path
  1.39      +4 -0      ports/www/webkit-gtk2/Makefile
_______________________________________________
cvs-all@freebsd.org mailing list
http://lists.freebsd.org/mailman/listinfo/cvs-all
To unsubscribe, send any mail to "cvs-all-unsubscribe@freebsd.org"