Bug 157673 - [update] audio/sox to 14.3.2
Summary: [update] audio/sox to 14.3.2
Status: Closed FIXED
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: Normal Affects Only Me
Assignee: Wesley Shields
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2011-06-07 00:40 UTC by Ryan Steinmetz
Modified: 2011-06-11 03:50 UTC (History)
0 users

See Also:


Attachments
file.diff (1.29 KB, patch)
2011-06-07 00:40 UTC, Ryan Steinmetz
no flags Details | Diff
sox.patch (4.49 KB, patch)
2011-06-08 17:48 UTC, Dan Nelson
no flags Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Ryan Steinmetz 2011-06-07 00:40:06 UTC
- Update to 14.3.2

=======================================

sox-14.3.2      2011-02-27
----------

File formats:

  o Add seek support to mp3 handler for speed improvements.  (Pavel Karneliuk)
  o Fix bug were WavPack header was not updated correctly when closing
    file.  Fixed libsox memory leak when closing WavPack files.
    (David Bryant)
  o Fix RIFF chunk length error when writing 24-bit files. (David Bryant)
  o 24-bit WAV files were leaving channel maps unassigned. Change to use
    common channel mappings based on channel count.  This allows to
    work more seemlessly with other apps such as WavPack and Foobar2000.
    (David Bryant)
  o Fix ffmpeg playback bug caused by alignment requirements on some platforms.
    Closes bug #3017690.  (Reuben Thomas).
  o Fix memory leak in ffmpeg. (Doug Cook)
  o Handle 0 length chunks in WAV files gracefully.  (Beat Jorg)
  o When skipping over chunks, account for word alignment. Helps
    with some Logic Pro generated files.  (D Lambley)
  o Fix incorrect MP3 file length determination with VBR & .5s initial
    silence.  (robs)

Audio device drivers:

  o Fix immediate segfault on OSX while attempting to record. (Adam Fritzler)
  o Fix segfault on OSX playback for some HW that gives smaller then
    requested buffers. (cbagwell)
  o Clean up system resource in coreaudio on close.  Allows running
    back-to-back open()/close()'s without exiting app first. (cbagwell)
  o Add support for 32-bit samples to OSS driver. (Eric Lammerts)
  o Add support for 24 and 32-bit samples to waveaudio (Win32) driver.
    (Doug Cook)
  o Support specifying audio device other than default on OSX (cbagwell)

Effects:

  o F.R. [3051700] spectrogram -r for `raw' spectrogram, no legend.  (robs)
  o Fix -w option on stats effect. (Ronald Sprouse)
  o Fix segfault with some ladspa plugins (Thor Andreassen)
  o Optionally look for png.h in libpng directory to support OpenBSD
    packaging.  Helps enable spectrograph effect. (cbagwell)
  o libpng15 requires application to include zlib.h header file. (cbagwell)
    Add this to spectrograph effect. [3184238]
  o Enable LADSPA effects on all platforms without any external
    dependencies.  Mainly useful for Linux, Windows and OS X which have
    binaries readily available. (cbagwell)
  o Support specifying an absolute end location for trim effect instead
    only an offset from trim begin location. (Ulrich Klauer)
  o Fix regression where MP3 handler required libmad headers to be installed.
    (Samuli Suominen) 
  o Allow dynamic loading of lame to be enabled even if lame header files
    are not installed.  (Doug Cook)

Other new features:

  o Soxi now reports duration of AMR files.  (robs)
  o Document the "multiple" combine option in man pages and in
    usage output (Ulrich Klauer).

Internal improvements:

  o Distribute msvc9 project files that had been in CVS only. (cbagwell)
  o Add msvc10 project files (also compatible with the Windows SDK 7.1).
    (Doug Cook)
  o cmake now compiles waveaudio driver under windows environment. (cbagwell)
    [3072672]

Fix: Patch attached with submission follows:
Comment 1 Edwin Groothuis freebsd_committer 2011-06-07 00:40:14 UTC
Maintainer of audio/sox,

Please note that PR ports/157673 has just been submitted.

If it contains a patch for an upgrade, an enhancement or a bug fix
you agree on, reply to this email stating that you approve the patch
and a committer will take care of it.

The full text of the PR can be found at:
    http://www.freebsd.org/cgi/query-pr.cgi?pr=ports/157673

-- 
Edwin Groothuis via the GNATS Auto Assign Tool
edwin@FreeBSD.org
Comment 2 Edwin Groothuis freebsd_committer 2011-06-07 00:40:16 UTC
State Changed
From-To: open->feedback

Awaiting maintainers feedback (via the GNATS Auto Assign Tool)
Comment 3 Wesley Shields freebsd_committer 2011-06-07 00:46:50 UTC
Responsible Changed
From-To: freebsd-ports-bugs->wxs

I'll take it.
Comment 4 Dan Nelson 2011-06-08 17:48:03 UTC
Here's a better patch:

+ update to 14.3.2 and add LICENSE, as in the original patch

+ Remove CPPFLAGS="${CPPFLAGS}" from CONFIGURE_ENV, since as of 2011-03-20
  the ports system does this for you.  Note: += syntax is not valid in
  CONFIGURE_ENV.

+ disable some more autoconf checks when WITH_GSM=no; sox was still finding
  libgsm.so if it existed.

+ remove the #include path fixups of gsm.h and libavformat.h; they're not
  needed anymore.

+ add files/patch-ffmpeg , to allow sox to build if the ffmpeg-devel is
  installed.


-- 
	Dan Nelson
	dnelson@allantgroup.com
Comment 5 dfilter service freebsd_committer 2011-06-11 03:47:59 UTC
wxs         2011-06-11 02:47:50 UTC

  FreeBSD ports repository

  Modified files:
    audio/sox            Makefile distinfo 
  Added files:
    audio/sox/files      patch-ffmpeg 
  Log:
  - Update to 14.3.2.
  - Add LICENSE.
  - Add a patch to fix build if ffmpeg-devel is installed.
  
  PR:             ports/157673
  Submitted by:   Ryan Steinmetz <rpsfa@rit.edu>
  Approved by:    Dan Nelson <dnelson@allantgroup.com> (maintainer)
  
  Revision  Changes    Path
  1.54      +7 -11     ports/audio/sox/Makefile
  1.23      +2 -2      ports/audio/sox/distinfo
  1.1       +55 -0     ports/audio/sox/files/patch-ffmpeg (new)
_______________________________________________
cvs-all@freebsd.org mailing list
http://lists.freebsd.org/mailman/listinfo/cvs-all
To unsubscribe, send any mail to "cvs-all-unsubscribe@freebsd.org"
Comment 6 Wesley Shields freebsd_committer 2011-06-11 03:48:01 UTC
State Changed
From-To: feedback->closed

Committed. Thanks!