Bug 158826 - Can't install java/icedtea-web
Can't install java/icedtea-web
Status: Closed FIXED
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s)
Latest
Any Any
: Normal Affects Only Me
Assigned To: FreeBSD Java mailing list
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2011-07-12 08:40 UTC by timp87
Modified: 2011-08-31 21:19 UTC (History)
0 users

See Also:


Attachments
ice.diff (2.45 KB, patch)
2011-07-12 11:53 UTC, Guido Falsi
no flags Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description timp87 2011-07-12 08:40:07 UTC
Hello!
Can't install java/icedtea-web

[root@timbsd]# portmaster java/icedtea-web
.......
===>  Installing for icedtea-web-1.1
===>   Generating temporary packing list
===>  Checking if java/icedtea-web already installed
gmake[1]: Entering directory `/usr/ports/java/icedtea-web/work/icedtea-web-1.1'
/bin/sh /usr/ports/java/icedtea-web/work/icedtea-web-1.1/install-sh -d /usr/local/bin /usr/local/share/icedtea-web/ /usr/local/lib
install  -s -o root -g wheel -m 555 /usr/ports/java/icedtea-web/work/icedtea-web-1.1/plugin/icedteanp/IcedTeaPlugin.so /usr/local/lib
/usr/local/bin/ginstall /usr/ports/java/icedtea-web/work/icedtea-web-1.1/liveconnect/lib/classes.jar /usr/local/share/icedtea-web/plugin.jar
/usr/local/bin/ginstall /usr/ports/java/icedtea-web/work/icedtea-web-1.1/netx.build/lib/classes.jar /usr/local/share/icedtea-web/netx.jar
install  -s -o root -g wheel -m 555 launcher.build/javaws /usr/local/bin
strip: /usr/local/bin/javaws: File format not recognized
install: wait: No such file or directory
gmake[1]: *** [install-exec-local] Error 70
gmake[1]: Leaving directory `/usr/ports/java/icedtea-web/work/icedtea-web-1.1'
gmake: *** [install-am] Error 2
*** Error code 2

Stop in /usr/ports/java/icedtea-web.
*** Error code 1

Stop in /usr/ports/java/icedtea-web.

===>>> Installation of icedtea-web-1.1 (java/icedtea-web) failed
===>>> Aborting update


===>>> You can restart from the point of failure with this command line:
       portmaster <flags> java/icedtea-web


[root@timbsd /usr/ports/java/icedtea-web]# make showconfig
===> The following configuration options are available for icedtea-web-1.1:
     PLUGIN=on "Enable the browser plug-in"
     RHINO=off "Add support for Proxy Auto Config files"
     TEST=off "Add support for running regression test"
===> Use 'make config' to modify these settings

[root@timbsd /usr/ports/java/openjdk6]# pkg_info | grep openjdk6
openjdk6-b23        Oracle's Java 6 virtual machine release under the GPL v2

[root@timbsd /usr/ports/java/openjdk6]# make showconfig
===> The following configuration options are available for openjdk6-b23:
     DEBUG=off "Enable legacy debugging support"
     FASTDEBUG=off "Include fastdebug build"
     ICEDTEA=on "Apply additional patches from IcedTea"
     IPV6=off "Enable IPv6 support"
     POLICY=on "Install the Unlimited Strength Policy Files"
     SOUND=on "Enable sound support"
     TEST=off "Add support for running regression test"
===> Use 'make config' to modify these settings
Comment 1 Edwin Groothuis freebsd_committer 2011-07-12 08:40:18 UTC
Responsible Changed
From-To: freebsd-ports-bugs->freebsd-java

Over to maintainer (via the GNATS Auto Assign Tool)
Comment 2 Guido Falsi freebsd_committer 2011-07-12 11:53:26 UTC
The port is trying to strip shell scripts, which fails.

Attached patch fixes this by patching the Makefie not to strip shell
scripts.

-- 
Guido Falsi <mad@madpilot.net>
Comment 3 timp87 2011-07-12 13:27:19 UTC
It works good. Thanks!
Comment 4 glewis 2011-07-12 16:03:25 UTC
On Tue, Jul 12, 2011 at 11:00:22AM +0000, Guido Falsi wrote:
>  The port is trying to strip shell scripts, which fails.
>  
>  Attached patch fixes this by patching the Makefie not to strip shell
>  scripts.

It's worse than just that.  It's going to overwrite the symlink for javaws
the javavm port creates in ${LOCALBASE}/bin if you have a port (e.g. jdk16)
which actually does install javaws installed.

This didn't happen previously since the IcedTea javaws was installed in
${LOCALBASE}/openjdk6/bin and could be chosen by javavm just like any
other alternative.

-- 
Greg Lewis                          Email   : glewis@eyesbeyond.com
Eyes Beyond                         Web     : http://www.eyesbeyond.com
Information Technology              FreeBSD : glewis@FreeBSD.org
Comment 5 Jung-uk Kim freebsd_committer 2011-07-12 18:26:41 UTC
On Tuesday 12 July 2011 11:30 am, Greg Lewis wrote:
> The following reply was made to PR ports/158826; it has been noted
> by GNATS.
>
> From: Greg Lewis <glewis@eyesbeyond.com>
> To: bug-followup@FreeBSD.org
> Cc:
> Subject: Re: ports/158826: Can't install java/icedtea-web
> Date: Tue, 12 Jul 2011 08:03:25 -0700
>
>  On Tue, Jul 12, 2011 at 11:00:22AM +0000, Guido Falsi wrote:
>  >  The port is trying to strip shell scripts, which fails.
>  >
>  >  Attached patch fixes this by patching the Makefie not to strip
>  > shell scripts.
>
>  It's worse than just that.  It's going to overwrite the symlink
> for javaws the javavm port creates in ${LOCALBASE}/bin if you have
> a port (e.g. jdk16) which actually does install javaws installed.
>
>  This didn't happen previously since the IcedTea javaws was
> installed in ${LOCALBASE}/openjdk6/bin and could be chosen by
> javavm just like any other alternative.

Yeah, you're right.  I forgot the symlinks. :-(

I am going to rename it to itweb-javaws with other fixes.

Jung-uk Kim
Comment 6 dfilter freebsd_committer 2011-07-12 20:21:11 UTC
jkim        2011-07-12 19:21:03 UTC

  FreeBSD ports repository

  Modified files:
    java/icedtea-web     Makefile 
    java/icedtea-web/files patch-Makefile.in 
  Added files:
    java/icedtea-web/files patch-launcher-javaws.in 
  Log:
  Fix various build and installation issues.
  
  - Replace various Linuxisms in Makefile with little more portable code.
  Remove now unnecessary build dependency of sysutils/coreutils.
  - Install launcher wrappers with INSTALL_SCRIPT[1].
  - Rename javaws launcher to itweb-javaws throughout.  This conflicts with
  a symlink created by java/javavmwrapper[2].
  
  PR:             ports/158826 [1]
  Reported by:    glewis [2]
  
  Revision  Changes    Path
  1.4       +11 -10    ports/java/icedtea-web/Makefile
  1.2       +138 -7    ports/java/icedtea-web/files/patch-Makefile.in
  1.1       +11 -0     ports/java/icedtea-web/files/patch-launcher-javaws.in (new)
_______________________________________________
cvs-all@freebsd.org mailing list
http://lists.freebsd.org/mailman/listinfo/cvs-all
To unsubscribe, send any mail to "cvs-all-unsubscribe@freebsd.org"
Comment 7 Jung-uk Kim freebsd_committer 2011-08-31 21:18:02 UTC
State Changed
From-To: open->closed

This problem was fixed some time ago.